extra/firefox to 33.1.1-1.1

fixes #935
This commit is contained in:
Kevin Mihelich 2014-12-01 03:34:18 +00:00
parent 8cf4b8c23b
commit aa4b09218d
2 changed files with 37 additions and 3 deletions

View file

@ -4,12 +4,13 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building webrtc
# - patch to fix downloads (https://bugzilla.mozilla.org/show_bug.cgi?id=1050258)
buildarch=20
pkgname=firefox
pkgver=33.1.1
pkgrel=1
pkgrel=1.1
pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
@ -28,7 +29,8 @@ options=('!emptydirs' '!makeflags')
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2{,.asc}
mozconfig firefox.desktop firefox-install-dir.patch vendor.js rhbz-966424.patch
firefox-fixed-loading-icon.png
arm-webrtc-fix.patch)
arm-webrtc-fix.patch
arm-download-fix.patch)
sha256sums=('ce67fab494acb56b9dc18896e9ea481b1a1ba61ca88ce3438f96d21cc554b9a9'
'SKIP'
'ffcb2a0ba2ed08f74931a11043717391ef380234cadccc6f0c13f1186ad80e8b'
@ -37,7 +39,8 @@ sha256sums=('ce67fab494acb56b9dc18896e9ea481b1a1ba61ca88ce3438f96d21cc554b9a9'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'6f81cd3c1d5d96aaeae9882cc24da4fd42ff7ebf25113d9516d5e7c94d375090')
'6f81cd3c1d5d96aaeae9882cc24da4fd42ff7ebf25113d9516d5e7c94d375090'
'a1fb0067e665af22d5e7bff5623fd85b89491c8f222a6f8eaca07c81b624454e')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@ -78,6 +81,9 @@ prepare() {
# Fix webrtc build on ARM
patch -Np0 -i ../arm-webrtc-fix.patch
# Fix downloading on ARM
patch -Np1 -i ../arm-download-fix.patch
}
build() {

View file

@ -0,0 +1,28 @@
# HG changeset patch
# User Douglas Crosher <dtc-moz@scieneer.com>
# Date 1415349848 -39600
# Fri Nov 07 19:44:08 2014 +1100
# Node ID b98d6205da98b5bec30b0677c30a6d09f351f4b8
# Parent 17e19083908620e8a83876e49bac6f6ba2fcc272
Bug 1050258 - ARM hard-float XPCOM: correct argument passing.
diff --git a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
--- a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
+++ b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
@@ -219,16 +219,17 @@ static inline void copy_dword(uint32_t*
{
if (ireg_args + 1 < end) {
if ((uint32_t)ireg_args & 4) {
ireg_args++;
}
*(uint64_t *)ireg_args = data;
ireg_args += 2;
} else {
+ ireg_args = end;
if ((uint32_t)stack_args & 4) {
stack_args++;
}
*(uint64_t *)stack_args = data;
stack_args += 2;
}
}