Added extra/cln

This commit is contained in:
Kevin Mihelich 2011-01-23 13:45:48 -05:00
parent e520e13d89
commit aa6717500b
5 changed files with 130 additions and 0 deletions

6
extra/cln/ChangeLog Normal file
View file

@ -0,0 +1,6 @@
2009-06-09 Eric Belanger <eric@archlinux.org>
* Added info page
* Fixed docs location
* Added gcc 4.4 patch (close FS#15015)
* Added ChangeLog

40
extra/cln/PKGBUILD Normal file
View file

@ -0,0 +1,40 @@
# $Id: PKGBUILD 72798 2010-03-20 03:28:40Z allan $
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Ben <ben@benmazer.net>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# - Added patch to fix compiling on ARM
# Source: https://bugzilla.redhat.com/show_bug.cgi?id=517478
plugrel=1
pkgname=cln
pkgver=1.2.2
pkgrel=3
pkgdesc="Class library for numbers"
arch=('i686' 'x86_64')
url="http://www.ginac.de/CLN/"
license=('GPL')
options=('!libtool')
depends=('gmp' 'bash' 'texinfo')
install=cln.install
source=(ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${pkgname}-${pkgver}.tar.bz2
cln-gcc44.patch
cln-arm-preprocessor-fix.patch)
md5sums=('6b479281fec86314b4c7a9357bd83ef8'
'aa678ade85c1e364c879b2e0b40ba80d'
'9bb1177b2462d071236acc15ba615e76')
sha1sums=('2d2a5d3e383a3043c5bf68299a466685ef4ec8ec'
'6abb412a387ba8d27a6a80f963a55677e431daf8'
'5322ed672f623218a7b608e9429e6d7d191b5b75')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < ../cln-gcc44.patch || return 1
patch -p1 -i ${srcdir}/cln-arm-preprocessor-fix.patch || return 1
./configure --prefix=/usr || return 1
make || return 1
make DESTDIR="${pkgdir}" htmldir=/usr/share/doc/cln/html dvidir=/usr/share/doc/cln/dvi install || return 1
rm "${pkgdir}/usr/share/info/dir"
gzip "${pkgdir}/usr/share/info/cln.info"
}

View file

@ -0,0 +1,14 @@
diff -dur cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc
--- cln-1.2.2.backup/src/base/digitseq/cl_asm_arm_.cc 2001-05-25 16:00:18.000000000 -0400
+++ cln-1.2.2/src/base/digitseq/cl_asm_arm_.cc 2009-08-14 12:23:31.000000000 -0400
@@ -77,8 +77,8 @@
#else
#define DECLARE_FUNCTION(x)
#endif
-#define GLABEL(x) _##x##:
-#define LABEL(x) x##:
+#define GLABEL(x) _##x:
+#define LABEL(x) x:
#define RRX rrx
#define END

50
extra/cln/cln-gcc44.patch Normal file
View file

@ -0,0 +1,50 @@
--- ./src/base/string/input/cl_st_get1.cc~ 2000-12-14 11:53:06.000000000 -0500
+++ ./src/base/string/input/cl_st_get1.cc 2009-06-07 16:36:45.681507023 -0400
@@ -1,6 +1,7 @@
// cl_fget().
// General includes.
+#include <cstdio>
#include "cl_sysdep.h"
// Specification.
--- ./src/base/string/input/cl_st_get2.cc~ 2000-12-14 11:53:06.000000000 -0500
+++ ./src/base/string/input/cl_st_get2.cc 2009-06-07 16:52:15.291008894 -0400
@@ -1,6 +1,7 @@
// cl_fget().
// General includes.
+#include <cstdio>
#include "cl_sysdep.h"
// Specification.
--- ./src/base/string/input/cl_st_getline1.cc~ 2000-12-14 11:53:06.000000000 -0500
+++ ./src/base/string/input/cl_st_getline1.cc 2009-06-08 19:18:18.815843098 -0400
@@ -1,6 +1,7 @@
// cl_fgetline().
// General includes.
+#include <cstdio>
#include "cl_sysdep.h"
// Specification.
--- ./src/base/string/input/cl_st_getline2.cc~ 2000-12-14 11:53:06.000000000 -0500
+++ ./src/base/string/input/cl_st_getline2.cc 2009-06-08 19:18:12.899175378 -0400
@@ -1,6 +1,7 @@
// cl_fgetline().
// General includes.
+#include <cstdio>
#include "cl_sysdep.h"
// Specification.
--- ./src/base/string/input/cl_st_gettoken.cc~ 2004-06-23 17:11:21.000000000 -0400
+++ ./src/base/string/input/cl_st_gettoken.cc 2009-06-08 19:47:41.202332829 -0400
@@ -1,6 +1,7 @@
// operator>>.
// General includes.
+#include <cstdio>
#include "cl_sysdep.h"
// Specification.

20
extra/cln/cln.install Normal file
View file

@ -0,0 +1,20 @@
infodir=/usr/share/info
filelist=(cln.info.gz)
post_install() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
post_install $1
}
pre_remove() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}