mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/fragments to 3.0.1-2
This commit is contained in:
parent
84cbe65784
commit
aabc5d4e9c
4 changed files with 84 additions and 12 deletions
|
@ -1,17 +1,27 @@
|
|||
pkgbase = fragments
|
||||
pkgdesc = BitTorrent client for GNOME
|
||||
pkgver = 3.0.1
|
||||
pkgrel = 1
|
||||
url = https://gitlab.gnome.org/World/Fragments
|
||||
pkgrel = 2
|
||||
url = https://apps.gnome.org/Fragments/
|
||||
arch = x86_64
|
||||
license = GPL3
|
||||
license = GPL-3.0-or-later
|
||||
makedepends = git
|
||||
makedepends = meson
|
||||
makedepends = rust
|
||||
depends = dconf
|
||||
depends = gcc-libs
|
||||
depends = glib2
|
||||
depends = glibc
|
||||
depends = gtk4
|
||||
depends = hicolor-icon-theme
|
||||
depends = libadwaita
|
||||
depends = openssl
|
||||
depends = transmission-cli
|
||||
depends = zlib
|
||||
options = !lto
|
||||
source = git+https://gitlab.gnome.org/World/Fragments.git#tag=3.0.1
|
||||
sha256sums = 5f11d5481b08de3ecb364c24095dd167843f8acc649bc539692ed08d96f20113
|
||||
source = fragments-window-icon.patch
|
||||
b2sums = 13afaddc26eab6e68199d0d1d8889c96bba394c5be63d641741d9994ae243e79e31ac243afc624b835cc575028723ecea556bfb419e0e01577429f6035f80c77
|
||||
b2sums = 968c7610283893aa327a76e68af3ed24dcbd0c61d24c09d524d5bb2791904b37b1da106e2118725eb188bec5e03b66bd04f93b7c0f6f835a573447224f7564b5
|
||||
|
||||
pkgname = fragments
|
||||
|
|
3
extra/fragments/.nvchecker.toml
Normal file
3
extra/fragments/.nvchecker.toml
Normal file
|
@ -0,0 +1,3 @@
|
|||
[fragments]
|
||||
source = "git"
|
||||
git = "https://gitlab.gnome.org/World/Fragments.git"
|
|
@ -5,19 +5,53 @@
|
|||
|
||||
pkgname=fragments
|
||||
pkgver=3.0.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc='BitTorrent client for GNOME'
|
||||
arch=('x86_64')
|
||||
url='https://gitlab.gnome.org/World/Fragments'
|
||||
license=('GPL3')
|
||||
arch=(x86_64)
|
||||
url='https://apps.gnome.org/Fragments/'
|
||||
license=(GPL-3.0-or-later)
|
||||
options=(!distcc)
|
||||
depends=('libadwaita' 'transmission-cli')
|
||||
makedepends=('git' 'meson' 'rust')
|
||||
source=("git+https://gitlab.gnome.org/World/Fragments.git#tag=$pkgver")
|
||||
sha256sums=('5f11d5481b08de3ecb364c24095dd167843f8acc649bc539692ed08d96f20113')
|
||||
depends=(
|
||||
dconf
|
||||
gcc-libs
|
||||
glib2
|
||||
glibc
|
||||
gtk4
|
||||
hicolor-icon-theme
|
||||
libadwaita
|
||||
openssl
|
||||
transmission-cli
|
||||
zlib
|
||||
)
|
||||
makedepends=(
|
||||
git
|
||||
meson
|
||||
rust
|
||||
)
|
||||
options=(!lto)
|
||||
source=(
|
||||
"git+https://gitlab.gnome.org/World/Fragments.git#tag=$pkgver"
|
||||
fragments-window-icon.patch
|
||||
)
|
||||
b2sums=(
|
||||
13afaddc26eab6e68199d0d1d8889c96bba394c5be63d641741d9994ae243e79e31ac243afc624b835cc575028723ecea556bfb419e0e01577429f6035f80c77
|
||||
968c7610283893aa327a76e68af3ed24dcbd0c61d24c09d524d5bb2791904b37b1da106e2118725eb188bec5e03b66bd04f93b7c0f6f835a573447224f7564b5
|
||||
)
|
||||
|
||||
prepare() {
|
||||
cd Fragments
|
||||
|
||||
# https://gitlab.gnome.org/World/Fragments/-/merge_requests/183
|
||||
patch -Np1 -i ../fragments-window-icon.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
# Use LTO
|
||||
#export CARGO_PROFILE_RELEASE_LTO=true CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
|
||||
|
||||
# Use debug
|
||||
#export CARGO_PROFILE_RELEASE_DEBUG=2
|
||||
|
||||
arch-meson Fragments build
|
||||
meson compile -C build
|
||||
}
|
||||
|
|
25
extra/fragments/fragments-window-icon.patch
Normal file
25
extra/fragments/fragments-window-icon.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From e0f7380821c868fa0f7cc0621368cfe2ce4d9d4d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
|
||||
Date: Sun, 18 Aug 2024 15:50:56 +0000
|
||||
Subject: [PATCH] Set icon for the window
|
||||
|
||||
---
|
||||
src/main.rs | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/main.rs b/src/main.rs
|
||||
index cfe067f..b8d0bdc 100644
|
||||
--- a/src/main.rs
|
||||
+++ b/src/main.rs
|
||||
@@ -64,6 +64,8 @@ fn main() {
|
||||
gio::resources_register(&res);
|
||||
|
||||
glib::set_application_name(config::NAME);
|
||||
+ gtk::Window::set_default_icon_name(config::APP_ID);
|
||||
+
|
||||
|
||||
// Run app itself
|
||||
FrgApplication::run();
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in a new issue