mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/lmms to 1.1.0-1
This commit is contained in:
parent
7451d27f09
commit
aae1c9939c
2 changed files with 3 additions and 64 deletions
|
@ -8,7 +8,7 @@
|
|||
# - remove wine makedepend, no vst
|
||||
|
||||
pkgname=lmms
|
||||
pkgver=1.0.3
|
||||
pkgver=1.1.0
|
||||
pkgrel=1
|
||||
pkgdesc='The Linux MultiMedia Studio.'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -24,17 +24,15 @@ provides=('lmms-extras')
|
|||
conflicts=('lmms-extras')
|
||||
options=('!makeflags')
|
||||
install=lmms.install
|
||||
source=("https://github.com/LMMS/${pkgname}/releases/download/v{$pkgver}/${pkgname}-${pkgver}-src.tar.bz2"
|
||||
source=("https://github.com/LMMS/${pkgname}/archive/v${pkgver}.tar.gz"
|
||||
lmms-1.0.3-build-fix.patch
|
||||
zynaddsubfx_unlink.patch)
|
||||
md5sums=('1f63ad9abd1781206d852e79b2191638'
|
||||
'fa8ab5c48b021b87f80444440479190a'
|
||||
md5sums=('170ce0615063e9a171f1980972cca262'
|
||||
'd2ea78ac0cf2979505f140c6845617cf')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
||||
patch -Np1 -i ../lmms-1.0.3-build-fix.patch
|
||||
patch -Np1 -i ../zynaddsubfx_unlink.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,59 +0,0 @@
|
|||
From f91925f34aa1ee8ecacb12b8c4943c7e8aaabbfe Mon Sep 17 00:00:00 2001
|
||||
From: Rafael Ruggiero <rafael46w@gmail.com>
|
||||
Date: Tue, 15 Jul 2014 17:41:07 -0300
|
||||
Subject: [PATCH] Update bode_shifter_cv_1432.c
|
||||
|
||||
---
|
||||
plugins/LadspaEffect/swh/bode_shifter_cv_1432.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
index 967edf6..a9c764e 100644
|
||||
--- a/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
+++ b/plugins/LadspaEffect/swh/bode_shifter_cv_1432.c
|
||||
@@ -350,7 +350,7 @@ static void runAddingBodeShifterCV(LADSPA_Handle instance, unsigned long sample_
|
||||
/* Perform the Hilbert FIR convolution
|
||||
* (probably FFT would be faster) */
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
||||
From ad35c553b39fc70237605952bf2c6ff1fac5b7b7 Mon Sep 17 00:00:00 2001
|
||||
From: Rafael Ruggiero <rafael46w@gmail.com>
|
||||
Date: Tue, 15 Jul 2014 17:42:01 -0300
|
||||
Subject: [PATCH] Update surround_encoder_1401.c
|
||||
|
||||
---
|
||||
plugins/LadspaEffect/swh/surround_encoder_1401.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/plugins/LadspaEffect/swh/surround_encoder_1401.c b/plugins/LadspaEffect/swh/surround_encoder_1401.c
|
||||
index d4b6ace..100a03e 100644
|
||||
--- a/plugins/LadspaEffect/swh/surround_encoder_1401.c
|
||||
+++ b/plugins/LadspaEffect/swh/surround_encoder_1401.c
|
||||
@@ -228,7 +228,7 @@ static void runSurroundEncoder(LADSPA_Handle instance, unsigned long sample_coun
|
||||
for (pos = 0; pos < sample_count; pos++) {
|
||||
delay[dptr] = s[pos];
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
||||
@@ -296,7 +296,7 @@ static void runAddingSurroundEncoder(LADSPA_Handle instance, unsigned long sampl
|
||||
for (pos = 0; pos < sample_count; pos++) {
|
||||
delay[dptr] = s[pos];
|
||||
hilb = 0.0f;
|
||||
- for (i = 0; i <= NZEROS/2; i++) {
|
||||
+ for (i = 0; i < NZEROS/2; i++) {
|
||||
hilb += (xcoeffs[i] * delay[(dptr - i*2) & (D_SIZE - 1)]);
|
||||
}
|
||||
dptr = (dptr + 1) & (D_SIZE - 1);
|
||||
--
|
||||
1.9.3
|
||||
|
Loading…
Reference in a new issue