mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed core/libsecret
This commit is contained in:
parent
4499e8fd05
commit
aaeb70540e
2 changed files with 0 additions and 63 deletions
|
@ -1,51 +0,0 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove makedepend on valgrind
|
||||
|
||||
pkgname=libsecret
|
||||
pkgver=0.20.4
|
||||
pkgrel=1
|
||||
pkgdesc="Library for storing and retrieving passwords and other secrets"
|
||||
url="https://wiki.gnome.org/Projects/Libsecret"
|
||||
arch=(x86_64)
|
||||
license=(LGPL)
|
||||
depends=(glib2 libgcrypt)
|
||||
checkdepends=(python-dbus dbus-glib python-gobject gjs)
|
||||
makedepends=(docbook-xsl gobject-introspection vala git gtk-doc meson)
|
||||
optdepends=('org.freedesktop.secrets: secret storage backend')
|
||||
provides=(libsecret-1.so)
|
||||
_commit=3fe635e64efd4b8dbc9ec3548b0bc8034c7665c4 # tags/0.20.4^0
|
||||
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit"
|
||||
fix-test.diff)
|
||||
sha256sums=('SKIP'
|
||||
'760e40ffcd3383149d62f803a900b3af1a838fb084a8403e45d0764696dd2ffe')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
|
||||
# Fix compiliation of test-vala-unstable
|
||||
# https://gitlab.gnome.org/GNOME/libsecret/-/issues/54
|
||||
git apply -3 ../fix-test.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
arch-meson $pkgname build
|
||||
meson compile -C build
|
||||
}
|
||||
|
||||
check() {
|
||||
dbus-run-session meson test -C build --print-errorlogs
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" meson install -C build
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
|
@ -1,12 +0,0 @@
|
|||
diff --git i/libsecret/meson.build w/libsecret/meson.build
|
||||
index 0c448b9..c0138d2 100644
|
||||
--- i/libsecret/meson.build
|
||||
+++ w/libsecret/meson.build
|
||||
@@ -185,6 +185,7 @@ pkg.generate(description: 'GObject bindings for Secret Service API (Unstable)',
|
||||
test_cflags = [
|
||||
libsecret_cflags,
|
||||
'-DSRCDIR="@0@"'.format(meson.source_root()),
|
||||
+ '-DSECRET_WITH_UNSTABLE',
|
||||
]
|
||||
|
||||
mock_service_lib = library('mock-service',
|
Loading…
Reference in a new issue