community/busybox to 1.32.1-2

This commit is contained in:
Kevin Mihelich 2021-01-10 19:33:45 +00:00
parent 82dfbbbee5
commit ab87211aba
2 changed files with 55 additions and 1 deletions

View file

@ -0,0 +1,50 @@
From 883cdb79a440d0425766f67aaef0cabde0a5060e Mon Sep 17 00:00:00 2001
From: Denys Vlasenko <vda.linux@googlemail.com>
Date: Sat, 9 Jan 2021 08:27:37 +0100
Subject: ash: fix ${unset_var/pattern/repl}
function old new delta
subevalvar 1349 1353 +4
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
---
shell/ash.c | 3 ++-
shell/ash_test/ash-vars/var_bash_repl_empty_var.right | 1 +
shell/ash_test/ash-vars/var_bash_repl_empty_var.tests | 2 ++
3 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/shell/ash.c b/shell/ash.c
index 37f9dd71b..76bf39ec2 100644
--- a/shell/ash.c
+++ b/shell/ash.c
@@ -7015,7 +7015,8 @@ subevalvar(char *start, char *str, int strloc,
slash_pos = -1;
if (repl) {
slash_pos = expdest - ((char *)stackblock() + strloc);
- STPUTC('/', expdest);
+ if (!(flag & EXP_DISCARD))
+ STPUTC('/', expdest);
//bb_error_msg("repl+1:'%s'", repl + 1);
p = argstr(repl + 1, (flag & EXP_DISCARD) | EXP_TILDE); /* EXP_TILDE: echo "${v/x/~}" expands ~ ! */
*repl = '/';
diff --git a/shell/ash_test/ash-vars/var_bash_repl_empty_var.right b/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
index 892916783..cf8f088c1 100644
--- a/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
+++ b/shell/ash_test/ash-vars/var_bash_repl_empty_var.right
@@ -1,2 +1,3 @@
+
Ok:0
diff --git a/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests b/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
index 73a43d38e..22aaba560 100755
--- a/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
+++ b/shell/ash_test/ash-vars/var_bash_repl_empty_var.tests
@@ -1,3 +1,5 @@
+unset v
+echo ${v/*/w}
v=''
echo ${v/*/w}
echo Ok:$?
--
cgit v1.2.1

View file

@ -7,7 +7,7 @@
pkgname=busybox
pkgver=1.32.1
pkgrel=1
pkgrel=2
pkgdesc="Utilities for rescue and embedded systems"
arch=("x86_64")
url="https://www.busybox.net"
@ -15,20 +15,24 @@ license=('GPL')
makedepends=("ncurses" "musl" "kernel-headers-musl")
validpgpkeys=('C9E9416F76E610DBD09D040F47B70C55ACC9965B')
source=("$url/downloads/$pkgname-$pkgver.tar.bz2"{,.sig}
'0001-ash-fix-unset_var-pattern-repl.patch'
"config"
"0001-comment-time-size-check.patch")
sha256sums=('9d57c4bd33974140fd4111260468af22856f12f5b5ef7c70c8d9b75c712a0dee'
'SKIP'
'4e4fb268c51e378a3ad0a12f903a601a136d31cae8b684a51ebabbc9a6cf9250'
'0b1df86c2fd0c8869c67096777960bddf7db2c54efab5ad890fc83e1b3cbf027'
'd390c798540bf4369da42a575369e737e3e270c7d3c6c2bd141d1da939f4d219')
b2sums=('b0258345d40628d8c12b4cc5c3efdb318cfb469e029242942cdad22aeec5142963291a746fbac450b43a4a1f2f7e9204442456691fa98f18eeaa58c70d714caf'
'SKIP'
'6ce36c1e467c55b3405af58b19636daaf1ead2a5a630ed93c0e86912ecccbce359df3061718f99f08204e705eb1352c00801af3f4241e470f7d64ef6367f3c7e'
'1ad361dd163e589aa85822834b7e5ec421c1fc7bfab1e481520a8d90ee920c2f1a07709871f864173c3cfb6eacf60f54a4e2adba4e061ae1a9a883e368f1893e'
'2a227153f936850778a772794c4eaa3b72157b76d07ecd9b491f19c690dff258e2c6a755ef2372136235a5220688847e9357812e95d8bdc5550593831b2d592d')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 < ../0001-ash-fix-unset_var-pattern-repl.patch
patch -p1 -i ../0001-comment-time-size-check.patch
}