mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/java8-openjdk to 8.u60-1
This commit is contained in:
parent
45c1894496
commit
aba3ee1cf7
4 changed files with 12 additions and 107 deletions
|
@ -1,12 +0,0 @@
|
|||
diff -r 61edd5c7412e make/linux/Makefile
|
||||
--- a/make/linux/Makefile Mon Mar 02 18:12:06 2015 +0000
|
||||
+++ b/make/linux/Makefile Tue Mar 03 15:58:13 2015 +0100
|
||||
@@ -233,7 +233,7 @@
|
||||
# Solaris 2.5.1, 2.6).
|
||||
# Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
|
||||
|
||||
-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%
|
||||
+SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
|
||||
OS_VERSION := $(shell uname -r)
|
||||
EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
|
||||
|
|
@ -1,46 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User sgehwolf
|
||||
# Date 1430335428 25200
|
||||
# Node ID 2a55e4998f0d28c7003a8a0f43d2c7602d89f54b
|
||||
# Parent cd8fe1a9205aedb6b5a1fc16e664412e48aee565
|
||||
8078666: JVM fastdebug build compiled with GCC 5 asserts with "widen increases"
|
||||
Summary: do the math on the unsigned type where overflows are well defined
|
||||
Reviewed-by: kvn, aph
|
||||
|
||||
diff -r cd8fe1a9205a -r 2a55e4998f0d src/share/vm/opto/type.cpp
|
||||
--- a/src/share/vm/opto/type.cpp Wed Jun 10 20:15:29 2015 -0400
|
||||
+++ b/src/share/vm/opto/type.cpp Wed Apr 29 12:23:48 2015 -0700
|
||||
@@ -1180,11 +1180,11 @@
|
||||
// Certain normalizations keep us sane when comparing types.
|
||||
// The 'SMALLINT' covers constants and also CC and its relatives.
|
||||
if (lo <= hi) {
|
||||
- if ((juint)(hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((juint)(hi - lo) >= max_juint) w = Type::WidenMax; // TypeInt::INT
|
||||
+ if (((juint)hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
+ if (((juint)hi - lo) >= max_juint) w = Type::WidenMax; // TypeInt::INT
|
||||
} else {
|
||||
- if ((juint)(lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((juint)(lo - hi) >= max_juint) w = Type::WidenMin; // dual TypeInt::INT
|
||||
+ if (((juint)lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
+ if (((juint)lo - hi) >= max_juint) w = Type::WidenMin; // dual TypeInt::INT
|
||||
}
|
||||
return w;
|
||||
}
|
||||
@@ -1438,11 +1438,11 @@
|
||||
// Certain normalizations keep us sane when comparing types.
|
||||
// The 'SMALLINT' covers constants.
|
||||
if (lo <= hi) {
|
||||
- if ((julong)(hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((julong)(hi - lo) >= max_julong) w = Type::WidenMax; // TypeLong::LONG
|
||||
+ if (((julong)hi - lo) <= SMALLINT) w = Type::WidenMin;
|
||||
+ if (((julong)hi - lo) >= max_julong) w = Type::WidenMax; // TypeLong::LONG
|
||||
} else {
|
||||
- if ((julong)(lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
- if ((julong)(lo - hi) >= max_julong) w = Type::WidenMin; // dual TypeLong::LONG
|
||||
+ if (((julong)lo - hi) <= SMALLINT) w = Type::WidenMin;
|
||||
+ if (((julong)lo - hi) >= max_julong) w = Type::WidenMin; // dual TypeLong::LONG
|
||||
}
|
||||
return w;
|
||||
}
|
||||
|
|
@ -17,9 +17,10 @@
|
|||
pkgname=('jre8-openjdk-headless' 'jre8-openjdk' 'jdk8-openjdk' 'openjdk8-src' 'openjdk8-doc')
|
||||
pkgbase=java8-openjdk
|
||||
_java_ver=8
|
||||
# http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
|
||||
_jdk_update=51
|
||||
_jdk_build=16
|
||||
# Found @ http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
|
||||
_jdk_update=60
|
||||
# Found @ http://hg.openjdk.java.net/jdk8u/jdk8u
|
||||
_jdk_build=24
|
||||
pkgver=${_java_ver}.u${_jdk_update}
|
||||
_repo_ver=jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
pkgrel=1
|
||||
|
@ -38,22 +39,16 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
JDK-8074312-hotspot.patch
|
||||
JVM_fastdebug_build_compiled_with_GCC_5_asserts_with_widen_increases.patch
|
||||
zero-interpreter-fix.patch
|
||||
rhbz1206656_fix_current_stack_pointer.patch)
|
||||
|
||||
sha256sums=('02eab2b937ed83c4505e93f58ad0b84a4e1a69e6d0baa4d041ec09ed98f18c2d'
|
||||
'00d783dda3a7d87eb55a72febe7666c4b3297616ef3f11bbd679a05f19a81825'
|
||||
'a7236d5e5824cea20b48ca4efb8e5109007024af9b85214e9153c4d633665d0a'
|
||||
'f7554dc2fba5dfd36af0ed618ebe4c7b1527b5a067052299a1679a4142bbbeee'
|
||||
'aa202ddf3bcc1dc54723bb26c0ae5ccaefc1693647e6b463955065d2b1720382'
|
||||
'5d6faf6c726392212659cebd93fdbf89a11b86bab60f5b220493d9d8e7ff0686'
|
||||
'3171ec4dbd96747eeb876a8fd3caf1e1e52da3dc91b63308193c914a5501d6e4'
|
||||
'ffdd0446fce7b624f2cdc80297b99eecfdf30adfee39d3b8832a78c1dc202636'
|
||||
'95fbd155806cac22de9e6df6f4f92ae79530f86d63cea1deaf98e607953e0b50'
|
||||
'8df4d5d78753ebc5bc425fd1c8fe788106ac8b9d3155feb162a748a96c81cc05'
|
||||
'ed2968406c6b05e7438a0ed7cb2b6041ddce369cbcedff11fd7563c8350e0e67'
|
||||
sha256sums=('97e368187b08067d57eb10bce08fb9057e63242c263f63ab7b7dd036cbf7aebf'
|
||||
'76736786a1205367167b1abd10b6f173885f8ca8b2c3f56d5ff94b9e65a98865'
|
||||
'9e7830631897679c97127387a1e962bfac46bafbe2b5a4be88e8bbf238e6c84c'
|
||||
'999f0242213a4d048cee4e990d62024d277bcc8d49ab6fd807e32271fe078985'
|
||||
'9643d8c22c4d6a680609168d84ac5a92421aa9973aea15cac687e4ccf167ff96'
|
||||
'cb854984714541af5cba6e920958d0c68f2de52bff5acf723387fa03d63d8c3d'
|
||||
'93a553f2e9dfc820e50bfd70f989c96cd330857849ddba23dc50246e99ab1329'
|
||||
'518dd422df787547bbeedb57a524501548a6efd8f96443ebc59276cc7922e801'
|
||||
'85d396e1663514390e73b0b072a5f93c51ca6e324ee0a08aa2ace599e3df83bf')
|
||||
|
||||
case "${CARCH}" in
|
||||
|
@ -80,13 +75,6 @@ prepare() {
|
|||
done
|
||||
|
||||
cd "${srcdir}/hotspot-${_repo_ver}"
|
||||
# https://bugs.openjdk.java.net/browse/JDK-8074312
|
||||
patch -p1 < "${srcdir}"/JDK-8074312-hotspot.patch
|
||||
# https://bugs.archlinux.org/task/45386
|
||||
# https://bugs.openjdk.java.net/browse/JDK-8078666
|
||||
patch -p1 < "${srcdir}"/JVM_fastdebug_build_compiled_with_GCC_5_asserts_with_widen_increases.patch
|
||||
|
||||
patch -p2 -i ../zero-interpreter-fix.patch
|
||||
patch -p2 -i ../rhbz1206656_fix_current_stack_pointer.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
# HG changeset patch
|
||||
# User roland
|
||||
# Date 1418632606 -3600
|
||||
# Node ID a733dad6fc1e2572ed227e898da35e0053cbb7c5
|
||||
# Parent db035d4ba1bd25ac8803bb2d177cb35681eb6907
|
||||
8067231: Zero builds fails after JDK-6898462
|
||||
Summary: Interpreter::remove_activation_entry() is not defined for the C++ interpreter
|
||||
Reviewed-by: roland, coleenp
|
||||
Contributed-by: Severin Gehwolf <sgehwolf@redhat.com>
|
||||
|
||||
--- jdk8/hotspot/src/share/vm/interpreter/interpreterRuntime.cpp Sat Dec 13 01:24:10 2014 +0300
|
||||
+++ jdk8/hotspot/src/share/vm/interpreter/interpreterRuntime.cpp Mon Dec 15 09:36:46 2014 +0100
|
||||
@@ -394,7 +394,11 @@
|
||||
// during deoptimization so the interpreter needs to skip it when
|
||||
// the frame is popped.
|
||||
thread->set_do_not_unlock_if_synchronized(true);
|
||||
+#ifdef CC_INTERP
|
||||
+ return (address) -1;
|
||||
+#else
|
||||
return Interpreter::remove_activation_entry();
|
||||
+#endif
|
||||
}
|
||||
|
||||
// Need to do this check first since when _do_not_unlock_if_synchronized
|
||||
|
Loading…
Reference in a new issue