community/libqtxdg to 3.5.0-1

This commit is contained in:
Kevin Mihelich 2020-04-26 13:09:06 +00:00
parent 7c2a500cf6
commit abc3f41f79
2 changed files with 11 additions and 9 deletions

View file

@ -1,4 +1,4 @@
From cacc184cb590591fffe5956294380c48f8390110 Mon Sep 17 00:00:00 2001
From 18855a034a2b1b386688b596c5924bb562cccdcb Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 25 Nov 2017 10:06:57 -0700
Subject: [PATCH] disable LTO
@ -8,10 +8,10 @@ Subject: [PATCH] disable LTO
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cmake/compiler_settings.cmake b/cmake/compiler_settings.cmake
index 6e318d9..87fe59a 100644
index 101b19f..f93df52 100644
--- a/cmake/compiler_settings.cmake
+++ b/cmake/compiler_settings.cmake
@@ -167,5 +167,5 @@ if (CMAKE_COMPILER_IS_GNUCXX OR QTXDG_COMPILER_IS_CLANGCXX)
@@ -77,5 +77,5 @@ if (CMAKE_COMPILER_IS_GNUCXX OR LXQT_COMPILER_IS_CLANGCXX)
# set(LTO_FLAGS "-flto")
endif()
# apply these options to "Release" build type only
@ -19,5 +19,5 @@ index 6e318d9..87fe59a 100644
+ #set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} ${LTO_FLAGS}")
endif()
--
2.14.1
2.24.1

View file

@ -5,8 +5,8 @@
# - patch to disable LTO
pkgname=libqtxdg
pkgver=3.4.0
pkgrel=4
pkgver=3.5.0
pkgrel=1
pkgdesc="Library providing freedesktop.org XDG specs implementations for Qt."
arch=("x86_64")
url="https://lxqt.org"
@ -14,17 +14,19 @@ license=("LGPL" "custom")
depends=("libsm" "libxkbcommon-x11" "qt5-base" "qt5-svg")
makedepends=("cmake" "lxqt-build-tools")
checkdepends=("xorg-server-xvfb")
provides=("libQt5Xdg.so" "libQt5XdgIconLoader.so")
source=(
"https://github.com/lxde/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
"https://github.com/lxde/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
'0001-disable-LTO.patch'
)
sha256sums=('7bb5bbbb901915888107ddcd1f120801569970832bda656b3abeb6514c2ab66e'
sha256sums=('41a99b36302f5391321ed1469a05dcba9033778fb27afca03ce320fa6ee4553c'
'SKIP'
'8d6d7370b40bd54bd7582138926fc258a055e30afeb8de1c3385de333542b54a')
'36061244c5f0822a9724f8d4a614673a52a6bd95979f7b0b746e206319ccef5f')
validpgpkeys=(
"169704C6FB490C6892C7F23C37E0AF1FDA48F373" # Jerome Leclanche <jerome@leclan.ch>
"7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3" # Alf Gaida <agaida@siduction.org>
"19DFDF3A579BD509DBB572D8BE793007AD22DF7E" # Pedram Pourang <tsujan2000@gmail.com>
)
prepare() {
@ -44,7 +46,7 @@ build() {
check() {
cd build
xvfb-run -d make test
xvfb-run --auto-display make test
}
package() {