community/mplayer-vaapi to 36265-3

This commit is contained in:
Kevin Mihelich 2013-08-01 12:51:24 +00:00
parent 3532eb3d5e
commit abddba7f6b
2 changed files with 1 additions and 25 deletions

View file

@ -8,7 +8,7 @@
pkgname=mplayer-vaapi
pkgver=36265
pkgrel=1
pkgrel=3
pkgdesc="A movie player, compiled with vaapi support"
arch=('i686' 'x86_64')
url="http://gitorious.org/vaapi/mplayer"
@ -26,7 +26,6 @@ backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
source=(http://pkgbuild.com/~foutrelis/sources/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
cdio-includes.patch
tweak-desktop-file.patch
demux-gif.patch
subreader-fix-srt-parsing.patch)
options=('!buildflags' '!emptydirs')
install=mplayer-vaapi.install
@ -34,7 +33,6 @@ sha256sums=('5747c28c30c15d1000fb655a8abaa4b22483746d0e82775b27466948ae0c549a'
'SKIP'
'72e6c654f9733953ad2466d0ea1a52f23e753791d8232d90f13293eb1b358720'
'5a09fb462729a4e573568f9e8c1f57dbe7f69c0b68cfa4f6d70b3e52c450d93b'
'6774f57c027474388497606edfccbb33509cc78b573cdc322dd0955764c6f9c2'
'8b6cd325d89ff8bce3662c6aaa9b61b8e6163c6574e09b575426a1eed02b8ad3')
prepare() {
@ -43,9 +41,6 @@ prepare() {
patch -Np0 -i "$srcdir/cdio-includes.patch"
patch -d etc -Np0 -i "$srcdir/tweak-desktop-file.patch"
# https://bugs.archlinux.org/task/36039
patch -Np0 -i "$srcdir/demux-gif.patch"
# http://bugzilla.mplayerhq.hu/show_bug.cgi?id=2139
patch -Np0 -i "$srcdir/subreader-fix-srt-parsing.patch"
}

View file

@ -1,19 +0,0 @@
--- libmpdemux/demux_gif.c-old 2012-08-20 08:47:01.000000000 -0600
+++ libmpdemux/demux_gif.c 2013-07-05 11:27:55.488387360 -0600
@@ -45,6 +45,16 @@
#define GIF_SIGNATURE (('G' << 16) | ('I' << 8) | 'F')
+static void PrintGifError(void)
+{
+ char *Err = GifErrorString();
+
+ if (Err != NULL)
+ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
+ else
+ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
+}
+
#ifndef CONFIG_GIF_TVT_HACK
// not supported by certain versions of the library
static int my_read_gif(GifFileType *gif, uint8_t *buf, int len)