mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-kirkwood-dt to 4.9.8-1
This commit is contained in:
parent
5ac43514a9
commit
abe5402202
2 changed files with 2 additions and 33 deletions
|
@ -1,25 +0,0 @@
|
|||
From 311bb4a115f653ff9f3202873303483007906c8f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 31 Aug 2014 08:45:13 -0600
|
||||
Subject: [PATCH] disable mv643xx_eth TSO
|
||||
|
||||
---
|
||||
drivers/net/ethernet/marvell/mv643xx_eth.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/net/ethernet/marvell/mv643xx_eth.c b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
index b151a94..e04af62 100644
|
||||
--- a/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
+++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
|
||||
@@ -3110,7 +3110,7 @@ static int mv643xx_eth_probe(struct platform_device *pdev)
|
||||
dev->watchdog_timeo = 2 * HZ;
|
||||
dev->base_addr = 0;
|
||||
|
||||
- dev->features = NETIF_F_SG | NETIF_F_IP_CSUM | NETIF_F_TSO;
|
||||
+ dev->features = NETIF_F_SG | NETIF_F_IP_CSUM;
|
||||
dev->vlan_features = dev->features;
|
||||
|
||||
dev->features |= NETIF_F_RXCSUM;
|
||||
--
|
||||
1.9.0
|
||||
|
|
@ -6,7 +6,7 @@ buildarch=2
|
|||
pkgbase=linux-kirkwood-dt
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=4.9.6
|
||||
pkgver=4.9.8
|
||||
srcver=${pkgver%.0}
|
||||
pkgrel=1
|
||||
cryptodev_commit=2dbbb2313f7c1d9465f4867c7d02851730154db8
|
||||
|
@ -25,7 +25,6 @@ options=('!strip')
|
|||
source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
||||
'config'
|
||||
'archlinuxarm.patch'
|
||||
'0001-disable-mv643xx_eth-TSO.patch'
|
||||
"cryptodev-${cryptodev_commit}.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
|
||||
"bfq1.patch::ftp://teambelgium.net/bfq/patches/${bfqkern}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r11-4.5.0.patch"
|
||||
"bfq2.patch::ftp://teambelgium.net/bfq/patches/${bfqkern}.0-${bfqver}/0002-block-introduce-the-BFQ-v7r11-I-O-sched-for-4.5.0.patch"
|
||||
|
@ -33,10 +32,9 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
|||
"bfq4.patch::ftp://teambelgium.net/bfq/patches/${bfqkern}.0-${bfqver}/0004-Turn-into-BFQ-${bfqver}-for-${bfqkern}.0.patch"
|
||||
'goflexhome_fdt.patch'
|
||||
'linux.preset')
|
||||
md5sums=('3d41fdbd6caccf91088d95670d714bb1'
|
||||
md5sums=('7b56bb1196642f0f6625906c6720a6b1'
|
||||
'8b70a792315968f8b2bc03ba28d841f9'
|
||||
'a6c6f6d930d43787117d00fc759c115b'
|
||||
'09d44b9f07abfaeaf4f688ee52034786'
|
||||
'6ecae916dcd58f9c0b9b768cfd1f61d3'
|
||||
'2c20b63f5afa8734664db0ce089523b7'
|
||||
'6a63525c7a69e5e6d72bbb03d572befd'
|
||||
|
@ -48,10 +46,6 @@ md5sums=('3d41fdbd6caccf91088d95670d714bb1'
|
|||
prepare() {
|
||||
cd "${srcdir}/linux-${srcver}"
|
||||
|
||||
# msg2 "Disable buggy TCP segmentation offload implementation"
|
||||
# msg2 "http://archlinuxarm.org/forum/viewtopic.php?f=9&t=7692"
|
||||
# patch -Np1 -i ${srcdir}/0001-disable-mv643xx_eth-TSO.patch
|
||||
|
||||
msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
|
||||
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
|
||||
patch -Np1 -i "${srcdir}/goflexhome_fdt.patch"
|
||||
|
|
Loading…
Reference in a new issue