diff --git a/extra/gjs/PKGBUILD b/extra/gjs/PKGBUILD
index ebd660ac4..8484c41e8 100644
--- a/extra/gjs/PKGBUILD
+++ b/extra/gjs/PKGBUILD
@@ -5,7 +5,7 @@
 #  - configure with --enable-compile-warnings=no
 
 pkgname=gjs
-pkgver=1.52.0
+pkgver=1.52.1
 pkgrel=1
 epoch=1
 pkgdesc="Javascript Bindings for GNOME"
@@ -15,7 +15,7 @@ license=(GPL)
 depends=(cairo gobject-introspection-runtime js52 gtk3)
 makedepends=(gobject-introspection git autoconf-archive xorg-server-xvfb)
 checkdepends=(valgrind)
-_commit=320268ef1902aa610cf2526d00065261fc90d4dc  # tags/1.52.0^0
+_commit=73751baa0247cb74791f923ea93017e4d5c12c2d  # tags/1.52.1^0
 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
 sha256sums=('SKIP')
 
@@ -31,7 +31,13 @@ prepare() {
 
 build() {
   cd $pkgname
-  ./configure --prefix=/usr --disable-static --libexecdir=/usr/lib --with-xvfb-tests --enable-compile-warnings=no
+  ./configure \
+    --prefix=/usr \
+    --libexecdir=/usr/lib \
+    --disable-static \
+    --enable-compile-warnings=yes \
+    --with-xvfb-tests \
+    --enable-compile-warnings=no
   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
   make
 }