mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/gcc to 4.7.1-4
This commit is contained in:
parent
034fbc134e
commit
ac01ff1fc0
3 changed files with 130 additions and 44 deletions
|
@ -9,15 +9,15 @@
|
|||
# - removed gnat (ada stuff) from gcc packaging
|
||||
# - disabled make check, too much stress, kills plugs :(
|
||||
# - specifid build host, disabled distcc, make -j1 (v5), -j2 (v7)
|
||||
# - patch for v7h gnueabihf triplet
|
||||
|
||||
plugrel=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc')
|
||||
pkgver=4.7.0
|
||||
pkgrel=6
|
||||
_snapshot=4.7-20120505
|
||||
_libstdcppmanver=20120307 # Note: check source directory name when updating this
|
||||
pkgver=4.7.1
|
||||
pkgrel=4
|
||||
#_snapshot=4.7-20120505
|
||||
_libstdcppmanver=20120605 # Note: check source directory name when updating this
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -25,15 +25,15 @@ url="http://gcc.gnu.org"
|
|||
makedepends=('binutils>=2.22' 'libmpc' 'cloog' 'ppl')
|
||||
checkdepends=('dejagnu')
|
||||
options=('!libtool' '!emptydirs' '!distcc')
|
||||
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-api.${_libstdcppmanver}.man.tar.bz2
|
||||
gcc_pure64.patch
|
||||
gcc-4.7.0-cloog-0.17.patch)
|
||||
md5sums=('8e2df3b9a755c9262db0df019cc3542e'
|
||||
'489d2f5311535800a120efd8d18db719'
|
||||
armhf-triplet-trunk.diff)
|
||||
md5sums=('933e6f15f51c031060af64a9e14149ff'
|
||||
'767c62f9a047c4434f2345decf1d0819'
|
||||
'ced48436c1b3c981d721a829f1094de1'
|
||||
'575f7d17b022e609447a590e481b18b5')
|
||||
'bd7330bd41845929f1e0efb3b7d0a060')
|
||||
|
||||
if [ -n "${_snapshot}" ]; then
|
||||
_basedir="${srcdir}/gcc-${_snapshot}"
|
||||
|
@ -54,14 +54,12 @@ build() {
|
|||
patch -p1 -i ${srcdir}/gcc_pure64.patch
|
||||
fi
|
||||
|
||||
# compatibility with latest cloog
|
||||
patch -p1 -i ${srcdir}/gcc-4.7.0-cloog-0.17.patch
|
||||
|
||||
echo ${pkgver} > gcc/BASE-VER
|
||||
|
||||
# ALARM: Specify build host types
|
||||
# ALARM: Specify build host types, triplet patch
|
||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=arm-unknown-linux-gnueabi --build=arm-unknown-linux-gnueabi" && MAKEFLAGS="-j1"
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabi --build=armv7l-unknown-linux-gnueabi --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16" && MAKEFLAGS="-j2"
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16" && MAKEFLAGS="-j2"
|
||||
[[ $CARCH == "armv7h" ]] && patch -p1 -i "${srcdir}/armhf-triplet-trunk.diff"
|
||||
|
||||
cd ${srcdir}
|
||||
mkdir gcc-build && cd gcc-build
|
||||
|
@ -77,6 +75,7 @@ build() {
|
|||
--disable-libstdcxx-pch --enable-libstdcxx-time \
|
||||
--enable-gnu-unique-object --enable-linker-build-id \
|
||||
--with-ppl --enable-cloog-backend=isl \
|
||||
--disable-ppl-version-check --disable-cloog-version-check \
|
||||
--enable-lto --enable-gold --enable-ld=default \
|
||||
--enable-plugin --with-plugin-ld=ld.gold \
|
||||
--with-linker-hash-style=gnu \
|
||||
|
@ -102,7 +101,7 @@ package_gcc-libs()
|
|||
{
|
||||
pkgdesc="Runtime libraries shipped by GCC"
|
||||
groups=('base')
|
||||
depends=('glibc>=2.15')
|
||||
depends=('glibc>=2.16')
|
||||
install=gcc-libs.install
|
||||
|
||||
cd gcc-build
|
||||
|
@ -158,8 +157,8 @@ package_gcc()
|
|||
rm -f $pkgdir/usr/share/man/man3/ffi*
|
||||
|
||||
# many packages require these symlinks
|
||||
install -dm755 ${pkgdir}/lib
|
||||
ln -s /usr/bin/cpp ${pkgdir}/lib/cpp
|
||||
#install -dm755 ${pkgdir}/lib
|
||||
#ln -s /usr/bin/cpp ${pkgdir}/lib/cpp
|
||||
ln -s gcc ${pkgdir}/usr/bin/cc
|
||||
|
||||
# POSIX conformance launcher scripts for c89 and c99
|
||||
|
@ -193,7 +192,8 @@ EOF
|
|||
|
||||
# install the libstdc++ man pages
|
||||
install -dm755 ${pkgdir}/usr/share/man/man3
|
||||
install -m644 ${srcdir}/man/man3/* ${pkgdir}/usr/share/man/man3/
|
||||
install -m644 ${srcdir}/libstdc++-api.${_libstdcppmanver}.man/man3/* \
|
||||
${pkgdir}/usr/share/man/man3/
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
|
|
110
core/gcc/armhf-triplet-trunk.diff
Normal file
110
core/gcc/armhf-triplet-trunk.diff
Normal file
|
@ -0,0 +1,110 @@
|
|||
diff -urN a/gcc/ada/gcc-interface/Makefile.in b/gcc/ada/gcc-interface/Makefile.in
|
||||
--- a/gcc/ada/gcc-interface/Makefile.in 2012-06-12 09:12:37.000000000 -0600
|
||||
+++ b/gcc/ada/gcc-interface/Makefile.in 2012-07-06 19:53:20.740322776 -0600
|
||||
@@ -1867,7 +1867,7 @@
|
||||
LIBRARY_VERSION := $(LIB_VERSION)
|
||||
endif
|
||||
|
||||
-ifeq ($(strip $(filter-out arm% linux-gnueabi,$(arch) $(osys)-$(word 4,$(targ)))),)
|
||||
+ifeq ($(strip $(filter-out arm%-linux,$(arch)-$(osys)) $(if $(findstring eabi,$(word 4,$(targ))),,$(word 4,$(targ)))),)
|
||||
LIBGNAT_TARGET_PAIRS = \
|
||||
a-intnam.ads<a-intnam-linux.ads \
|
||||
s-inmaop.adb<s-inmaop-posix.adb \
|
||||
diff -urN a/gcc/config.gcc b/gcc/config.gcc
|
||||
--- a/gcc/config.gcc 2012-06-04 03:51:00.000000000 -0600
|
||||
+++ b/gcc/config.gcc 2012-07-06 19:53:20.724697276 -0600
|
||||
@@ -842,7 +842,7 @@
|
||||
esac
|
||||
tmake_file="${tmake_file} arm/t-arm"
|
||||
case ${target} in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h"
|
||||
tmake_file="$tmake_file arm/t-arm-elf arm/t-bpabi arm/t-linux-eabi"
|
||||
# Define multilib configuration for arm-linux-androideabi.
|
||||
@@ -869,7 +869,7 @@
|
||||
tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/linux-gas.h arm/uclinux-elf.h glibc-stdint.h"
|
||||
tmake_file="arm/t-arm arm/t-arm-elf"
|
||||
case ${target} in
|
||||
- arm*-*-uclinux*eabi)
|
||||
+ arm*-*-uclinux*eabi*)
|
||||
tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h"
|
||||
tmake_file="$tmake_file arm/t-bpabi"
|
||||
# The BPABI long long divmod functions return a 128-bit value in
|
||||
diff -urN a/gcc/testsuite/lib/target-supports.exp b/gcc/testsuite/lib/target-supports.exp
|
||||
--- a/gcc/testsuite/lib/target-supports.exp 2012-04-09 03:24:22.000000000 -0600
|
||||
+++ b/gcc/testsuite/lib/target-supports.exp 2012-07-06 19:53:20.732510026 -0600
|
||||
@@ -3840,7 +3840,7 @@
|
||||
|| [istarget i?86-*-*]
|
||||
|| [istarget x86_64-*-*]
|
||||
|| [istarget alpha*-*-*]
|
||||
- || [istarget arm*-*-linux-gnueabi]
|
||||
+ || [istarget arm*-*-linux-*eabi*]
|
||||
|| [istarget bfin*-*linux*]
|
||||
|| [istarget hppa*-*linux*]
|
||||
|| [istarget s390*-*-*]
|
||||
@@ -3870,7 +3870,7 @@
|
||||
|| [istarget i?86-*-*]
|
||||
|| [istarget x86_64-*-*]
|
||||
|| [istarget alpha*-*-*]
|
||||
- || [istarget arm*-*-linux-gnueabi]
|
||||
+ || [istarget arm*-*-linux-*eabi*]
|
||||
|| [istarget hppa*-*linux*]
|
||||
|| [istarget s390*-*-*]
|
||||
|| [istarget powerpc*-*-*]
|
||||
diff -urN a/libgcc/config.host b/libgcc/config.host
|
||||
--- a/libgcc/config.host 2012-04-30 11:39:57.000000000 -0600
|
||||
+++ b/libgcc/config.host 2012-07-06 19:53:20.787199276 -0600
|
||||
@@ -327,7 +327,7 @@
|
||||
arm*-*-linux*) # ARM GNU/Linux with ELF
|
||||
tmake_file="${tmake_file} arm/t-arm t-fixedpoint-gnu-prefix"
|
||||
case ${host} in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
tmake_file="${tmake_file} arm/t-elf arm/t-bpabi arm/t-linux-eabi t-slibgcc-libgcc"
|
||||
tm_file="$tm_file arm/bpabi-lib.h"
|
||||
unwind_header=config/arm/unwind-arm.h
|
||||
diff -urN a/libjava/configure.ac b/libjava/configure.ac
|
||||
--- a/libjava/configure.ac 2012-05-21 12:14:01.000000000 -0600
|
||||
+++ b/libjava/configure.ac 2012-07-06 19:53:20.709071776 -0600
|
||||
@@ -931,7 +931,7 @@
|
||||
# on Darwin -single_module speeds up loading of the dynamic libraries.
|
||||
extra_ldflags_libjava=-Wl,-single_module
|
||||
;;
|
||||
-arm*linux*eabi)
|
||||
+arm*-*-linux-*eabi*)
|
||||
# Some of the ARM unwinder code is actually in libstdc++. We
|
||||
# could in principle replicate it in libgcj, but it's better to
|
||||
# have a dependency on libstdc++.
|
||||
diff -urN a/libstdc++-v3/configure.host b/libstdc++-v3/configure.host
|
||||
--- a/libstdc++-v3/configure.host 2012-02-10 11:10:12.000000000 -0700
|
||||
+++ b/libstdc++-v3/configure.host 2012-07-06 19:53:20.748135526 -0600
|
||||
@@ -340,7 +340,7 @@
|
||||
fi
|
||||
esac
|
||||
case "${host}" in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
port_specific_symbol_files="\$(srcdir)/../config/os/gnu-linux/arm-eabi-extra.ver"
|
||||
;;
|
||||
esac
|
||||
diff -urN a/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc b/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc
|
||||
--- a/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc 2011-09-21 05:23:11.000000000 -0600
|
||||
+++ b/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc 2012-07-06 19:53:20.771573776 -0600
|
||||
@@ -1,5 +1,5 @@
|
||||
// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
|
||||
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
|
||||
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
|
||||
|
||||
// 2007-05-03 Benjamin Kosnik <bkoz@redhat.com>
|
||||
//
|
||||
diff -urN a/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc b/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc
|
||||
--- a/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc 2011-09-21 05:23:11.000000000 -0600
|
||||
+++ b/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc 2012-07-06 19:53:20.763761026 -0600
|
||||
@@ -1,5 +1,5 @@
|
||||
// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
|
||||
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
|
||||
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
|
||||
|
||||
// 2007-05-03 Benjamin Kosnik <bkoz@redhat.com>
|
||||
//
|
|
@ -1,24 +0,0 @@
|
|||
diff -Naur gcc-4.6-20120120-orig/configure gcc-4.6-20120120/configure
|
||||
--- gcc-4.6-20120120-orig/configure 2011-12-18 20:03:44.000000000 +1000
|
||||
+++ gcc-4.6-20120120/configure 2012-02-03 17:55:14.885990135 +1000
|
||||
@@ -6049,8 +6049,8 @@
|
||||
LDFLAGS="${_cloog_saved_LDFLAGS} ${clooglibs} ${ppllibs}"
|
||||
|
||||
if test "${cloog_org}" = yes ; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.1 of CLooG" >&5
|
||||
-$as_echo_n "checking for version 0.16.1 of CLooG... " >&6; }
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.17 of CLooG" >&5
|
||||
+$as_echo_n "checking for version 0.17 of CLooG... " >&6; }
|
||||
if test "${gcc_cv_cloog_ct_0_14_0+set}" = set; then :
|
||||
$as_echo_n "(cached) " >&6
|
||||
else
|
||||
@@ -6061,8 +6061,7 @@
|
||||
main ()
|
||||
{
|
||||
#if CLOOG_VERSION_MAJOR != 0 \
|
||||
- || CLOOG_VERSION_MINOR != 16 \
|
||||
- || CLOOG_VERSION_REVISION < 1
|
||||
+ || CLOOG_VERSION_MINOR != 17
|
||||
choke me
|
||||
#endif
|
||||
;
|
Loading…
Reference in a new issue