mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/boost to 1.68.0-1
This commit is contained in:
parent
6b12f79ced
commit
ac289378c8
4 changed files with 8 additions and 95 deletions
|
@ -1,4 +1,5 @@
|
|||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Marius Knaust <marius.knaust@gmail.com>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
|
@ -15,30 +16,15 @@
|
|||
|
||||
pkgbase=boost
|
||||
pkgname=('boost-libs' 'boost')
|
||||
pkgver=1.67.0
|
||||
pkgver=1.68.0
|
||||
_boostver=${pkgver//./_}
|
||||
pkgrel=7
|
||||
pkgrel=1
|
||||
url='http://www.boost.org/'
|
||||
arch=('x86_64')
|
||||
license=('custom')
|
||||
makedepends=('icu' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
|
||||
add-missing-return-statement-in-numpy-import.patch
|
||||
lockfree-add-include-boost-next_prior.patch
|
||||
fix-return-var-qualifier-in-svm_ptr-get_context.patch)
|
||||
sha256sums=('2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba'
|
||||
'04aa755427415c3e1e8080d2bc607c27856f806599c8d35737a3c263b419ed8d'
|
||||
'2639c43e33f9279ffbebf270be0e0951b9f0e7a8264f8c3bfebb5b9901da2db6'
|
||||
'43cdc2081f90d2acc7e4d9de6689bce07b2a1b4754e85dc7fa50872afa330ffa')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgbase}_${_boostver}
|
||||
patch -Np2 -i ../lockfree-add-include-boost-next_prior.patch
|
||||
patch -Np2 -i ../fix-return-var-qualifier-in-svm_ptr-get_context.patch
|
||||
|
||||
# https://github.com/boostorg/python/issues/209
|
||||
patch -d libs/python -Np1 < ../add-missing-return-statement-in-numpy-import.patch
|
||||
}
|
||||
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
|
||||
sha256sums=('7f6130bc3cf65f56a618888ce9d5ea704fa10b462be126ad053e80e553d6d8b7')
|
||||
|
||||
build() {
|
||||
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"
|
||||
|
@ -143,8 +129,6 @@ package_boost-libs() {
|
|||
pkgdesc='Free peer-reviewed portable C++ source libraries - runtime libraries'
|
||||
depends=('bzip2' 'zlib' 'icu')
|
||||
optdepends=('openmpi: for mpi support')
|
||||
|
||||
# powerdns-recursor keeps being rebuild against outdated boost-libs
|
||||
provides=('libboost_context.so')
|
||||
|
||||
install -dm755 "${pkgdir}"/usr
|
||||
|
@ -161,3 +145,5 @@ package_boost-libs() {
|
|||
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
|
||||
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
From ed4776b59caec6dfbea548a96701a810653e6f24 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Moritz=20Wanzenb=C3=B6ck?= <moritz.wanzenboeck@catalysts.cc>
|
||||
Date: Wed, 11 Jul 2018 11:57:46 +0200
|
||||
Subject: [PATCH] Add missing return statement in numpy import
|
||||
|
||||
This adds a missing return statement in the python3 specific
|
||||
import logic of boost.python.numpy.
|
||||
|
||||
For python3 wrap_import_array() needs to return a pointer value.
|
||||
The import_array() macro only returns NULL in case of error. The
|
||||
missing return statement is UB, so the compiler can assume it does
|
||||
not happen. This means the compiler can assume the error branch
|
||||
is always taken, so import_array must always fail.
|
||||
---
|
||||
src/numpy/numpy.cpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/numpy/numpy.cpp b/src/numpy/numpy.cpp
|
||||
index 8e259bc75..3ae2295e3 100644
|
||||
--- a/src/numpy/numpy.cpp
|
||||
+++ b/src/numpy/numpy.cpp
|
||||
@@ -19,6 +19,7 @@ static void wrap_import_array()
|
||||
static void * wrap_import_array()
|
||||
{
|
||||
import_array();
|
||||
+ return NULL;
|
||||
}
|
||||
#endif
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
From fdbdb94db64e888fce90fe519be23c2a4396a82e Mon Sep 17 00:00:00 2001
|
||||
From: pradeep <pradeep@arrayfire.com>
|
||||
Date: Tue, 8 May 2018 14:53:38 +0530
|
||||
Subject: [PATCH 1/2] Fix return var qualifier in svm_ptr::get_context
|
||||
|
||||
Lack of `const` qualifier is throwing errors with GCC 8.1
|
||||
---
|
||||
include/boost/compute/memory/svm_ptr.hpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/boost/compute/memory/svm_ptr.hpp b/include/boost/compute/memory/svm_ptr.hpp
|
||||
index c8753f5b..56cf1268 100644
|
||||
--- a/include/boost/compute/memory/svm_ptr.hpp
|
||||
+++ b/include/boost/compute/memory/svm_ptr.hpp
|
||||
@@ -126,7 +126,7 @@ class svm_ptr
|
||||
return m_ptr - other.m_ptr;
|
||||
}
|
||||
|
||||
- context& get_context() const
|
||||
+ const context& get_context() const
|
||||
{
|
||||
return m_context;
|
||||
}
|
|
@ -1,21 +0,0 @@
|
|||
From 12726cda009a855073b9bedbdce57b6ce7763da2 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Dimov <pdimov@pdimov.com>
|
||||
Date: Sat, 2 Dec 2017 04:10:46 +0200
|
||||
Subject: [PATCH] Add #include <boost/next_prior.hpp>; no longer in utility.hpp
|
||||
|
||||
---
|
||||
include/boost/lockfree/spsc_queue.hpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/include/boost/lockfree/spsc_queue.hpp b/include/boost/lockfree/spsc_queue.hpp
|
||||
index 7903d2c..c7f2953 100644
|
||||
--- a/include/boost/lockfree/spsc_queue.hpp
|
||||
+++ b/include/boost/lockfree/spsc_queue.hpp
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <boost/assert.hpp>
|
||||
#include <boost/static_assert.hpp>
|
||||
#include <boost/utility.hpp>
|
||||
+#include <boost/next_prior.hpp>
|
||||
#include <boost/utility/enable_if.hpp>
|
||||
#include <boost/config.hpp> // for BOOST_LIKELY
|
||||
|
Loading…
Reference in a new issue