extra/suitesparse to 5.8.0-2

This commit is contained in:
Kevin Mihelich 2020-07-03 21:39:50 +00:00
parent ab77312b8e
commit ac39ec037d
2 changed files with 9 additions and 9 deletions

View file

@ -5,27 +5,27 @@
pkgname=suitesparse
pkgver=5.8.0
pkgrel=1
pkgrel=2
pkgdesc="A collection of sparse matrix libraries"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('x86_64')
conflicts=('umfpack')
provides=('umfpack')
replaces=('umfpack')
depends=('metis' 'lapack' 'tbb')
depends=('metis' 'lapack' 'tbb' 'mpfr')
makedepends=('gcc-fortran' 'cmake' 'chrpath')
license=('GPL')
options=('staticlibs')
source=($pkgname-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver.tar.gz"
suitesparse-no-demo.patch
libatomic.patch)
sha256sums=('5ce343444c589d5c46d1ef2b4dde625fdb287e1838f24bc5a5f7054149145fc3'
'f80488bb076753d38ea21d207bd682bdc97e21220c733da025f518a5b7e8e030'
sha256sums=('94a9b7134eb4dd82b97f1a22a6b464feb81e73af2dcdf683c6f252285191df1d'
'409b32e546ec4936d0d88e39c59ee68dfd9f630d8c454ce1e3d58243df7ad396'
'b91e5ee92c027a5b216debccee2d37712b31a4fb2a544d7721060ccf2f60a7da')
prepare() {
cd SuiteSparse-$pkgver
patch -p1 -i ../suitesparse-no-demo.patch
patch -p1 -i ../suitesparse-no-demo.patch # Don't run demo
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && patch -p1 -i ../libatomic.patch || true
}

View file

@ -1,11 +1,11 @@
--- SuiteSparse-5.6.0/Makefile.orig 2019-11-05 22:37:26.086135974 +0000
+++ SuiteSparse-5.6.0/Makefile 2019-11-05 22:37:37.549632429 +0000
@@ -12,7 +12,7 @@
# Compile the default rules for each package
@@ -16,7 +16,7 @@
# installs all libraries SuiteSparse/lib.
go: metis
( cd SuiteSparse_config && $(MAKE) )
- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
( cd AMD && $(MAKE) )
( cd BTF && $(MAKE) )
( cd CAMD && $(MAKE) )