mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/gnutls to 3.0.14-1
This commit is contained in:
parent
495a29b1c4
commit
ac93282f85
2 changed files with 6 additions and 38 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 150689 2012-02-20 10:15:52Z andyrtr $
|
||||
# $Id: PKGBUILD 151094 2012-02-24 20:55:22Z andyrtr $
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -7,8 +7,8 @@
|
|||
plugrel=1
|
||||
|
||||
pkgname=gnutls
|
||||
pkgver=3.0.13
|
||||
pkgrel=2
|
||||
pkgver=3.0.14
|
||||
pkgrel=1
|
||||
pkgdesc="A library which provides a secure layer over a reliable transport layer"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -17,16 +17,12 @@ install=gnutls.install
|
|||
options=('!libtool' '!zipman')
|
||||
depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle>=2.4' 'p11-kit>=0.11')
|
||||
makedepends=('strace')
|
||||
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
buildfix.diff)
|
||||
md5sums=('ec549be557f31ea8c1738cb441ef23ec'
|
||||
'a6a9a1d148abd6377e7634eb03bdaf7c'
|
||||
'9b2a32b41391d95aeb8ddae3756fa191')
|
||||
source=(ftp://ftp.gnu.org/gnu/gnutls/${pkgname}-${pkgver}.tar.xz{,.sig})
|
||||
md5sums=('0d613985c867846ccb5cbaba8fa576ef'
|
||||
'847af57e7d4702b176d1cbf157962f6e')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
# fix hanging make check - http://git.savannah.gnu.org/gitweb/?p=gnutls.git;a=commit;h=642e6b5ca996325dc0ca6401a3b87039408b2585
|
||||
patch -Np1 -i ${srcdir}/buildfix.diff
|
||||
./configure --prefix=/usr \
|
||||
--with-zlib \
|
||||
--disable-static \
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
index 17f6d3f..cc01dcd 100644 (file)
|
||||
|
||||
|
||||
--- a/tests/mini-loss-time.c
|
||||
+++ b/tests/mini-loss-time.c
|
||||
@@ -267,6 +267,7 @@ static void start (int server_packet, int client_packet)
|
||||
{
|
||||
/* parent */
|
||||
server (fd[0], server_packet);
|
||||
+ kill(child, SIGTERM);
|
||||
}
|
||||
else
|
||||
{
|
||||
--- a/src/libopts/m4/libopts.m4
|
||||
+++ b/src/libopts/m4/libopts.m4
|
||||
@@ -487,9 +487,9 @@ AC_DEFUN([LIBOPTS_CHECK_COMMON],[
|
||||
fi])
|
||||
|
||||
AC_ARG_ENABLE([libopts-install],
|
||||
- AC_HELP_STRING([--disable-libopts-install],
|
||||
- [Do not install libopts with client installation]))
|
||||
- AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" != Xno])
|
||||
+ AC_HELP_STRING([--enable-libopts-install],
|
||||
+ [Install libopts with client installation]))
|
||||
+ AM_CONDITIONAL([INSTALL_LIBOPTS],[test "X${enable_libopts_install}" = Xyes])
|
||||
|
||||
[if test -z "${NEED_LIBOPTS_DIR}" ; then]
|
||||
AC_MSG_CHECKING([whether autoopts-config can be found])
|
Loading…
Reference in a new issue