aur updates

This commit is contained in:
Kevin Mihelich 2015-06-19 00:35:13 +00:00
parent 0a906b0b09
commit acc2a0b819
16 changed files with 354 additions and 246 deletions

View file

@ -3,7 +3,7 @@
# Contributor: Maik Broemme <mbroemme@libmpq.org>
pkgname=asterisk
pkgver=13.3.2
pkgver=13.4.0
pkgrel=1
pkgdesc="A complete PBX solution"
arch=('i686' 'x86_64')
@ -125,13 +125,14 @@ source=(http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-$
${pkgname}.logrotated \
${pkgname}.tmpfile)
install=${pkgname}.install
sha256sums=('ff87592a49156e2f7c03a39a12d099a610e71c3135ca9548429b4066fc76aaa5'
'74e0b278d553499f0c648a6e3d55c0dbb11b0c6dc93a85b020a21eafadb83783'
sha256sums=('2049012665e99d2967b18d1594ae752307db7e967235877f1e058e6fb5b4c045'
'94acb6e68424195a12fd9d406b3fb586f264a550e75801f6e020a86e800dd42c'
'caa24cfec5c6b4f8cea385269e39557362acad7e2a552994c3bc24080e3bdd4e'
'673c0c55bce8068c297f9cdd389402c2d5d5a25e2cf84732cb071198bd6fa78a')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
#git apply < ${srcdir}/gcc5.patch
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin
make
}

View file

@ -13,8 +13,9 @@ ExecStop=/usr/bin/asterisk -rx 'core stop now'
ExecReload=/usr/bin/asterisk -rx 'core reload'
# safe_asterisk emulation
Restart=always
Restart=on-failure
RestartSec=10
RestartPreventExitStatus=0
[Install]
WantedBy=multi-user.target

View file

@ -1,76 +0,0 @@
From 9993a05606353b0088df4fbbcaa10232a96d4bbe Mon Sep 17 00:00:00 2001
From: Simon Howard <fraggle@gmail.com>
Date: Fri, 24 Oct 2014 19:41:57 -0400
Subject: [PATCH 1/3] Ignore loop tags on non-looping substitute tracks.
If a substitute music track is played in a non-looping configuration
(eg. the title screen music), ignore loop tags in the file to be
consistent with other source ports. This fixes a bug that was discussed
on #245.
---
src/i_sdlmusic.c | 34 +++++++++++++---------------------
1 file changed, 13 insertions(+), 21 deletions(-)
diff --git a/src/i_sdlmusic.c b/src/i_sdlmusic.c
index cca4132..16c5d51 100644
--- a/src/i_sdlmusic.c
+++ b/src/i_sdlmusic.c
@@ -1247,34 +1247,26 @@ static void RestartCurrentTrack(void)
double start = (double) file_metadata.start_time
/ file_metadata.samplerate_hz;
- // If the track is playing on loop then reset to the start point.
- // Otherwise we need to stop the track.
- if (current_track_loop)
+ // If the track finished we need to restart it.
+ if (current_track_music != NULL)
{
- // If the track finished we need to restart it.
- if (current_track_music != NULL)
- {
- Mix_PlayMusic(current_track_music, 1);
- }
-
- Mix_SetMusicPosition(start);
- SDL_LockAudio();
- current_track_pos = file_metadata.start_time;
- SDL_UnlockAudio();
- }
- else
- {
- Mix_HaltMusic();
- current_track_music = NULL;
- playing_substitute = false;
+ Mix_PlayMusic(current_track_music, 1);
}
+
+ Mix_SetMusicPosition(start);
+ SDL_LockAudio();
+ current_track_pos = file_metadata.start_time;
+ SDL_UnlockAudio();
}
// Poll music position; if we have passed the loop point end position
// then we need to go back.
static void I_SDL_PollMusic(void)
{
- if (playing_substitute && file_metadata.valid)
+ // When playing substitute tracks, loop tags only apply if we're playing
+ // a looping track. Tracks like the title screen music have the loop
+ // tags ignored.
+ if (current_track_loop && playing_substitute && file_metadata.valid)
{
double end = (double) file_metadata.end_time
/ file_metadata.samplerate_hz;
@@ -1286,7 +1278,7 @@ static void I_SDL_PollMusic(void)
}
// Have we reached the actual end of track (not loop end)?
- if (!Mix_PlayingMusic() && current_track_loop)
+ if (!Mix_PlayingMusic())
{
RestartCurrentTrack();
}
--
2.3.5

View file

@ -0,0 +1,46 @@
From bed0ff13bf09b3c6190f9ff0cf6f7182a96a0faf Mon Sep 17 00:00:00 2001
From: Simon Howard <fraggle@soulsphere.org>
Date: Wed, 10 Jun 2015 22:38:19 -0400
Subject: [PATCH] setup: Fix help URL for level warp menu.
The help URL for the warp menu was linking to the multiplayer start
game menu.
---
src/setup/multiplayer.c | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)
diff --git a/src/setup/multiplayer.c b/src/setup/multiplayer.c
index a36f4da..3fe6a82 100644
--- a/src/setup/multiplayer.c
+++ b/src/setup/multiplayer.c
@@ -37,6 +37,7 @@
#define MULTI_START_HELP_URL "http://www.chocolate-doom.org/setup-multi-start"
#define MULTI_JOIN_HELP_URL "http://www.chocolate-doom.org/setup-multi-join"
#define MULTI_CONFIG_HELP_URL "http://www.chocolate-doom.org/setup-multi-config"
+#define LEVEL_WARP_HELP_URL "http://www.chocolate-doom.org/setup-level-warp"
#define NUM_WADS 10
#define NUM_EXTRA_PARAMS 10
@@ -715,9 +716,17 @@ static void StartGameMenu(char *window_title, int multiplayer)
txt_widget_t *iwad_selector;
window = TXT_NewWindow(window_title);
- TXT_SetWindowHelpURL(window, MULTI_START_HELP_URL);
- TXT_AddWidgets(window,
+ if (multiplayer)
+ {
+ TXT_SetWindowHelpURL(window, MULTI_START_HELP_URL);
+ }
+ else
+ {
+ TXT_SetWindowHelpURL(window, LEVEL_WARP_HELP_URL);
+ }
+
+ TXT_AddWidgets(window,
gameopt_table = TXT_NewTable(2),
TXT_NewSeparator("Monster options"),
TXT_NewInvertedCheckBox("Monsters enabled", &nomonsters),
--
2.4.3

View file

@ -1,32 +0,0 @@
From 401b108d064c2a4a7b011b0368823427b388351c Mon Sep 17 00:00:00 2001
From: Simon Howard <fraggle@gmail.com>
Date: Fri, 24 Oct 2014 19:48:01 -0400
Subject: [PATCH 2/3] Ignore metadata loop tags if both are zero.
If LOOP_START and LOOP_END are both set to zero, ignore them. This
is consistent with other source ports.
---
src/i_sdlmusic.c | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/src/i_sdlmusic.c b/src/i_sdlmusic.c
index 16c5d51..b8c2b2f 100644
--- a/src/i_sdlmusic.c
+++ b/src/i_sdlmusic.c
@@ -405,6 +405,13 @@ static void ReadLoopPoints(char *filename, file_metadata_t *metadata)
// Only valid if at the very least we read the sample rate.
metadata->valid = metadata->samplerate_hz > 0;
+
+ // If start and end time are both zero, ignore the loop tags.
+ // This is consistent with other source ports.
+ if (metadata->start_time == 0 && metadata->end_time == 0)
+ {
+ metadata->valid = false;
+ }
}
// Given a MUS lump, look up a substitute MUS file to play instead
--
2.3.5

View file

@ -1,53 +0,0 @@
From aa4b6727e65471f305a337400ebc36b3d74d442a Mon Sep 17 00:00:00 2001
From: Fabian Greffrath <fabian+debian@greffrath.com>
Date: Tue, 28 Oct 2014 06:27:33 +0100
Subject: [PATCH 3/3] setup: dynamically set size of iwad_labels array
With the addition of the Freedoom IWADs, the number of IWADs supported
by chocolate-doom has been raised to 10. However, the iwad_labels[]
array only holds place for up to 8 pointers. Incidently, I have all 10
IWADs installed and trying to warp into a game from
chocolate-doom-setup leads to an out-of-bounds access of this array
and so the application crashes with a segmentation fault.
Instead of increasing the array size to 10, which will bite us next
time, I decided to set its size dynamically as soon as the number of
IWADs of known.
---
src/setup/multiplayer.c | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/src/setup/multiplayer.c b/src/setup/multiplayer.c
index d833a49..2aaae9a 100644
--- a/src/setup/multiplayer.c
+++ b/src/setup/multiplayer.c
@@ -55,7 +55,7 @@ static const iwad_t fallback_iwads[] = {
// Array of IWADs found to be installed
static const iwad_t **found_iwads;
-static char *iwad_labels[8];
+static char **iwad_labels;
// Index of the currently selected IWAD
@@ -559,10 +559,16 @@ static txt_widget_t *IWADSelector(void)
for (i=0; found_iwads[i] != NULL; ++i)
{
- iwad_labels[i] = found_iwads[i]->description;
++num_iwads;
}
+ iwad_labels = malloc(sizeof(*iwad_labels) * num_iwads);
+
+ for (i=0; i < num_iwads; ++i)
+ {
+ iwad_labels[i] = found_iwads[i]->description;
+ }
+
// If no IWADs are found, provide Doom 2 as an option, but
// we're probably screwed.
--
2.3.5

View file

@ -3,31 +3,31 @@
pkgname=(chocolate-{doom,heretic,hexen,strife,common})
pkgbase=${pkgname[0]}
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
pkgver=2.1.0
pkgrel=3
pkgver=2.2.0
pkgrel=2
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
makedepends=('python')
source=(http://chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz
0001-Ignore-loop-tags-on-non-looping-substitute-tracks.patch
0002-Ignore-metadata-loop-tags-if-both-are-zero.patch
0003-setup-dynamically-set-size-of-iwad_labels-array.patch)
sha256sums=('629305e7f328659f3e93e89b93adc9da4e99b5a351e51ceb749dcf3e3da8bcd3'
'39a9e9452167b59f2482a8b4a81cf433c3ae1ca9b0fac69ac94beecee554135b'
'33952a8eb4de22b4304654ce3b62ca9009d084e2be4cb0cd338237137d698880'
'46b578981aa936b73da359e8f3bbf72a485402a7bc14ac9d92a64490fff51b6c')
0001-setup-Fix-help-URL-for-level-warp-menu.patch)
sha256sums=('9fa9c56e72f8a04adf8f0800141192e9bafd38c9e424f70942ece6e515570173'
'f890dac486a77ace888e18419e0a3f95c2ff59fab9bea08eb92558c3d7320e50')
prepare() {
cd "${pkgbase}-${pkgver}"
for patch in ../*.patch; do
if [ ! -f "$patch" ]; then
break;
else
patch -p1 -i "$patch"
fi
done
# Change binary dir from /usr/games to /usr/bin
sed 's|/games|/bin|g' -i src{,/setup}/Makefile.in
patch -p1 -i ../0001-Ignore-loop-tags-on-non-looping-substitute-tracks.patch
patch -p1 -i ../0002-Ignore-metadata-loop-tags-if-both-are-zero.patch
patch -p1 -i ../0003-setup-dynamically-set-size-of-iwad_labels-array.patch
}
build() {

View file

@ -1,7 +1,7 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=('python-rtslib-fb' 'python2-rtslib-fb')
_pkgname=rtslib-fb
pkgver=2.1.fb53
pkgver=2.1.fb56
pkgrel=1
pkgdesc="free branch version of the LIO target API"
arch=('any')
@ -12,12 +12,17 @@ backup=()
options=()
install=
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz target.service)
sha256sums=('0578a8c32227cda5129e41dd4142ad43325d1aafe56d4e60a31430b15a269744'
sha256sums=('d93c2e45c3d3c3c8cf3bf544014e58b5156a7b7ceb3eab4d36e0b56840abbd0f'
'74b9e5c11eab1781aa8b43680b429080ae800fbcdafd29626791b5426a4cdea8')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
#patch -p1 < ../setup-syntax.patch
}
package_python-rtslib-fb() {
depends=('python')
depends=('python' 'python-six')
conflicts=('python2-rtslib' 'targetcli-fb<=2.1.fb31')
cd "$srcdir/$_pkgname-$pkgver"
@ -36,7 +41,7 @@ package_python-rtslib-fb() {
}
package_python2-rtslib-fb() {
depends=('python2')
depends=('python2' 'python2-six')
conflicts=('python2-rtslib')
cd "$srcdir/$_pkgname-$pkgver"

123
aur/python2-path/Changelog Normal file
View file

@ -0,0 +1,123 @@
Changes
7.3
#91: Releases now include a universal wheel.
7.2
In chmod, added support for multiple symbolic masks (separated by commas).
In chmod, fixed issue in setting of symbolic mask with = where unreferenced permissions were cleared.
7.1
#23: Added support for symbolic masks to .chmod.
7.0
The open method now uses io.open and supports all of the parameters to that function. open will always raise an OSError on failure, even on Python 2.
Updated write_text to support additional newline patterns.
The text method now always returns text (never bytes), and thus requires an encoding parameter be supplied if the default encoding is not sufficient to decode the content of the file.
6.2
path class renamed to Path. The path name remains as an alias for compatibility.
6.1
chown now accepts names in addition to numeric IDs.
6.0
Drop support for Python 2.5. Python 2.6 or later required.
Installation now requires setuptools.
5.3
Allow arbitrary callables to be passed to path.walk errors parameter. Enables workaround for issues such as #73 and #56.
5.2
#61: path.listdir now decodes filenames from os.listdir when loading characters from a file. On Python 3, the behavior is unchanged. On Python 2, the behavior will now mimick that of Python 3, attempting to decode all filenames and paths using the encoding indicated by sys.getfilesystemencoding(), and escaping any undecodable characters using the surrogateescape handler.
5.1
#53: Added path.in_place for editing files in place.
5.0
path.fnmatch now takes an optional parameter normcase and this parameter defaults to self.module.normcase (using case normalization most pertinent to the path object itself). Note that this change means that any paths using a custom ntpath module on non-Windows systems will have different fnmatch behavior. Before:
# on Unix
>>> p = path('Foo')
>>> p.module = ntpath
>>> p.fnmatch('foo')
False
After:
# on any OS
>>> p = path('Foo')
>>> p.module = ntpath
>>> p.fnmatch('foo')
True
To maintain the original behavior, either dont define the module for the path or supply explicit normcase function:
>>> p.fnmatch('foo', normcase=os.path.normcase)
# result always varies based on OS, same as fnmatch.fnmatch
For most use-cases, the default behavior should remain the same.
Issue #50: Methods that accept patterns (listdir, files, dirs, walk, walkdirs, walkfiles, and fnmatch) will now use a normcase attribute if it is present on the pattern parameter. The path module now provides a CaseInsensitivePattern wrapper for strings suitable for creating case-insensitive patterns for those methods.
4.4
Issue #44: _hash method would open files in text mode, producing invalid results on Windows. Now files are opened in binary mode, producing consistent results.
Issue #47: Documentation is dramatically improved with Intersphinx links to the Python os.path functions and documentation for all methods and properties.
4.3
Issue #32: Add chdir and cd methods.
4.2
open() now passes all positional and keyword arguments through to the underlying builtins.open call.
4.1
Native Python 2 and Python 3 support without using 2to3 during the build process.
4.0
Added a chunks() method to a allow quick iteration over pieces of a file at a given path.
Issue #28: Fix missing argument to samefile.
Initializer no longer enforces isinstance basestring for the source object. Now any object that supplies __unicode__ can be used by a path (except None). Clients that depend on a ValueError being raised for int and other non-string objects should trap these types internally.
Issue #30: chown no longer requires both uid and gid to be provided and will not mutate the ownership if nothing is provided.
3.2
Issue #22: __enter__ now returns self.
3.1
Issue #20: relpath now supports a “start” parameter to match the signature of os.path.relpath.
3.0
Minimum Python version is now 2.5.
2.6
Issue #5: Implemented path.tempdir, which returns a path object which is a temporary directory and context manager for cleaning up the directory.
Issue #12: One can now construct path objects from a list of strings by simply using path.joinpath. For example:
path.joinpath('a', 'b', 'c') # or
path.joinpath(*path_elements)
2.5
Issue #7: Add the ability to do chaining of operations that formerly only returned None.
Issue #4: Raise a TypeError when constructed from None.

View file

@ -1,8 +1,9 @@
# Maintainer: vorpalblade <vorpalblade77@gmail.com>
# Contributor: Anxo Beltrán <anxo.beltran.alvarez@gmail.com>
# Contributor: David Danier <david.danier@team23.de>
pkgname=python2-path
pkgver=5.1
pkgrel=2
pkgver=7.3
pkgrel=1
pkgdesc="path.py provides a class (path) for working with files and directories. Less typing than os.path, more fun, a few new tricks"
arch=('any')
url="https://pypi.python.org/pypi/path.py"
@ -10,10 +11,17 @@ license=('MIT')
depends=('python2')
options=(!emptydirs)
source=(http://pypi.python.org/packages/source/p/path.py/path.py-${pkgver}.zip)
sha256sums=('976b1392527c77383eb827de7fd44dacaf1297a63aa0df526f47af302f479d54')
changelog=Changelog
sha256sums=('f7d146f40768e3742199a5316fbe3eb6a6091b9feedcb4b969c7348dc03151e1')
build() {
cd "${srcdir}/path.py-${pkgver}"
python2 setup.py build || return 1
}
package() {
cd ${srcdir}/path.py-${pkgver}
# python2 setup.py build || return 1
python2 setup.py install --root=${pkgdir} --optimize=1 || return 1
python2 setup.py install --root="${pkgdir}" \
--prefix=/usr \
--compile \
--optimize=1 || return 1
}

View file

@ -1,11 +1,8 @@
# Contributor : Daniel Neve <the.mephit@googlemail.com>
plugrel=1
pkgshort=pynzb
pkgname=python2-$pkgshort
pkgver=0.1.0
pkgrel=2
pkgrel=3
pkgdesc="A unified API for parsing NZB files"
arch=('any')
url="http://pypi.python.org/pypi/pynzb/"
@ -21,6 +18,12 @@ md5sums=('63c74a36348ac28aa99732dcb8be8c59'
build() {
cd $srcdir/$pkgshort-$pkgver
python2 setup.py install --root=$pkgdir/ --optimize=1 || return 1
python2 setup.py build
}
package() {
cd $srcdir/$pkgshort-$pkgver
python2 setup.py install --root="${pkgdir}" \
--prefix=/usr \
--compile -O1
install -D -m644 $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
}

View file

@ -1,39 +1,56 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
# Maintainer: techryda <techryda at silentdome dot com>
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributo: Jianhui Z <jianhui@outlook.com>
# Contributo: Tau Tsao <realturner at gmail.com>
# Contributor: Tomasz Zok <tomasz.zok [at] gmail.com>
# Contributor: techryda <techryda at silentdome dot com>
# Contributor: Mathias R. <pu154r@overlinux.org>
pkgname=xrdp
pkgver=0.6.1
pkgrel=1
pkgver=0.8.0
pkgrel=2
pkgdesc="An open source remote desktop protocol (RDP) server"
url="http://xrdp.sourceforge.net/"
arch=('i686' 'x86_64' 'armv6h')
license=('GPL')
depends=('tigervnc')
source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-v$pkgver.tar.gz"
'xrdp.service'
'xrdp-sesman.service')
md5sums=('26099c6588943262023607c1b4e774d8'
'0cb760b3e8a34f9bdf4daa871444d74c'
'58eb44bdc7ca5bb436d6fd66826f9b0f')
license=('Apache')
depends=('tigervnc' 'libjpeg-turbo' 'libxrandr' 'libpulse' 'fuse')
backup=('etc/xrdp/sesman.ini' 'etc/xrdp/xrdp.ini')
install=xrdp.install
source=(https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz
fixups.patch)
md5sums=('2b0c3affc65ee77ad251514c62896757'
'07f35f8700cd9384f5d13117fd3a4e04')
prepare() {
cd "${pkgname}-v${pkgver}"
# Fix path in xrdp.sh file
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
cd "${pkgname}-${pkgver}"
sed -i 's|/etc/sysconfig/xrdp|/etc/xrdp/xrdp.ini|' instfiles/xrdp.service
sed -i 's|/etc/sysconfig/xrdp|/etc/xrdp/xrdp.ini|' instfiles/xrdp-sesman.service
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
sed -i 's|/usr/sbin|/usr/bin|' instfiles/xrdp.service
sed -i 's|/usr/sbin|/usr/bin|' instfiles/xrdp-sesman.service
patch -p2 -b -z .orig <../fixups.patch
./bootstrap
}
build() {
cd "${pkgname}-v${pkgver}"
./bootstrap
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin
make
cd "${pkgname}-${pkgver}"
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--sbindir=/usr/bin \
--with-systemdsystemdunitdir=/usr/lib/systemd/system \
--enable-jpeg \
--enable-simplesound \
--enable-fuse \
--enable-loadpulsemodules
make V=0
}
package() {
cd "${pkgname}-v${pkgver}"
make DESTDIR="$pkgdir" install
cd ${pkgdir}
# Install systemd service files
mkdir -p usr/lib/systemd/system
cp ${srcdir}/*.service usr/lib/systemd/system
cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}

79
aur/xrdp/fixups.patch Normal file
View file

@ -0,0 +1,79 @@
diff -up src/xrdp-0.8.0/instfiles/Makefile.am.orig src/xrdp-0.8.0/instfiles/Makefile.am
--- src/xrdp-0.8.0/instfiles/Makefile.am.orig 2014-05-19 23:41:42.000000000 -0600
+++ src/xrdp-0.8.0/instfiles/Makefile.am 2015-05-26 17:22:39.000000000 -0600
@@ -28,5 +28,7 @@ startscript_DATA = \
# must be tab below
install-data-hook:
chmod 755 $(DESTDIR)$(sysconfdir)/xrdp/xrdp.sh
- chmod 755 $(DESTDIR)$(sysconfdir)/init.d/xrdp
- sed -i 's|__BASE__|$(prefix)|' $(DESTDIR)$(sysconfdir)/init.d/xrdp;
+ if [ -f $(DESTDIR)$(sysconfdir)/init.d/xrdp ]; then \
+ chmod 755 $(DESTDIR)$(sysconfdir)/init.d/xrdp; \
+ sed -i 's|__BASE__|$(prefix)|' $(DESTDIR)$(sysconfdir)/init.d/xrdp; \
+ fi
diff -up src/xrdp-0.8.0/instfiles/pam.d/xrdp-sesman.orig src/xrdp-0.8.0/instfiles/pam.d/xrdp-sesman
--- src/xrdp-0.8.0/instfiles/pam.d/xrdp-sesman.orig 2014-05-19 23:41:42.000000000 -0600
+++ src/xrdp-0.8.0/instfiles/pam.d/xrdp-sesman 2015-05-26 17:22:39.000000000 -0600
@@ -1,5 +1,9 @@
#%PAM-1.0
-@include common-auth
-@include common-account
-@include common-session
-@include common-password
+#@include common-auth
+#@include common-account
+#@include common-session
+#@include common-password
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff -up src/xrdp-0.8.0/sesman/startwm.sh.orig src/xrdp-0.8.0/sesman/startwm.sh
--- src/xrdp-0.8.0/sesman/startwm.sh.orig 2014-05-19 23:41:42.000000000 -0600
+++ src/xrdp-0.8.0/sesman/startwm.sh 2015-05-26 17:22:39.000000000 -0600
@@ -8,6 +8,17 @@ wm_start()
export LANG LANGUAGE
fi
+ # arch user
+ if [ -r ~/.xinitrc ]; then
+ . ~/.xinitrc
+ exit 0
+ fi
+ # arch
+ if [ -r /etc/X11/xinit/xinitrc ]; then
+ . /etc/X11/xinit/xinitrc
+ exit 0
+ fi
+
# debian
if [ -r /etc/X11/Xsession ]; then
. /etc/X11/Xsession
diff -up src/xrdp-0.8.0/xrdp/xrdp.ini.orig src/xrdp-0.8.0/xrdp/xrdp.ini
--- src/xrdp-0.8.0/xrdp/xrdp.ini.orig 2014-05-19 23:41:42.000000000 -0600
+++ src/xrdp-0.8.0/xrdp/xrdp.ini 2015-05-26 17:25:17.000000000 -0600
@@ -36,7 +36,7 @@ grey=dedede
#red=ff0000
#green=00ff00
#background=626c72
-#autorun=xrdp1
+autorun=xrdp2
#hidelogwindow=yes
# when true, userid/password *must* be passed on cmd line
@@ -119,6 +119,15 @@ xrdpvr=true
# for debugging xrdp, add following line to section xrdp1
# chansrvport=/tmp/.xrdp/xrdp_chansrv_socket_7210
+[xrdp0]
+name=sesman-Xvnc-delay
+lib=libvnc.so
+username=ask
+password=ask
+ip=127.0.0.1
+port=-1
+delay_ms=2000
+
[xrdp1]
name=sesman-X11rdp
lib=libxup.so

View file

@ -1,15 +0,0 @@
[Unit]
Description=xrdp session manager
After=syslog.target network.target
StopWhenUnneeded=true
[Service]
Type=forking
PIDFile=/var/run/xrdp-sesman.pid
EnvironmentFile=/etc/xrdp/xrdp.ini
ExecStart=/usr/bin/xrdp-sesman $SESMAN_OPTIONS
ExecStop=/usr/bin/xrdp-sesman $SESMAN_OPTIONS --kill
[Install]
WantedBy=multi-user.target

15
aur/xrdp/xrdp.install Normal file
View file

@ -0,0 +1,15 @@
post_upgrade() {
if [ ! -e /etc/xrdp/rsakeys.ini ]; then
xrdp-keygen xrdp /etc/xrdp/rsakeys.ini
fi
}
post_install() {
post_upgrade
}
pre_remove() {
if [ -f /etc/xrdp/rsakeys.ini ]; then
rm /etc/xrdp/rsakeys.ini
fi
}

View file

@ -1,14 +0,0 @@
[Unit]
Description=xrdp daemon
Requires=xrdp-sesman.service
After=syslog.target network.target xrdp-sesman.service
[Service]
Type=forking
PIDFile=/var/run/xrdp.pid
EnvironmentFile=/etc/xrdp/xrdp.ini
ExecStart=/usr/bin/xrdp $XRDP_OPTIONS
ExecStop=/usr/bin/xrdp $XRDP_OPTIONS --kill
[Install]
WantedBy=multi-user.target