mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-kirkwood add BFQ patch files (source host seems to be down)
This commit is contained in:
parent
9e0abac3a9
commit
acdb1faa89
3 changed files with 6014 additions and 0 deletions
|
@ -0,0 +1,62 @@
|
||||||
|
From 599be431332e31a25ebe203155fa18d34781c3d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Arianna Avanzini <avanzini.arianna@gmail.com>
|
||||||
|
Date: Tue, 5 Mar 2013 10:41:49 +0100
|
||||||
|
Subject: [PATCH] block, bfq: attempt to fix use-after-free which affects SLUB
|
||||||
|
behavior (3.3.0 to 3.8.0)
|
||||||
|
|
||||||
|
It may happen that a call to bfq_del_bfqq_busy() puts the last
|
||||||
|
reference taken on a queue and frees it. Subsequent accesses to that
|
||||||
|
same queue would result in a use-after-free. Make sure that a queue
|
||||||
|
that has just been deleted from busy is no more touched.
|
||||||
|
---
|
||||||
|
block/bfq-iosched.c | 20 ++++++++++----------
|
||||||
|
1 file changed, 10 insertions(+), 10 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/block/bfq-iosched.c b/block/bfq-iosched.c
|
||||||
|
index 9378b7d..e9a6514 100644
|
||||||
|
--- a/block/bfq-iosched.c
|
||||||
|
+++ b/block/bfq-iosched.c
|
||||||
|
@@ -1244,14 +1244,23 @@ static void __bfq_bfqq_expire(struct bfq_data *bfqd, struct bfq_queue *bfqq)
|
||||||
|
|
||||||
|
__bfq_bfqd_reset_active(bfqd);
|
||||||
|
|
||||||
|
+ /*
|
||||||
|
+ * If this bfqq is shared between multiple processes, check
|
||||||
|
+ * to make sure that those processes are still issuing I/Os
|
||||||
|
+ * within the mean seek distance. If not, it may be time to
|
||||||
|
+ * break the queues apart again.
|
||||||
|
+ */
|
||||||
|
+ if (bfq_bfqq_coop(bfqq) && BFQQ_SEEKY(bfqq))
|
||||||
|
+ bfq_mark_bfqq_split_coop(bfqq);
|
||||||
|
+
|
||||||
|
if (RB_EMPTY_ROOT(&bfqq->sort_list)) {
|
||||||
|
- bfq_del_bfqq_busy(bfqd, bfqq, 1);
|
||||||
|
/*
|
||||||
|
* overloading budget_timeout field to store when
|
||||||
|
* the queue remains with no backlog, used by
|
||||||
|
* the weight-raising mechanism
|
||||||
|
*/
|
||||||
|
bfqq->budget_timeout = jiffies ;
|
||||||
|
+ bfq_del_bfqq_busy(bfqd, bfqq, 1);
|
||||||
|
} else {
|
||||||
|
bfq_activate_bfqq(bfqd, bfqq);
|
||||||
|
/*
|
||||||
|
@@ -1259,15 +1268,6 @@ static void __bfq_bfqq_expire(struct bfq_data *bfqd, struct bfq_queue *bfqq)
|
||||||
|
*/
|
||||||
|
bfq_rq_pos_tree_add(bfqd, bfqq);
|
||||||
|
}
|
||||||
|
-
|
||||||
|
- /*
|
||||||
|
- * If this bfqq is shared between multiple processes, check
|
||||||
|
- * to make sure that those processes are still issuing I/Os
|
||||||
|
- * within the mean seek distance. If not, it may be time to
|
||||||
|
- * break the queues apart again.
|
||||||
|
- */
|
||||||
|
- if (bfq_bfqq_coop(bfqq) && BFQQ_SEEKY(bfqq))
|
||||||
|
- bfq_mark_bfqq_split_coop(bfqq);
|
||||||
|
}
|
||||||
|
|
||||||
|
/**
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
|
@ -0,0 +1,97 @@
|
||||||
|
From 59fd22f37d9acfa07186a02bb1cd2d64785d82b1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Arianna Avanzini <avanzini.arianna@gmail.com>
|
||||||
|
Date: Sat, 4 Feb 2012 10:55:51 +0100
|
||||||
|
Subject: [PATCH 1/2] block: cgroups, kconfig, build bits for BFQ-v6-3.8
|
||||||
|
|
||||||
|
Update Kconfig.iosched and do the related Makefile changes to include
|
||||||
|
kernel configuration options for BFQ. Also add the bfqio controller
|
||||||
|
to the cgroups subsystem.
|
||||||
|
|
||||||
|
Signed-off-by: Paolo Valente <paolo.valente@unimore.it>
|
||||||
|
Signed-off-by: Arianna Avanzini <avanzini.arianna@gmail.com>
|
||||||
|
---
|
||||||
|
block/Kconfig.iosched | 26 ++++++++++++++++++++++++++
|
||||||
|
block/Makefile | 1 +
|
||||||
|
include/linux/cgroup_subsys.h | 6 ++++++
|
||||||
|
3 files changed, 33 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/block/Kconfig.iosched b/block/Kconfig.iosched
|
||||||
|
index 421bef9..56474b2 100644
|
||||||
|
--- a/block/Kconfig.iosched
|
||||||
|
+++ b/block/Kconfig.iosched
|
||||||
|
@@ -39,6 +39,28 @@ config CFQ_GROUP_IOSCHED
|
||||||
|
---help---
|
||||||
|
Enable group IO scheduling in CFQ.
|
||||||
|
|
||||||
|
+config IOSCHED_BFQ
|
||||||
|
+ tristate "BFQ I/O scheduler"
|
||||||
|
+ depends on EXPERIMENTAL
|
||||||
|
+ default n
|
||||||
|
+ ---help---
|
||||||
|
+ The BFQ I/O scheduler tries to distribute bandwidth among
|
||||||
|
+ all processes according to their weights.
|
||||||
|
+ It aims at distributing the bandwidth as desired, independently of
|
||||||
|
+ the disk parameters and with any workload. It also tries to
|
||||||
|
+ guarantee low latency to interactive and soft real-time
|
||||||
|
+ applications. If compiled built-in (saying Y here), BFQ can
|
||||||
|
+ be configured to support hierarchical scheduling.
|
||||||
|
+
|
||||||
|
+config CGROUP_BFQIO
|
||||||
|
+ bool "BFQ hierarchical scheduling support"
|
||||||
|
+ depends on CGROUPS && IOSCHED_BFQ=y
|
||||||
|
+ default n
|
||||||
|
+ ---help---
|
||||||
|
+ Enable hierarchical scheduling in BFQ, using the cgroups
|
||||||
|
+ filesystem interface. The name of the subsystem will be
|
||||||
|
+ bfqio.
|
||||||
|
+
|
||||||
|
choice
|
||||||
|
prompt "Default I/O scheduler"
|
||||||
|
default DEFAULT_CFQ
|
||||||
|
@@ -52,6 +74,9 @@ choice
|
||||||
|
config DEFAULT_CFQ
|
||||||
|
bool "CFQ" if IOSCHED_CFQ=y
|
||||||
|
|
||||||
|
+ config DEFAULT_BFQ
|
||||||
|
+ bool "BFQ" if IOSCHED_BFQ=y
|
||||||
|
+
|
||||||
|
config DEFAULT_NOOP
|
||||||
|
bool "No-op"
|
||||||
|
|
||||||
|
@@ -61,6 +86,7 @@ config DEFAULT_IOSCHED
|
||||||
|
string
|
||||||
|
default "deadline" if DEFAULT_DEADLINE
|
||||||
|
default "cfq" if DEFAULT_CFQ
|
||||||
|
+ default "bfq" if DEFAULT_BFQ
|
||||||
|
default "noop" if DEFAULT_NOOP
|
||||||
|
|
||||||
|
endmenu
|
||||||
|
diff --git a/block/Makefile b/block/Makefile
|
||||||
|
index 39b76ba..c0d20fa 100644
|
||||||
|
--- a/block/Makefile
|
||||||
|
+++ b/block/Makefile
|
||||||
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_BLK_DEV_THROTTLING) += blk-throttle.o
|
||||||
|
obj-$(CONFIG_IOSCHED_NOOP) += noop-iosched.o
|
||||||
|
obj-$(CONFIG_IOSCHED_DEADLINE) += deadline-iosched.o
|
||||||
|
obj-$(CONFIG_IOSCHED_CFQ) += cfq-iosched.o
|
||||||
|
+obj-$(CONFIG_IOSCHED_BFQ) += bfq-iosched.o
|
||||||
|
|
||||||
|
obj-$(CONFIG_BLOCK_COMPAT) += compat_ioctl.o
|
||||||
|
obj-$(CONFIG_BLK_DEV_INTEGRITY) += blk-integrity.o
|
||||||
|
diff --git a/include/linux/cgroup_subsys.h b/include/linux/cgroup_subsys.h
|
||||||
|
index f204a7a..b999bfa 100644
|
||||||
|
--- a/include/linux/cgroup_subsys.h
|
||||||
|
+++ b/include/linux/cgroup_subsys.h
|
||||||
|
@@ -78,3 +78,9 @@ SUBSYS(hugetlb)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* */
|
||||||
|
+
|
||||||
|
+#ifdef CONFIG_CGROUP_BFQIO
|
||||||
|
+SUBSYS(bfqio)
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+/* */
|
||||||
|
--
|
||||||
|
1.8.1.2
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue