mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
removed core/glib2
This commit is contained in:
parent
e80c1cdf4a
commit
ad4513eca4
4 changed files with 0 additions and 134 deletions
|
@ -1,87 +0,0 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
# Contributor: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgbase=glib2
|
||||
pkgname=(glib2 glib2-docs)
|
||||
pkgver=2.66.3
|
||||
pkgrel=1.1
|
||||
pkgdesc="Low level core library"
|
||||
url="https://wiki.gnome.org/Projects/GLib"
|
||||
license=(LGPL2.1)
|
||||
arch=(x86_64)
|
||||
depends=(pcre libffi util-linux-libs zlib)
|
||||
makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux
|
||||
meson dbus sysprof)
|
||||
checkdepends=(desktop-file-utils)
|
||||
_commit=30c06eb5fc5c1d6b992c144ebf8ae540d99b2fd2 # tags/2.66.3^0
|
||||
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
|
||||
noisy-glib-compile-schemas.diff
|
||||
glib-compile-schemas.hook gio-querymodules.hook)
|
||||
sha256sums=('SKIP'
|
||||
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
|
||||
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
|
||||
'557c88177f011ced17bdeac1af3f882b2ca33b386a866fdf900b35f927a2bbe8')
|
||||
|
||||
pkgver() {
|
||||
cd glib
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd glib
|
||||
|
||||
# Suppress noise from glib-compile-schemas.hook
|
||||
git apply -3 ../noisy-glib-compile-schemas.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
CFLAGS+=" -DG_DISABLE_CAST_CHECKS"
|
||||
arch-meson glib build \
|
||||
-D selinux=disabled \
|
||||
-D sysprof=enabled \
|
||||
-D man=true \
|
||||
-D gtk_doc=true
|
||||
meson compile -C build
|
||||
}
|
||||
|
||||
check() {
|
||||
meson test -C build --no-suite flaky --print-errorlogs
|
||||
}
|
||||
|
||||
package_glib2() {
|
||||
depends+=(libmount.so)
|
||||
provides+=(libgio-2.0.so libglib-2.0.so libgmodule-2.0.so libgobject-2.0.so
|
||||
libgthread-2.0.so)
|
||||
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
|
||||
'libelf: gresource inspection tool')
|
||||
|
||||
DESTDIR="$pkgdir" meson install -C build
|
||||
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
|
||||
|
||||
# Avoid a dep on sysprof
|
||||
sed -i 's/, sysprof-capture-4//' "$pkgdir"/usr/lib/pkgconfig/*.pc
|
||||
|
||||
export PYTHONHASHSEED=0
|
||||
python -m compileall -d /usr/share/glib-2.0/codegen \
|
||||
"$pkgdir/usr/share/glib-2.0/codegen"
|
||||
python -O -m compileall -d /usr/share/glib-2.0/codegen \
|
||||
"$pkgdir/usr/share/glib-2.0/codegen"
|
||||
|
||||
# Split docs
|
||||
mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
|
||||
}
|
||||
|
||||
package_glib2-docs() {
|
||||
pkgdesc="Documentation for GLib"
|
||||
depends=()
|
||||
license+=(custom)
|
||||
|
||||
mkdir -p "$pkgdir/usr/share"
|
||||
mv gtk-doc "$pkgdir/usr/share"
|
||||
|
||||
install -Dt "$pkgdir/usr/share/licenses/glib2-docs" -m644 glib/docs/reference/COPYING
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
|
@ -1,11 +0,0 @@
|
|||
[Trigger]
|
||||
Type = Path
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/lib/gio/modules/*.so
|
||||
|
||||
[Action]
|
||||
Description = Updating GIO module cache...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/gio-querymodules /usr/lib/gio/modules
|
|
@ -1,12 +0,0 @@
|
|||
[Trigger]
|
||||
Type = Path
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/share/glib-2.0/schemas/*.gschema.xml
|
||||
Target = usr/share/glib-2.0/schemas/*.gschema.override
|
||||
|
||||
[Action]
|
||||
Description = Compiling GSettings XML schema files...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
|
|
@ -1,24 +0,0 @@
|
|||
diff --git i/gio/glib-compile-schemas.c w/gio/glib-compile-schemas.c
|
||||
index b8de0907248f6860..130f89b1728f7932 100644
|
||||
--- i/gio/glib-compile-schemas.c
|
||||
+++ w/gio/glib-compile-schemas.c
|
||||
@@ -1219,19 +1219,6 @@ parse_state_start_schema (ParseState *state,
|
||||
return;
|
||||
}
|
||||
|
||||
- if (path && (g_str_has_prefix (path, "/apps/") ||
|
||||
- g_str_has_prefix (path, "/desktop/") ||
|
||||
- g_str_has_prefix (path, "/system/")))
|
||||
- {
|
||||
- gchar *message = NULL;
|
||||
- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
|
||||
- "Paths starting with "
|
||||
- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
|
||||
- id, path);
|
||||
- g_printerr ("%s\n", message);
|
||||
- g_free (message);
|
||||
- }
|
||||
-
|
||||
state->schema_state = schema_state_new (path, gettext_domain,
|
||||
extends, extends_name, list_of);
|
||||
|
Loading…
Reference in a new issue