extra/kdebindings-python: updated arm patch

This commit is contained in:
Kevin Mihelich 2013-02-09 20:03:18 +00:00
parent a72ffc93c6
commit ad862936e8
3 changed files with 24 additions and 25 deletions

View file

@ -17,15 +17,15 @@ groups=('kdebindings')
makedepends=('cmake' 'automoc4' 'boost' 'kdepim-runtime' 'python2-pyqt'
'pyqt' 'qscintilla' 'python2-sip' 'python-sip' 'mesa')
source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.xz"
"pykde4-4.4.4-arm-sip.patch")
"pykde4-4.10.0-arm-sip.patch")
sha1sums=('d587d16363d2184320faf3636ac92f9b50ef5720'
'20d37a8b127eebffc4556352168786036969ee78')
'f0798d25767768006d5f674049e51b2e39f9f4eb')
build() {
export PYTHONDONTWRITEBYTECODE="TRUE"
cd "${srcdir}/pykde4-${pkgver}"
patch -Np3 -i "${srcdir}/pykde4-4.4.4-arm-sip.patch"
patch -Np1 -i "${srcdir}/pykde4-4.10.0-arm-sip.patch"
cd "${srcdir}"
mkdir build
cd build

View file

@ -0,0 +1,21 @@
diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2013-01-23 14:49:42.000000000 -0700
+++ b/CMakeLists.txt 2013-02-09 11:14:13.362993722 -0700
@@ -101,6 +101,8 @@
${KDEPIMLIBS_INCLUDE_DIRS}
)
+# Pull in ARM configuration options if needed
+STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
set(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
set(SIP_CONCAT_PARTS 8)
if (WIN32)
@@ -108,7 +110,7 @@
else ()
set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
endif ()
-set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
# Use an extra option when compiling on Python 3.
if (PYTHON_VERSION_MAJOR GREATER 2)

View file

@ -1,22 +0,0 @@
diff -Naur pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt pykde4-4.4.3/python/pykde4/CMakeLists.txt
--- pykde4-4.4.3.orig/python/pykde4/CMakeLists.txt 2010-03-29 14:57:40.000000000 +0200
+++ pykde4-4.4.3/python/pykde4/CMakeLists.txt 2010-05-31 15:49:17.095615617 +0200
@@ -75,6 +75,9 @@
${KDEPIMLIBS_INCLUDE_DIRS}
)
+# Pull in ARM configuration options if needed
+STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
+
SET(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
SET(SIP_CONCAT_PARTS 8)
IF (WIN32)
@@ -82,7 +85,7 @@
ELSE (WIN32)
SET(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
ENDIF (WIN32)
-SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+SET(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
# Use an extra option when compiling on Python 3.
IF (PYTHON_3)