linux-peach: kernel-CVE-2016-0728.patch

This commit is contained in:
Jason Plum 2016-01-20 15:27:36 -05:00
parent 171d00c7d7
commit adedd568f1
2 changed files with 85 additions and 1 deletions

View file

@ -7,7 +7,7 @@ pkgbase=linux-peach
_kernelname=${pkgbase#linux}
_desc="Exynos Chromebooks (Peach, Snow, Spring)"
pkgver=3.8.11
pkgrel=2
pkgrel=3
_commit=75dd2035f13c18744f6085d9f86a15172b95ea81
arch=('armv7h')
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.8"
@ -19,6 +19,7 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
'0001-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch'
'0002-use-chromiumos-mwifiex-drivers.patch'
'0003-exynos-DRM-have-exynos_drm_fbdev_update-set-smem_sta.patch'
'kernel-CVE-2016-0728.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -31,6 +32,7 @@ md5sums=('SKIP'
'8d44534965bda4a009e03d11bbb03d2f'
'bdcaf5ecc962cfdd6a732be8fbb96e0a'
'f7f9c336e574efae3aeb32562e8752ef'
'6470e9783bd1c7a8feddc2d67f07afd5'
'7e1d18307858818b9d85cd841a6da6b9'
'9791091c8e4158297533df988d1a47da'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -41,6 +43,7 @@ prepare() {
git apply 0001-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch
git apply 0002-use-chromiumos-mwifiex-drivers.patch
git apply 0003-exynos-DRM-have-exynos_drm_fbdev_update-set-smem_sta.patch
git apply kernel-CVE-2016-0728.patch
cp config .config

View file

@ -0,0 +1,81 @@
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
From: Yevgeny Pats <yevgeny@perception-point.io>
Date: Tue, 19 Jan 2016 22:09:04 +0000
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
This fixes CVE-2016-0728.
If a thread is asked to join as a session keyring the keyring that's already
set as its session, we leak a keyring reference.
This can be tested with the following program:
#include <stddef.h>
#include <stdio.h>
#include <sys/types.h>
#include <keyutils.h>
int main(int argc, const char *argv[])
{
int i = 0;
key_serial_t serial;
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
if (keyctl(KEYCTL_SETPERM, serial,
KEY_POS_ALL | KEY_USR_ALL) < 0) {
perror("keyctl");
return -1;
}
for (i = 0; i < 100; i++) {
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
}
return 0;
}
If, after the program has run, there something like the following line in
/proc/keys:
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
with a usage count of 100 * the number of times the program has been run,
then the kernel is malfunctioning. If leaked-keyring has zero usages or
has been garbage collected, then the problem is fixed.
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
Signed-off-by: David Howells <dhowells@redhat.com>
Acked-by: Don Zickus <dzickus@redhat.com>
Acked-by: Prarit Bhargava <prarit@redhat.com>
Acked-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: James Morris <james.l.morris@oracle.com>
---
security/keys/process_keys.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
index a3f85d2..e6d50172 100644
--- a/security/keys/process_keys.c
+++ b/security/keys/process_keys.c
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
ret = PTR_ERR(keyring);
goto error2;
} else if (keyring == new->session_keyring) {
+ key_put(keyring);
ret = 0;
goto error2;
}
--
cgit v0.12