removed extra/samba

This commit is contained in:
Kevin Mihelich 2022-08-08 12:40:47 +00:00
parent e60080e95d
commit ae3af10063
6 changed files with 0 additions and 298 deletions

View file

@ -1,221 +0,0 @@
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
# Contributor: Michael Hansen <zrax0111 gmail com>
# Contributor: Marco A Rojas <marquicus at gmail.com>
# Contributor: Netanel Shine <netanel at archlinux.org.il >
# Contributor: ngoonee <ngoonee.talk@gmail.com>
# Contributor: Adam Russell <adamlr6+arch@gmail.com>
# Contributor: Dhananjay Sathe <dhananjaysathe@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on ceph-libs, remove depend on ceph-libs in samba package
pkgbase=samba
pkgname=('smbclient' 'samba')
pkgver=4.16.4
pkgrel=2
arch=(x86_64)
url="https://www.samba.org"
license=('GPL3')
makedepends=('python' 'python-markdown' 'python-dnspython' 'docbook-xsl' 'pkg-config' 'libbsd' 'db' 'popt' 'libcups'
'readline' 'tevent' 'acl' 'libldap' 'libcap' 'ldb' 'krb5' 'pam'
'systemd' 'gnutls' 'talloc' 'tdb' 'dbus' 'libaio'
'perl-parse-yapp' 'libnsl' 'libtirpc' 'rpcsvc-proto' 'jansson'
'liburing' 'perl-json' 'glusterfs')
optdepends=(
'python-dnspython: samba_dnsupdate and samba_upgradedns in AD setup'
'python-markdown: for samba-tool domain schemeupgrade'
'glusterfs: for vfs_glusterfs support'
)
source=(https://us1.samba.org/samba/ftp/stable/${pkgbase}-${pkgver}.tar{.gz,.asc}
samba.logrotate
samba.pam
samba.conf
samba-glibc-2.36.patch)
validpgpkeys=('81F5E2832BD2545A1897B713AA99442FB680B620') #Samba Distribution Verification Key <samba-bugs@samba.org>
sha512sums=('9754275ace30755b75f747e201f8ad4550a823c8606e550c0ce6b3ccbaf048dd895bf2c21127271298304be7f80de9b6451091c4949ebe267ee1cf3ab497cd85'
'SKIP'
'2ba0691ded467e4d6e40821f6de58c00f8962209efe2e60284c0c87756ab471c22c3d63b77d506e48c90ed0d852a2a24e41be1d499cf74a73cb99da0b503c858'
'1e6183ab0eb812b3ef687ac2c26ce78f7cb30540f606d20023669ac00ba04075487fb72e4dc89cc05dab0269ff6aca98fc1167cc75669c225b88b592482fbf67'
'e46ee848baabb261e7468ecee43aba4d001a24f86f5322ae522abdb75030fd0ebd9063b9df0be3576c4d1654d81331f5e389aee16ec2fa138259ae4728e94efc'
'a6404c4ecfa60ab38fb79c5cd6af2818762ff2fe787e512c0eee0af6459d7726e168e76724a3012d895a30a68c11723e7a3f1fdb027d56dda8e1fdcc9059b915')
### UNINSTALL dmapi package before building!!!
prepare() {
cd samba-${pkgver}
patch -Np1 -i ../samba-glibc-2.36.patch
}
build() {
# Use samba-pkg as a staging directory for the split packages
# (This is so RPATHS and symlinks are generated correctly via
# make install, but the otherwise unsplit pieces can be split)
_pkgsrc="${srcdir}"/samba-pkg
rm -rf ${_pkgsrc}
_samba4_idmap_modules=idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2
_samba4_pdb_modules=pdb_tdbsam,pdb_ldap,pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4
_samba4_auth_modules=auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4
cd samba-${pkgver}
./configure --enable-fhs \
--prefix=/usr \
--sysconfdir=/etc \
--sbindir=/usr/bin \
--libdir=/usr/lib \
--libexecdir=/usr/lib/samba \
--localstatedir=/var \
--with-configdir=/etc/samba \
--with-lockdir=/var/cache/samba \
--with-sockets-dir=/run/samba \
--with-piddir=/run \
--with-ads \
--with-ldap \
--with-winbind \
--with-acl-support \
--with-systemd \
--systemd-install-services \
--with-pam \
--with-pammodulesdir=/usr/lib/security \
--bundled-libraries=!tdb,!talloc,!pytalloc-util,!tevent,!popt,!ldb,!pyldb-util \
--with-shared-modules=${_samba4_idmap_modules},${_samba4_pdb_modules},${_samba4_auth_modules} \
--disable-rpath-install \
--with-cluster-support \
--with-profiling-data
# Add this to the options once it's working...
#--with-system-mitkrb5 /opt/heimdal
make
make DESTDIR="${_pkgsrc}/" install
# This gets skipped somehow
if [ ! -e "${_pkgsrc}"/usr/bin/smbtar ]; then
install -m755 "${srcdir}"/samba-${pkgver}/source3/script/smbtar "${_pkgsrc}"/usr/bin/
fi
}
package_smbclient() {
pkgdesc="Tools to access a server's filespace and printers via SMB"
depends=('popt' 'cifs-utils' 'tdb' 'ldb'
'tevent' 'libgcrypt' 'python' 'talloc' 'readline' 'gnutls'
'libbsd' 'libldap' 'libcups' 'libarchive' 'libnsl' 'jansson'
'libldb.so' 'libtdb.so' 'libtevent.so' 'libreadline.so' 'icu' 'libunwind')
replaces=('libwbclient')
provides=('libwbclient')
_smbclient_bins=('smbclient' 'rpcclient' 'smbspool'
'smbtree' 'smbcacls' 'smbcquotas' 'smbget' 'net'
'nmblookup' 'smbtar')
# Use samba-pkg as a staging directory for the split packages
# (This is so RPATHS and symlinks are generated correctly via
# make install, but the otherwise unsplit pieces can be split)
_pkgsrc="${srcdir}"/samba-pkg
install -d -m755 "${pkgdir}"/usr/bin
for bin in ${_smbclient_bins[@]}; do
mv "${_pkgsrc}"/usr/bin/${bin} "${pkgdir}"/usr/bin/
done
# smbclient binaries link to the majority of the samba
# libs, so this is a shortcut instead of resolving the
# whole dependency tree by hand
install -d -m755 "${pkgdir}"/usr/lib
for lib in "${_pkgsrc}"/usr/lib/lib*.so*; do
mv ${lib} "${pkgdir}"/usr/lib/
done
install -d -m755 "${pkgdir}"/usr/lib/samba
for lib in "${_pkgsrc}"/usr/lib/samba/lib*.so*; do
mv ${lib} "${pkgdir}"/usr/lib/samba/
done
install -d -m755 "${pkgdir}"/usr/lib/pkgconfig
mv "${_pkgsrc}"/usr/lib/pkgconfig/smbclient.pc "${pkgdir}"/usr/lib/pkgconfig/
mv "${_pkgsrc}"/usr/lib/pkgconfig/netapi.pc "${pkgdir}"/usr/lib/pkgconfig/
mv "${_pkgsrc}"/usr/lib/pkgconfig/wbclient.pc "${pkgdir}"/usr/lib/pkgconfig/
install -d -m755 "${pkgdir}"/usr/share/man/man1
install -d -m755 "${pkgdir}"/usr/share/man/man7
install -d -m755 "${pkgdir}"/usr/share/man/man8
for bin in ${_smbclient_bins[@]}; do
if [ -e "${_pkgsrc}"/usr/share/man/man1/${bin}.1 ]; then
mv "${_pkgsrc}"/usr/share/man/man1/${bin}.1 "${pkgdir}"/usr/share/man/man1/
fi
if [ -e "${_pkgsrc}"/usr/share/man/man8/${bin}.8 ]; then
mv "${_pkgsrc}"/usr/share/man/man8/${bin}.8 "${pkgdir}"/usr/share/man/man8/
fi
done
mv "${_pkgsrc}"/usr/share/man/man7/libsmbclient.7 "${pkgdir}"/usr/share/man/man7/
install -d -m755 "${pkgdir}"/usr/include/samba-4.0
mv "${_pkgsrc}"/usr/include/samba-4.0/libsmbclient.h "${pkgdir}"/usr/include/samba-4.0/
mv "${_pkgsrc}"/usr/include/samba-4.0/netapi.h "${pkgdir}"/usr/include/samba-4.0/
mv "${_pkgsrc}"/usr/include/samba-4.0/wbclient.h "${pkgdir}"/usr/include/samba-4.0/
mkdir -p "${pkgdir}"/usr/lib/cups/backend
ln -sf /usr/bin/smbspool "${pkgdir}"/usr/lib/cups/backend/smb
}
package_samba() {
pkgdesc="SMB Fileserver and AD Domain server"
depends=('db>=4.7' 'popt' 'libcups' 'libcap>=2.16' 'gnutls>=2.4.1'
'talloc' 'ldb' 'libbsd' 'python' 'iniparser' 'tdb' 'libaio' 'perl-parse-yapp' "smbclient>=$pkgver" 'gpgme'
'libldb.so' 'libtdb.so' 'libtevent.so' 'liburing' 'libunwind')
backup=(etc/logrotate.d/samba
etc/pam.d/samba
etc/conf.d/samba)
install=samba.install
# Use samba-pkg as a staging directory for the split packages
# (This is so RPATHS and symlinks are generated correctly via
# make install, but the otherwise unsplit pieces can be split)
_pkgsrc="${srcdir}"/samba-pkg
# Everything that libwbclient and smbclient didn't install goes
# into the samba package...
mv "${_pkgsrc}"/* "${pkgdir}"
rmdir "${_pkgsrc}"
# Make admin scripts look in the right place for the samba python module
for script in bin/samba_dnsupdate bin/samba_kcc bin/samba_spnupdate \
bin/samba_upgradedns bin/samba-tool
do
sed -i "/^sys\.path\.insert/ a\
sys.path.insert(0, '/usr/lib/python${_pyver}/site-packages')" \
"${pkgdir}"/usr/${script}
done
# packaging/wscript_build to use /etc/conf.d
sed -i -e '/^EnvironmentFile/ s/sysconfig/conf.d/' "${pkgdir}"/usr/lib/systemd/system/*.service
install -d -m755 "${pkgdir}"/etc/conf.d
install -m644 "${srcdir}"/samba-${pkgver}/packaging/systemd/samba.sysconfig "${pkgdir}"/etc/conf.d/samba
# create ephemeral dirs via tmpfiles rather than shipping them in package
install -D -m644 "${srcdir}"/samba.conf "${pkgdir}"/usr/lib/tmpfiles.d/samba.conf
# create config dir
install -d -m755 "${pkgdir}"/etc/samba
mkdir -p "${pkgdir}"/etc/samba/private
chmod 700 "${pkgdir}"/etc/samba/private
install -D -m644 "${srcdir}"/samba.logrotate "${pkgdir}"/etc/logrotate.d/samba
install -D -m644 "${srcdir}"/samba.pam "${pkgdir}"/etc/pam.d/samba
# spool directory
install -d -m1777 "${pkgdir}"/var/spool/samba
rm -rf "${pkgdir}"/run
rm -rf "${pkgdir}"/var/run
rm -rf "${pkgdir}"/etc/sysconfig
# copy ldap example
install -D -m644 "${srcdir}"/samba-${pkgver}/examples/LDAP/samba.schema "${pkgdir}"/usr/share/doc/samba/examples/LDAP/samba.schema
# Fix waf installing the wrong permissions for sudoers.d
chmod 750 ${pkgdir}/etc/sudoers.d
chmod 750 ${pkgdir}/etc/sudoers.d/ctdb
# Fix waf installing the wrong permissions for sudoers.d
chmod 750 ${pkgdir}/etc/sudoers.d
chmod 440 ${pkgdir}/etc/sudoers.d/ctdb
# install ctdb service
install -D -m644 "${srcdir}"/samba-${pkgver}/ctdb/config/ctdb.service ${pkgdir}/usr/lib/systemd/system/ctdb.service
}
# vim: ts=2 sw=2 et:

View file

@ -1,57 +0,0 @@
From eee9ff0228f52008bfc565241f6dfe07ae7a7044 Mon Sep 17 00:00:00 2001
From: Andreas Schneider <asn@samba.org>
Date: Tue, 2 Aug 2022 07:55:46 +0200
Subject: [PATCH] lib:replace: Only include <sys/mount.h> on non-Linux systems
Details at:
https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
BUG: https://bugzilla.samba.org/show_bug.cgi?id=15132
Signed-off-by: Andreas Schneider <asn@samba.org>
Reviewed-by: Ralph Boehme <slow@samba.org>
(cherry picked from commit 766151bf5b7ef95ae4c8c98b8994e5c21c5bbec0)
---
lib/replace/system/filesys.h | 4 +++-
lib/replace/wscript | 3 +++
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/lib/replace/system/filesys.h b/lib/replace/system/filesys.h
index 034e5d5886c..bb9482c69af 100644
--- a/lib/replace/system/filesys.h
+++ b/lib/replace/system/filesys.h
@@ -36,7 +36,8 @@
#include <sys/param.h>
#endif
-#ifdef HAVE_SYS_MOUNT_H
+/* This include is required on UNIX (*BSD, AIX, ...) for statfs() */
+#if !defined(LINUX) && defined(HAVE_SYS_MOUNT_H)
#include <sys/mount.h>
#endif
@@ -44,6 +45,7 @@
#include <mntent.h>
#endif
+/* This include is required on Linux for statfs() */
#ifdef HAVE_SYS_VFS_H
#include <sys/vfs.h>
#endif
diff --git a/lib/replace/wscript b/lib/replace/wscript
index e4c2d513076..0db93d8caf1 100644
--- a/lib/replace/wscript
+++ b/lib/replace/wscript
@@ -31,6 +31,9 @@ def configure(conf):
conf.env.standalone_replace = conf.IN_LAUNCH_DIR()
+ if sys.platform.rfind('linux') > -1:
+ conf.DEFINE('LINUX', '1')
+
conf.DEFINE('BOOL_DEFINED', 1)
conf.DEFINE('HAVE_LIBREPLACE', 1)
conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
--
2.37.1

View file

@ -1,2 +0,0 @@
D /run/samba 0755 - - -
d /var/log/samba 0755 - - -

View file

@ -1,10 +0,0 @@
#!/bin/sh
post_upgrade() {
if [ "$(vercmp $2 4.0.4)" -lt 0 ]; then
echo "Major upgrade from samba 3.x to 4.x,"
echo "please read the Samba4 migration guide:"
echo "http://wiki.samba.org/index.php/Samba4/samba3upgrade/HOWTO"
fi
}
# vim:set ts=2 sw=2 et:

View file

@ -1,5 +0,0 @@
/var/log/samba/log.smbd /var/log/samba/log.nmbd /var/log/samba/*.log {
notifempty
missingok
copytruncate
}

View file

@ -1,3 +0,0 @@
auth required pam_unix.so
account required pam_unix.so
session required pam_unix.so