mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/gstreamer to 1.22.0-2
This commit is contained in:
parent
bc5a4e3143
commit
ae8c934b82
6 changed files with 111 additions and 255 deletions
|
@ -11,22 +11,22 @@ Subject: [PATCH] HACK: meson: Disable broken tests
|
|||
4 files changed, 4 deletions(-)
|
||||
|
||||
diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
|
||||
index 63ca7e6d0631..f98f1789b9d8 100644
|
||||
index f97b65bfcbc4..c70d6a035355 100644
|
||||
--- a/subprojects/gst-editing-services/meson.build
|
||||
+++ b/subprojects/gst-editing-services/meson.build
|
||||
@@ -273,7 +273,6 @@ subdir('plugins')
|
||||
if not get_option('tools').disabled()
|
||||
subdir('tools')
|
||||
endif
|
||||
@@ -270,7 +270,6 @@ subdir('ges')
|
||||
subdir('plugins')
|
||||
subdir('tools')
|
||||
|
||||
-subdir('tests')
|
||||
if not get_option('examples').disabled()
|
||||
subdir('examples')
|
||||
endif
|
||||
diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
|
||||
index 40e58eded847..a0405c792a1b 100644
|
||||
index d3d472fe0fdb..c1825e49f64d 100644
|
||||
--- a/subprojects/gst-python/meson.build
|
||||
+++ b/subprojects/gst-python/meson.build
|
||||
@@ -104,5 +104,4 @@ if not get_option('plugin').disabled()
|
||||
@@ -106,5 +106,4 @@ if not get_option('plugin').disabled()
|
||||
endif
|
||||
endif
|
||||
if not get_option('tests').disabled()
|
||||
|
@ -45,10 +45,10 @@ index 229af32f8117..b9372c125d77 100644
|
|||
'gst/sessionpool',
|
||||
'gst/stream',
|
||||
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
|
||||
index 322bcac96ad2..194500e3e6c4 100644
|
||||
index 9cd3fcf19cb7..4f8e6d27f9a3 100644
|
||||
--- a/subprojects/gstreamer-vaapi/meson.build
|
||||
+++ b/subprojects/gstreamer-vaapi/meson.build
|
||||
@@ -202,7 +202,6 @@ plugins = []
|
||||
@@ -219,7 +219,6 @@ plugins = []
|
||||
|
||||
subdir('gst-libs')
|
||||
subdir('gst')
|
|
@ -1,84 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Nirbheek Chauhan <nirbheek@centricular.com>
|
||||
Date: Wed, 21 Sep 2022 21:48:31 +0530
|
||||
Subject: [PATCH] meson: Add a new option to control the source for orc
|
||||
|
||||
Previously we were unconditionally cloning the orc subproject because
|
||||
we want the developer environment to use the latest orc. However, some
|
||||
people want to use the system orc instead, or want to auto-detect
|
||||
which to use, with the system orc getting preference. This requires
|
||||
adding a new option to select that. See discussion at:
|
||||
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/2556
|
||||
|
||||
Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1282
|
||||
|
||||
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3062>
|
||||
---
|
||||
meson.build | 22 +++++++++++++++++++++-
|
||||
meson_options.txt | 1 +
|
||||
subprojects/orc.wrap | 3 +++
|
||||
3 files changed, 25 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index bf8415d0aee8..0f0c601d96f0 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -126,7 +126,19 @@ elif build_system == 'darwin'
|
||||
subproject('macos-bison-binary')
|
||||
endif
|
||||
|
||||
-orc_subproject = subproject('orc', required: get_option('orc'))
|
||||
+orc_option = get_option('orc')
|
||||
+# There is a check below to keep this in sync with subprojects/gst-plugins-base/meson.build
|
||||
+orc_req = '>= 0.4.24'
|
||||
+orc_source_option = get_option('orc-source')
|
||||
+orc_subproject = disabler()
|
||||
+if orc_option.allowed()
|
||||
+ if orc_source_option == 'subproject'
|
||||
+ orc_subproject = subproject('orc', required: orc_option)
|
||||
+ else
|
||||
+ dependency('orc-0.4', version: orc_req, required: orc_option,
|
||||
+ allow_fallback: orc_source_option == 'auto')
|
||||
+ endif
|
||||
+endif
|
||||
|
||||
foreach custom_subproj: get_option('custom_subprojects').split(',')
|
||||
if custom_subproj != ''
|
||||
@@ -162,6 +174,14 @@ foreach sp : subprojects
|
||||
subproj = subproject(project_name, required: is_required)
|
||||
endif
|
||||
|
||||
+ if project_name == 'gst-plugins-base'
|
||||
+ gst_base_orc_req = subproj.get_variable('orc_req', '')
|
||||
+ if gst_base_orc_req != orc_req
|
||||
+ error('orc_req is "@0@" but it should be "@1@" from subprojects/gst-plugins-base/meson.build'
|
||||
+ .format(orc_req, gst_base_orc_req))
|
||||
+ endif
|
||||
+ endif
|
||||
+
|
||||
if subproj.found()
|
||||
plugins = subproj.get_variable('plugins', [])
|
||||
all_plugins += plugins
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 7a43f3443098..a2d4203c22ef 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -33,6 +33,7 @@ option('gst-full-device-providers', type : 'string', value : '',
|
||||
description : '''List of device providers to expose in gstreamer-full's ABI with the syntax plugin1:dp1;plugin2:dp1:dp2. By default '' will export all device provider of the enabled plugin.''')
|
||||
option('gst-full-dynamic-types', type : 'string', value : '',
|
||||
description : '''List of dynamic types to expose in gstreamer-full's ABI with the syntax plugin:dt1,dt2. By default '' will export all device provider of the enabled plugin.''')
|
||||
+option('orc-source', type: 'combo', choices: ['system', 'subproject', 'auto'], value: 'subproject')
|
||||
|
||||
# License-related feature options
|
||||
option('gpl', type: 'feature', value: 'disabled',
|
||||
diff --git a/subprojects/orc.wrap b/subprojects/orc.wrap
|
||||
index 690d8e368b38..a3b553a614fa 100644
|
||||
--- a/subprojects/orc.wrap
|
||||
+++ b/subprojects/orc.wrap
|
||||
@@ -3,3 +3,6 @@ directory=orc
|
||||
url=https://gitlab.freedesktop.org/gstreamer/orc.git
|
||||
push-url=git@gitlab.freedesktop.org:gstreamer/orc.git
|
||||
revision=887392103956a8733a750c4442e2664d5c26527d
|
||||
+
|
||||
+[provide]
|
||||
+orc-0.4 = orc_dep
|
|
@ -0,0 +1,25 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
||||
Date: Tue, 24 Jan 2023 02:52:49 +0000
|
||||
Subject: [PATCH] vaapi: Skip plugin pc file for shared plugins
|
||||
|
||||
Following similar logic in the other subprojects.
|
||||
---
|
||||
subprojects/gstreamer-vaapi/meson.build | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
|
||||
index 4f8e6d27f9a3..5f8b5159dee2 100644
|
||||
--- a/subprojects/gstreamer-vaapi/meson.build
|
||||
+++ b/subprojects/gstreamer-vaapi/meson.build
|
||||
@@ -240,6 +240,10 @@ meson.add_dist_script('scripts/gen-changelog.py', meson.project_name(), '1.20.0'
|
||||
|
||||
pkgconfig = import('pkgconfig')
|
||||
plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
|
||||
+if get_option('default_library') == 'shared'
|
||||
+ # If we don't build static plugins there is no need to generate pc files
|
||||
+ plugins_pkgconfig_install_dir = disabler()
|
||||
+endif
|
||||
|
||||
plugin_names = []
|
||||
gst_plugins = []
|
|
@ -1,81 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Nirbheek Chauhan <nirbheek@centricular.com>
|
||||
Date: Wed, 21 Sep 2022 19:19:45 +0530
|
||||
Subject: [PATCH] meson: Use implicit builtin dirs in pkgconfig generation
|
||||
|
||||
Starting with Meson 0.62, meson automatically populates the variables
|
||||
list in the pkgconfig file if you reference builtin directories in the
|
||||
pkgconfig file (whether via a custom pkgconfig variable or elsewhere).
|
||||
We need this, because ${prefix}/libexec is a hard-coded value which is
|
||||
incorrect on, for example, Debian.
|
||||
|
||||
Bump requirement to 0.62, and remove version compares that retained
|
||||
support for older Meson versions.
|
||||
|
||||
Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1245
|
||||
|
||||
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3061>
|
||||
(cherry picked from commit a0e6278dba899f122d806994d47ee0e2c1741b34)
|
||||
|
||||
Removed meson requirement bump to ease backporting, although this is not
|
||||
strictly correct.
|
||||
---
|
||||
subprojects/gst-plugins-base/meson.build | 16 ++++++++--------
|
||||
subprojects/gstreamer/meson.build | 17 ++++++++---------
|
||||
2 files changed, 16 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/subprojects/gst-plugins-base/meson.build b/subprojects/gst-plugins-base/meson.build
|
||||
index 0beccf00459e..1681484bfd54 100644
|
||||
--- a/subprojects/gst-plugins-base/meson.build
|
||||
+++ b/subprojects/gst-plugins-base/meson.build
|
||||
@@ -440,14 +440,14 @@ if get_option('default_library') == 'shared'
|
||||
plugins_pkgconfig_install_dir = disabler()
|
||||
endif
|
||||
|
||||
-pkgconfig_variables = ['exec_prefix=${prefix}',
|
||||
- 'toolsdir=${exec_prefix}/bin',
|
||||
- 'pluginsdir=${libdir}/gstreamer-1.0',
|
||||
- 'datarootdir=${prefix}/share',
|
||||
- 'datadir=${datarootdir}',
|
||||
- 'girdir=${datadir}/gir-1.0',
|
||||
- 'typelibdir=${libdir}/girepository-1.0',
|
||||
- 'libexecdir=${prefix}/libexec']
|
||||
+pkgconfig_variables = [
|
||||
+ 'exec_prefix=${prefix}',
|
||||
+ 'toolsdir=${exec_prefix}/bin',
|
||||
+ 'pluginsdir=${libdir}/gstreamer-1.0',
|
||||
+ 'girdir=${datadir}/gir-1.0',
|
||||
+ 'typelibdir=${libdir}/girepository-1.0',
|
||||
+ 'pluginscannerdir=${libexecdir}/gstreamer-1.0'
|
||||
+]
|
||||
pkgconfig_subdirs = ['gstreamer-1.0']
|
||||
|
||||
meson_pkg_config_file_fixup_script = find_program('scripts/meson-pkg-config-file-fixup.py')
|
||||
diff --git a/subprojects/gstreamer/meson.build b/subprojects/gstreamer/meson.build
|
||||
index ce860ed140e4..adc0ee728a11 100644
|
||||
--- a/subprojects/gstreamer/meson.build
|
||||
+++ b/subprojects/gstreamer/meson.build
|
||||
@@ -579,15 +579,14 @@ if get_option('default_library') == 'shared'
|
||||
# If we don't build static plugins there is no need to generate pc files
|
||||
plugins_pkgconfig_install_dir = disabler()
|
||||
endif
|
||||
-pkgconfig_variables = ['exec_prefix=${prefix}',
|
||||
- 'toolsdir=${exec_prefix}/bin',
|
||||
- 'pluginsdir=${libdir}/gstreamer-1.0',
|
||||
- 'datarootdir=${prefix}/share',
|
||||
- 'datadir=${datarootdir}',
|
||||
- 'girdir=${datadir}/gir-1.0',
|
||||
- 'typelibdir=${libdir}/girepository-1.0',
|
||||
- 'libexecdir=${prefix}/libexec',
|
||||
- 'pluginscannerdir=${libexecdir}/gstreamer-1.0']
|
||||
+pkgconfig_variables = [
|
||||
+ 'exec_prefix=${prefix}',
|
||||
+ 'toolsdir=${exec_prefix}/bin',
|
||||
+ 'pluginsdir=${libdir}/gstreamer-1.0',
|
||||
+ 'girdir=${datadir}/gir-1.0',
|
||||
+ 'typelibdir=${libdir}/girepository-1.0',
|
||||
+ 'pluginscannerdir=${libexecdir}/gstreamer-1.0'
|
||||
+]
|
||||
pkgconfig_uninstalled_variables = ['exec_prefix=${prefix}',
|
||||
'gstreamerdir=${prefix}/subprojects/gstreamer',
|
||||
'bashhelpersdir=${gstreamerdir}/data/bash-completion/helpers',
|
|
@ -6,6 +6,7 @@
|
|||
# - removed libgstsvthevcenc.so from gst-plugins-bad install list
|
||||
# - meson with -D gst-plugins-bad:svthevcenc=disabled
|
||||
# - removed gst-plug-msdk package, meson with -D gst-plugins-bad:msdk=disabled
|
||||
# - removed gst-plug-qsv package, meson with -D gst-plugins-bad:qsv=disabled
|
||||
# - !distcc - build is failing with distcc
|
||||
|
||||
pkgbase=gstreamer
|
||||
|
@ -18,6 +19,7 @@ pkgname=(
|
|||
gst-plugins-bad
|
||||
gst-plugin-gtk
|
||||
gst-plugin-opencv
|
||||
gst-plugin-qml6
|
||||
gst-plugin-qmlgl
|
||||
gst-plugin-va
|
||||
gst-plugin-wpe
|
||||
|
@ -29,13 +31,13 @@ pkgname=(
|
|||
gst-python
|
||||
gstreamer-docs
|
||||
)
|
||||
pkgver=1.20.5
|
||||
pkgrel=5
|
||||
pkgver=1.22.0
|
||||
pkgrel=2
|
||||
pkgdesc="Multimedia graph framework"
|
||||
url="https://gstreamer.freedesktop.org/"
|
||||
arch=(x86_64)
|
||||
license=(LGPL)
|
||||
options=(!distcc)
|
||||
license=(LGPL)
|
||||
makedepends=(
|
||||
# superproject
|
||||
git meson
|
||||
|
@ -45,12 +47,13 @@ makedepends=(
|
|||
|
||||
# gst-plugins-base
|
||||
cdparanoia graphene opus libtheora libxv sdl2 qt5-base qt5-tools zlib libglvnd
|
||||
wayland wayland-protocols libx11 libgudev libdrm mesa orc
|
||||
wayland wayland-protocols libx11 libgudev libdrm mesa orc libxi
|
||||
|
||||
# gst-plugins-good
|
||||
nasm v4l-utils aalib flac jack2 lame libcaca libdv mpg123 libraw1394
|
||||
libavc1394 libiec61883 qt5-declarative qt5-x11extras qt5-wayland libpulse
|
||||
libshout taglib twolame libvpx wavpack cairo libsoup3
|
||||
libshout taglib twolame libvpx wavpack cairo libsoup3 qt6-declarative
|
||||
qt6-wayland qt6-tools nettle
|
||||
|
||||
# gst-plugins-bad
|
||||
opencv vulkan-icd-loader vulkan-headers vulkan-validation-layers shaderc
|
||||
|
@ -58,8 +61,8 @@ makedepends=(
|
|||
libfdk-aac fluidsynth libgme libkate liblrdf ladspa libde265 lilv lv2
|
||||
libmicrodns mjpegtools libmpcdec neon openal libdvdnav rtmpdump sbc soundtouch
|
||||
spandsp libsrtp zvbi libnice webrtc-audio-processing wildmidi
|
||||
zxing-cpp zbar nettle libxml2 gsm libopenmpt wpewebkit libldac libfreeaptx
|
||||
qrencode json-glib libva libxkbcommon-x11
|
||||
zxing-cpp zbar libxml2 gsm libopenmpt wpewebkit libldac libfreeaptx qrencode
|
||||
json-glib libva libxkbcommon-x11
|
||||
|
||||
# gst-plugins-ugly
|
||||
a52dec opencore-amr libcdio libdvdread libmpeg2 libsidplay x264
|
||||
|
@ -74,107 +77,87 @@ makedepends=(
|
|||
python-gobject
|
||||
)
|
||||
checkdepends=(xorg-server-xvfb)
|
||||
options=(debug)
|
||||
_commit=f7806a854aad960eae3288db4a67a574f92428fe # tags/1.20.5^0
|
||||
source=(
|
||||
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git#commit=$_commit"
|
||||
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-${pkgver%%+*}.tar.xz"{,.asc}
|
||||
0001-meson-Add-a-new-option-to-control-the-source-for-orc.patch
|
||||
0002-HACK-meson-Disable-broken-tests.patch
|
||||
0003-Support-zxing-c-2.0.patch
|
||||
0004-meson-Use-implicit-builtin-dirs-in-pkgconfig-generat.patch
|
||||
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git?signed#tag=$pkgver"
|
||||
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-$pkgver.tar.xz"{,.asc}
|
||||
0001-HACK-meson-Disable-broken-tests.patch
|
||||
0002-Support-zxing-c-2.0.patch
|
||||
0003-vaapi-Skip-plugin-pc-file-for-shared-plugins.patch
|
||||
)
|
||||
sha256sums=('SKIP'
|
||||
'b3177d9320e2a1d872b85adf1a29cd4fad995adb4a41a478372419bdd8c87a95'
|
||||
'SKIP'
|
||||
'c2b2fb2ebbb36527f5a43178597367485d95fe58268be043f8a9ebe962147bd9'
|
||||
'2b44fe7562d876d41878c9b513f9d36fbac43fa1c42db3ad2df309ced644de87'
|
||||
'4c96b339cf9d76785532bcd6067e73f2f45d03d593b1475da18a0d229d1a9f31'
|
||||
'8e4e90dbb0b29ee8ec4afee0482a86392858619178c55b9eebda4992f3e92da2')
|
||||
b2sums=('SKIP'
|
||||
'78152f7dccbefa6a8bb2c844b4ef4e1eab97c6e54a017bbe896fe3afb646942449a87387c66499f454e968b63f00a8040c9360ca7248c6dd7819228cf22fd94f'
|
||||
'SKIP'
|
||||
'a90340cd3285882fb8416aae8bce44e3354e43790b947c93c749bc6dce8fa74c900ae933eb24ec872b319dffe16d42eaef6f6d41ddeccd61ea093b2b46e89e3b'
|
||||
'88af02805ab7a0a6f79fd1fbf56206b6325f1bbeef9415d8bead83331dc04bddf28f4731bc1ab60b37fc7bd1473547838f4de930d9179e842b6190aee7e068a4'
|
||||
'621ed5ad8051fa513c8ebd987b5a856bf4468f7d0150673783b4010b5c87b0a5ec7f62e402bbea1de493c5d029f3c3f1897cf9289e2168c430632e12ff80c423')
|
||||
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
|
||||
|
||||
pkgver() {
|
||||
cd gstreamer
|
||||
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd gstreamer
|
||||
|
||||
# Fix build with opencv 4.7
|
||||
git cherry-pick -n 8d5ac30955cf052a12ef8c87c0cae6d124d4d7b6
|
||||
|
||||
# Fix build with zxing-cpp 1.4
|
||||
git cherry-pick -n 7cfc3130a7906c199861d2ef331a07d749a4b769
|
||||
|
||||
# Fix linking with system orc
|
||||
git apply -3 ../0001-meson-Add-a-new-option-to-control-the-source-for-orc.patch
|
||||
|
||||
# Disable broken tests
|
||||
git apply -3 ../0002-HACK-meson-Disable-broken-tests.patch
|
||||
git apply -3 ../0001-HACK-meson-Disable-broken-tests.patch
|
||||
|
||||
# Fix build with zxing-cpp 2.0
|
||||
git apply -3 ../0003-Support-zxing-c-2.0.patch
|
||||
git apply -3 ../0002-Support-zxing-c-2.0.patch
|
||||
|
||||
# Fix pkgconfig variables
|
||||
# https://bugs.archlinux.org/task/77031
|
||||
git apply -3 ../0004-meson-Use-implicit-builtin-dirs-in-pkgconfig-generat.patch
|
||||
# Fix install
|
||||
git apply -3 ../0003-vaapi-Skip-plugin-pc-file-for-shared-plugins.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
local meson_options=(
|
||||
# Superproject options
|
||||
-D devtools=disabled
|
||||
-D doc=disabled
|
||||
-D examples=disabled
|
||||
-D gobject-cast-checks=disabled
|
||||
-D gpl=enabled
|
||||
-D gst-examples=disabled
|
||||
-D libnice=disabled
|
||||
-D orc-source=system
|
||||
-D package-origin="https://www.archlinux.org/"
|
||||
-D vaapi=enabled
|
||||
-D gstreamer:dbghelp=disabled
|
||||
-D gstreamer:gobject-cast-checks=disabled
|
||||
|
||||
# Package names
|
||||
-D gstreamer:package-name="Arch Linux gstreamer $pkgver-$pkgrel"
|
||||
-D gstreamer:package-origin="https://www.archlinux.org/"
|
||||
-D gstreamer:ptp-helper-permissions=capabilities
|
||||
-D gst-plugins-base:gobject-cast-checks=disabled
|
||||
-D gst-plugins-base:package-name="Arch Linux gst-plugins-base $pkgver-$pkgrel"
|
||||
-D gst-plugins-base:package-origin="https://www.archlinux.org/"
|
||||
-D gst-plugins-good:package-name="Arch Linux gst-plugins-good $pkgver-$pkgrel"
|
||||
-D gst-plugins-bad:package-name="Arch Linux gst-plugins-bad $pkgver-$pkgrel"
|
||||
-D gst-plugins-ugly:package-name="Arch Linux gst-plugins-ugly $pkgver-$pkgrel"
|
||||
-D gst-libav:package-name="Arch Linux gst-libav $pkgver-$pkgrel"
|
||||
-D gst-rtsp-server:package-name="Arch Linux gst-rtsp-server $pkgver-$pkgrel"
|
||||
|
||||
# Subproject options
|
||||
-D gstreamer:dbghelp=disabled
|
||||
-D gstreamer:ptp-helper-permissions=capabilities
|
||||
-D gst-plugins-base:libvisual=disabled
|
||||
-D gst-plugins-base:tremor=disabled
|
||||
-D gst-plugins-good:gobject-cast-checks=disabled
|
||||
-D gst-plugins-good:package-name="Arch Linux gst-plugins-good $pkgver-$pkgrel"
|
||||
-D gst-plugins-good:package-origin="https://www.archlinux.org/"
|
||||
-D gst-plugins-good:rpicamsrc=disabled
|
||||
-D gst-plugins-bad:amfcodec=disabled
|
||||
-D gst-plugins-bad:directfb=disabled
|
||||
-D gst-plugins-bad:directshow=disabled
|
||||
-D gst-plugins-bad:directsound=disabled
|
||||
-D gst-plugins-bad:flite=disabled
|
||||
-D gst-plugins-bad:gobject-cast-checks=disabled
|
||||
-D gst-plugins-bad:gs=disabled
|
||||
-D gst-plugins-bad:iqa=disabled
|
||||
-D gst-plugins-bad:isac=disabled
|
||||
-D gst-plugins-bad:magicleap=disabled
|
||||
-D gst-plugins-bad:msdk=disabled
|
||||
-D gst-plugins-bad:svthevcenc=disabled
|
||||
-D gst-plugins-bad:onnx=disabled
|
||||
-D gst-plugins-bad:openh264=disabled
|
||||
-D gst-plugins-bad:openni2=disabled
|
||||
-D gst-plugins-bad:opensles=disabled
|
||||
-D gst-plugins-bad:package-name="Arch Linux gst-plugins-bad $pkgver-$pkgrel"
|
||||
-D gst-plugins-bad:package-origin="https://www.archlinux.org/"
|
||||
-D gst-plugins-bad:svthevcenc=disabled
|
||||
-D gst-plugins-bad:qsv=disabled
|
||||
-D gst-plugins-bad:tinyalsa=disabled
|
||||
-D gst-plugins-bad:voaacenc=disabled
|
||||
-D gst-plugins-bad:voamrwbenc=disabled
|
||||
-D gst-plugins-bad:wasapi2=disabled
|
||||
-D gst-plugins-bad:wasapi=disabled
|
||||
-D gst-plugins-ugly:gobject-cast-checks=disabled
|
||||
-D gst-plugins-ugly:package-name="Arch Linux gst-plugins-ugly $pkgver-$pkgrel"
|
||||
-D gst-plugins-ugly:package-origin="https://www.archlinux.org/"
|
||||
-D gst-libav:package-name="Arch Linux gst-libav $pkgver-$pkgrel"
|
||||
-D gst-libav:package-origin="https://www.archlinux.org/"
|
||||
-D gst-rtsp-server:gobject-cast-checks=disabled
|
||||
-D gst-rtsp-server:package-name="Arch Linux gst-rtsp-server $pkgver-$pkgrel"
|
||||
-D gst-rtsp-server:package-origin="https://www.archlinux.org/"
|
||||
-D gst-plugins-bad:wic=disabled
|
||||
-D gst-plugins-bad:win32ipc=disabled
|
||||
-D gst-editing-services:validate=disabled
|
||||
-D gstreamer-vaapi:package-origin="https://www.archlinux.org/"
|
||||
)
|
||||
|
||||
arch-meson gstreamer build "${meson_options[@]}"
|
||||
|
@ -188,7 +171,7 @@ check() (
|
|||
|
||||
# Flaky due to timeouts
|
||||
xvfb-run -s '-nolisten local' \
|
||||
meson test -C build --print-errorlogs
|
||||
meson test -C build --print-errorlogs -t 3
|
||||
)
|
||||
|
||||
_install() {
|
||||
|
@ -241,16 +224,17 @@ package_gst-plugins-bad-libs() {
|
|||
pkgdesc+=" - bad"
|
||||
depends=(
|
||||
"gst-plugins-base-libs=$pkgver"
|
||||
orc libdrm libx11 libgudev libusb libxkbcommon-x11
|
||||
orc libdrm libx11 libgudev libusb libxkbcommon-x11 libva libnice
|
||||
)
|
||||
|
||||
cd root; local files=(
|
||||
usr/include/gstreamer-1.0/gst/audio/{audio-bad-prelude,gstnonstreamaudiodecoder,gstplanaraudioadapter}.h
|
||||
usr/include/gstreamer-1.0/gst/{basecamerabinsrc,codecparsers,insertbin,interfaces,isoff,mpegts,play,player,sctp,transcoder,uridownloader,vulkan,wayland,webrtc}
|
||||
usr/lib/libgst{adaptivedemux,badaudio,basecamerabinsrc,codecparsers,codecs,insertbin,isoff,mpegts,photography,play,player,sctp,transcoder,uridownloader,vulkan,wayland,webrtc}-1.0.so*
|
||||
usr/lib/pkgconfig/gstreamer-{bad-audio,codecparsers,insertbin,mpegts,photography,play,player,sctp,transcoder,vulkan{,-wayland,-xcb},wayland,webrtc}-1.0.pc
|
||||
usr/lib/girepository-1.0/Gst{BadAudio,Codecs,InsertBin,Mpegts,Play,Player,Transcoder,Vulkan{,Wayland,XCB},WebRTC}-1.0.typelib
|
||||
usr/share/gir-1.0/Gst{BadAudio,Codecs,InsertBin,Mpegts,Play,Player,Transcoder,Vulkan{,Wayland,XCB},WebRTC}-1.0.gir
|
||||
usr/include/gstreamer-1.0/gst/{basecamerabinsrc,codecparsers,cuda,insertbin,interfaces,isoff,mpegts,play,player,sctp,transcoder,uridownloader,va,vulkan,wayland,webrtc}
|
||||
usr/lib/libgst{adaptivedemux,badaudio,basecamerabinsrc,codecparsers,codecs,cuda,insertbin,isoff,mpegts}-1.0.so*
|
||||
usr/lib/libgst{photography,play,player,sctp,transcoder,uridownloader,va,vulkan,wayland,webrtc,webrtcnice}-1.0.so*
|
||||
usr/lib/pkgconfig/gstreamer-{bad-audio,codecparsers,cuda,insertbin,mpegts,photography,play,player,sctp,transcoder,vulkan{,-wayland,-xcb},va,wayland,webrtc{,-nice}}-1.0.pc
|
||||
usr/lib/girepository-1.0/{CudaGst,Gst{BadAudio,Codecs,Cuda,InsertBin,Mpegts,Play,Player,Transcoder,Va,Vulkan{,Wayland,XCB},WebRTC}}-1.0.typelib
|
||||
usr/share/gir-1.0/{CudaGst,Gst{BadAudio,Codecs,Cuda,InsertBin,Mpegts,Play,Player,Transcoder,Va,Vulkan{,Wayland,XCB},WebRTC}}-1.0.gir
|
||||
|
||||
usr/lib/pkgconfig/gstreamer-plugins-bad-1.0.pc
|
||||
usr/lib/gstreamer-1.0/libgstaccurip.so
|
||||
|
@ -268,6 +252,7 @@ package_gst-plugins-bad-libs() {
|
|||
usr/lib/gstreamer-1.0/libgstbluez.so
|
||||
usr/lib/gstreamer-1.0/libgstcamerabin.so
|
||||
usr/lib/gstreamer-1.0/libgstcodecalpha.so
|
||||
usr/lib/gstreamer-1.0/libgstcodectimestamper.so
|
||||
usr/lib/gstreamer-1.0/libgstcoloreffects.so
|
||||
usr/lib/gstreamer-1.0/libgstdebugutilsbad.so
|
||||
usr/lib/gstreamer-1.0/libgstdecklink.so
|
||||
|
@ -342,7 +327,7 @@ package_gst-plugins-base-libs() {
|
|||
pkgdesc+=" - base"
|
||||
depends=(
|
||||
"gstreamer=$pkgver"
|
||||
orc libxv iso-codes libgudev libgl mesa
|
||||
orc libxv iso-codes libgudev libgl mesa libxi
|
||||
)
|
||||
|
||||
cd root; local files=(
|
||||
|
@ -371,9 +356,8 @@ package_gst-plugins-base-libs() {
|
|||
usr/lib/gstreamer-1.0/libgstsubparse.so
|
||||
usr/lib/gstreamer-1.0/libgsttcp.so
|
||||
usr/lib/gstreamer-1.0/libgsttypefindfunctions.so
|
||||
usr/lib/gstreamer-1.0/libgstvideoconvert.so
|
||||
usr/lib/gstreamer-1.0/libgstvideoconvertscale.so
|
||||
usr/lib/gstreamer-1.0/libgstvideorate.so
|
||||
usr/lib/gstreamer-1.0/libgstvideoscale.so
|
||||
usr/lib/gstreamer-1.0/libgstvideotestsrc.so
|
||||
usr/lib/gstreamer-1.0/libgstvolume.so
|
||||
usr/lib/gstreamer-1.0/libgstximagesink.so
|
||||
|
@ -413,13 +397,14 @@ package_gst-plugins-good() {
|
|||
"gst-plugins-base-libs=$pkgver"
|
||||
libpulse libsoup3 gst-plugins-base-libs wavpack aalib taglib libdv libshout
|
||||
libvpx gdk-pixbuf2 libcaca libavc1394 libiec61883 libxdamage v4l-utils cairo
|
||||
libgudev speex flac libraw1394 lame mpg123 twolame
|
||||
libgudev speex flac libraw1394 lame mpg123 twolame nettle
|
||||
libjack.so
|
||||
)
|
||||
|
||||
cd root; local files=(
|
||||
usr/lib/gstreamer-1.0/libgst1394.so
|
||||
usr/lib/gstreamer-1.0/libgstaasink.so
|
||||
usr/lib/gstreamer-1.0/libgstadaptivedemux2.so
|
||||
usr/lib/gstreamer-1.0/libgstalaw.so
|
||||
usr/lib/gstreamer-1.0/libgstalpha.so
|
||||
usr/lib/gstreamer-1.0/libgstalphacolor.so
|
||||
|
@ -487,6 +472,7 @@ package_gst-plugins-good() {
|
|||
usr/lib/gstreamer-1.0/libgstwavpack.so
|
||||
usr/lib/gstreamer-1.0/libgstwavparse.so
|
||||
usr/lib/gstreamer-1.0/libgstximagesrc.so
|
||||
usr/lib/gstreamer-1.0/libgstxingmux.so
|
||||
usr/lib/gstreamer-1.0/libgsty4menc.so
|
||||
|
||||
usr/share/gstreamer-1.0/presets/GstIirEqualizer{3,10}Bands.prs
|
||||
|
@ -505,7 +491,7 @@ package_gst-plugins-bad() {
|
|||
libkate liblrdf lilv libmodplug mjpegtools libmpcdec neon openal openexr
|
||||
openjpeg2 opus libdvdnav libdvdread librsvg rtmpdump sbc libsndfile libltc
|
||||
soundtouch spandsp srt libsrtp zvbi vulkan-icd-loader libxcb wayland libwebp
|
||||
libnice webrtc-audio-processing wildmidi x265 zbar gsm libopenmpt libldac
|
||||
webrtc-audio-processing wildmidi x265 zbar gsm libopenmpt libldac
|
||||
libfreeaptx qrencode json-glib libavtp libmicrodns zxing-cpp
|
||||
)
|
||||
|
||||
|
@ -577,10 +563,11 @@ package_gst-plugins-bad() {
|
|||
|
||||
package_gst-plugin-gtk() {
|
||||
pkgdesc+=" - gtk plugin"
|
||||
depends=("gst-plugins-base-libs=$pkgver" gtk3)
|
||||
depends=("gst-plugins-bad-libs=$pkgver" gtk3)
|
||||
|
||||
cd root; local files=(
|
||||
usr/lib/gstreamer-1.0/libgstgtk.so
|
||||
usr/lib/gstreamer-1.0/libgstgtkwayland.so
|
||||
); _install
|
||||
}
|
||||
|
||||
|
@ -596,6 +583,18 @@ package_gst-plugin-opencv() {
|
|||
); _install
|
||||
}
|
||||
|
||||
package_gst-plugin-qml6() {
|
||||
pkgdesc+=" - qml6 plugin"
|
||||
depends=(
|
||||
"gst-plugins-base-libs=$pkgver"
|
||||
qt6-declarative qt6-wayland
|
||||
)
|
||||
|
||||
cd root; local files=(
|
||||
usr/lib/gstreamer-1.0/libgstqml6.so
|
||||
); _install
|
||||
}
|
||||
|
||||
package_gst-plugin-qmlgl() {
|
||||
pkgdesc+=" - qmlgl plugin"
|
||||
depends=(
|
||||
|
@ -610,11 +609,9 @@ package_gst-plugin-qmlgl() {
|
|||
|
||||
package_gst-plugin-va() {
|
||||
pkgdesc+=" - va plugin"
|
||||
depends=("gst-plugins-bad-libs=$pkgver" libva)
|
||||
depends=("gst-plugins-bad-libs=$pkgver")
|
||||
|
||||
cd root; local files=(
|
||||
usr/lib/libgstva-1.0.so*
|
||||
|
||||
usr/lib/gstreamer-1.0/libgstva.so
|
||||
); _install
|
||||
}
|
||||
|
@ -649,7 +646,6 @@ package_gst-plugins-ugly() {
|
|||
usr/lib/gstreamer-1.0/libgstrealmedia.so
|
||||
usr/lib/gstreamer-1.0/libgstsid.so
|
||||
usr/lib/gstreamer-1.0/libgstx264.so
|
||||
usr/lib/gstreamer-1.0/libgstxingmux.so
|
||||
|
||||
usr/share/gstreamer-1.0/presets/Gst{Amrnb,X264}Enc.prs
|
||||
|
||||
|
@ -710,7 +706,7 @@ package_gst-editing-services() {
|
|||
|
||||
package_gstreamer-vaapi() {
|
||||
pkgdesc+=" - vaapi plugin"
|
||||
depends=("gst-plugins-bad-libs=$pkgver" libva libxrandr)
|
||||
depends=("gst-plugins-bad-libs=$pkgver" libxrandr)
|
||||
|
||||
cd root; local files=(
|
||||
usr/lib/gstreamer-1.0/libgstvaapi.so
|
||||
|
|
Loading…
Reference in a new issue