mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/gcc to 11.2.0-3
This commit is contained in:
parent
edd3a6d88a
commit
aea14ea84a
5 changed files with 31 additions and 319 deletions
|
@ -1,8 +1,10 @@
|
|||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
|
||||
# Maintainer: Frederik Schwan <freswa at archlinux dot org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: Daniel Kozak <kozzi11@gmail.com>
|
||||
|
||||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
|
||||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->glibc->binutils->gcc
|
||||
# NOTE: libtool requires rebuilt with each new gcc version
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -15,7 +17,7 @@
|
|||
noautobuild=1
|
||||
|
||||
pkgname=(gcc gcc-libs gcc-fortran gcc-objc gcc-go gcc-d)
|
||||
pkgver=11.1.0
|
||||
pkgver=11.2.0
|
||||
_majorver=${pkgver%%.*}
|
||||
_islver=0.24
|
||||
pkgrel=3
|
||||
|
@ -23,36 +25,29 @@ pkgdesc='The GNU Compiler Collection'
|
|||
arch=(x86_64)
|
||||
license=(GPL LGPL FDL custom)
|
||||
url='https://gcc.gnu.org'
|
||||
makedepends=(binutils libmpc doxygen python git libxcrypt)
|
||||
checkdepends=(dejagnu inetutils)
|
||||
options=(!emptydirs !distcc)
|
||||
makedepends=(binutils libmpc gcc-ada doxygen lib32-glibc lib32-gcc-libs python git libxcrypt zstd)
|
||||
checkdepends=(dejagnu inetutils tcl expect python-pytest)
|
||||
options=(!emptydirs !lto debug !distcc)
|
||||
_libdir=usr/lib/gcc/$CHOST/${pkgver%%+*}
|
||||
# _commit=6beb39ee6c465c21d0cc547fd66b445100cdcc35
|
||||
# source=(git://gcc.gnu.org/git/gcc.git#commit=$_commit
|
||||
source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
|
||||
http://isl.gforge.inria.fr/isl-${_islver}.tar.xz
|
||||
https://libisl.sourceforge.io/isl-${_islver}.tar.xz
|
||||
c89 c99
|
||||
gdc_phobos_path.patch
|
||||
fs64270.patch
|
||||
ipa-fix-bit-CPP-when-combined-with-IPA-bit-CP.patch
|
||||
ipa-fix-ICE-in-get_default_value.patch
|
||||
gcc-ada-repro.patch
|
||||
gcc11-Wno-format-security.patch)
|
||||
)
|
||||
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
|
||||
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
|
||||
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
|
||||
D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
|
||||
sha256sums=('4c4a6fb8a8396059241c2e674b85b351c26a5d678274007f076957afa1cc9ddf'
|
||||
sha256sums=('d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
|
||||
'SKIP'
|
||||
'043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad'
|
||||
'de48736f6e4153f03d0a5d38ceb6c6fdb7f054e8f47ddd6af0a3dbf14f27b931'
|
||||
'2513c6d9984dd0a2058557bf00f06d8d5181734e41dcfe07be7ed86f2959622a'
|
||||
'c86372c207d174c0918d4aedf1cb79f7fc093649eb1ad8d9450dccc46849d308'
|
||||
'1ef190ed4562c4db8c1196952616cd201cfdd788b65f302ac2cc4dabb4d72cee'
|
||||
'fcb11c9bcea320afd202b031b48f8750aeaedaa4b0c5dddcd2c0a16381e927e4'
|
||||
'42865f2af3f48140580c4ae70b6ea03b5bdca0f29654773ef0d42ce00d60ea16'
|
||||
'1773f5137f08ac1f48f0f7297e324d5d868d55201c03068670ee4602babdef2f'
|
||||
'504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e')
|
||||
'1773f5137f08ac1f48f0f7297e324d5d868d55201c03068670ee4602babdef2f')
|
||||
|
||||
prepare() {
|
||||
[[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
|
||||
|
@ -74,14 +69,11 @@ prepare() {
|
|||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
||||
|
||||
# D hacks
|
||||
patch -p1 -i "$srcdir/gdc_phobos_path.patch"
|
||||
patch -Np1 -i "$srcdir/gdc_phobos_path.patch"
|
||||
|
||||
# Reproducible gcc-ada
|
||||
patch -Np0 < "$srcdir/gcc-ada-repro.patch"
|
||||
|
||||
# configure.ac: When adding -Wno-format, also add -Wno-format-security
|
||||
patch -Np0 < "$srcdir/gcc11-Wno-format-security.patch"
|
||||
|
||||
# ALARM: Specify build host types, triplet patch
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=neon"
|
||||
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a --enable-fix-cortex-a53-835769 --enable-fix-cortex-a53-843419"
|
||||
|
@ -92,10 +84,11 @@ prepare() {
|
|||
build() {
|
||||
cd gcc-build
|
||||
|
||||
# using -pipe causes spurious test-suite failures
|
||||
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
|
||||
CFLAGS=${CFLAGS/-pipe/}
|
||||
CXXFLAGS=${CXXFLAGS/-pipe/}
|
||||
# Credits @allanmcrae
|
||||
# https://github.com/allanmcrae/toolchain/blob/f18604d70c5933c31b51a320978711e4e6791cf1/gcc/PKGBUILD
|
||||
# TODO: properly deal with the build issues resulting from this
|
||||
CFLAGS=${CFLAGS/-Werror=format-security/}
|
||||
CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
|
||||
|
||||
"$srcdir/gcc/configure" --prefix=/usr \
|
||||
--libdir=/usr/lib \
|
||||
|
@ -114,7 +107,6 @@ build() {
|
|||
--enable-default-ssp \
|
||||
--enable-gnu-indirect-function \
|
||||
--enable-gnu-unique-object \
|
||||
--enable-install-libiberty \
|
||||
--enable-linker-build-id \
|
||||
--enable-lto \
|
||||
--enable-plugin \
|
||||
|
@ -122,33 +114,36 @@ build() {
|
|||
--enable-threads=posix \
|
||||
--disable-libssp \
|
||||
--disable-libstdcxx-pch \
|
||||
--disable-libunwind-exceptions \
|
||||
--disable-multilib \
|
||||
--disable-werror \
|
||||
$CONFIGFLAG \
|
||||
gdc_include_dir=/usr/include/dlang/gdc
|
||||
|
||||
make
|
||||
# see https://bugs.archlinux.org/task/71777 for rationale re *FLAGS handling
|
||||
make -O STAGE1_CFLAGS="-O2" \
|
||||
BOOT_CFLAGS="$CFLAGS" \
|
||||
BOOT_LDFLAGS="$LDFLAGS" \
|
||||
LDFLAGS_FOR_TARGET="$LDFLAGS"
|
||||
|
||||
# make documentation
|
||||
make -C $CHOST/libstdc++-v3/doc doc-man-doxygen
|
||||
make -O -C $CHOST/libstdc++-v3/doc doc-man-doxygen
|
||||
}
|
||||
|
||||
check() {
|
||||
cd gcc-build
|
||||
|
||||
# disable libphobos test to avoid segfaults and other unfunny ways to waste my time
|
||||
sed -i '/maybe-check-target-libphobos \\/d' Makefile
|
||||
# disable libphobos test to avoid segfaults and other unfunny ways to waste my time
|
||||
sed -i '/maybe-check-target-libphobos \\/d' Makefile
|
||||
|
||||
# do not abort on error as some are "expected"
|
||||
make -k check || true
|
||||
make -O -k check || true
|
||||
"$srcdir/gcc/contrib/test_summary"
|
||||
}
|
||||
|
||||
package_gcc-libs() {
|
||||
pkgdesc='Runtime libraries shipped by GCC'
|
||||
depends=('glibc>=2.27')
|
||||
options+=(!strip)
|
||||
options=(!emptydirs !strip)
|
||||
provides=(libgo.so libgfortran.so libgphobos.so
|
||||
libubsan.so libasan.so liblsan.so)
|
||||
replaces=(libgphobos)
|
||||
|
@ -196,9 +191,9 @@ package_gcc-libs() {
|
|||
|
||||
package_gcc() {
|
||||
pkgdesc="The GNU Compiler Collection - C and C++ frontends"
|
||||
depends=("gcc-libs=$pkgver-$pkgrel" 'binutils>=2.28' libmpc)
|
||||
depends=("gcc-libs=$pkgver-$pkgrel" 'binutils>=2.28' libmpc zstd)
|
||||
groups=('base-devel')
|
||||
options+=(staticlibs)
|
||||
options=(!emptydirs staticlibs debug)
|
||||
|
||||
cd gcc-build
|
||||
|
||||
|
@ -240,9 +235,6 @@ package_gcc() {
|
|||
fi
|
||||
make -C $CHOST/libsanitizer/lsan DESTDIR="$pkgdir" install-nodist_toolexeclibHEADERS
|
||||
|
||||
make -C libiberty DESTDIR="$pkgdir" install
|
||||
install -m644 libiberty/pic/libiberty.a "$pkgdir/usr/lib"
|
||||
|
||||
make -C gcc DESTDIR="$pkgdir" install-man install-info
|
||||
rm "$pkgdir"/usr/share/man/man1/{gccgo,gfortran,gdc}.1
|
||||
rm "$pkgdir"/usr/share/info/{gccgo,gfortran,gdc}.info
|
||||
|
@ -329,7 +321,7 @@ package_gcc-d() {
|
|||
depends=("gcc=$pkgver-$pkgrel")
|
||||
provides=(gdc)
|
||||
replaces=(gdc)
|
||||
options=('staticlibs')
|
||||
options=(staticlibs debug)
|
||||
|
||||
cd gcc-build
|
||||
make -C gcc DESTDIR="$pkgdir" d.install-{common,man,info}
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
Disable ssp on -nostdlib, -nodefaultlibs and -ffreestanding
|
||||
|
||||
--- a/gcc/gcc.c 2017-07-04 09:15:57.740793000 +0200
|
||||
+++ b/gcc/gcc.c 2018-03-02 13:58:44.387741114 +0100
|
||||
@@ -857,6 +857,12 @@ proper position among the other output f
|
||||
#define LINK_GCC_C_SEQUENCE_SPEC "%G %L %G"
|
||||
#endif
|
||||
|
||||
+#ifdef ENABLE_DEFAULT_SSP
|
||||
+#define NO_SSP_SPEC "%{nostdlib|nodefaultlibs|ffreestanding:-fno-stack-protector} "
|
||||
+#else
|
||||
+#define NO_SSP_SPEC ""
|
||||
+#endif
|
||||
+
|
||||
#ifndef LINK_SSP_SPEC
|
||||
#ifdef TARGET_LIBC_PROVIDES_SSP
|
||||
#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
|
||||
@@ -1131,7 +1148,7 @@ static const char *cc1_options =
|
||||
%{-version:--version}\
|
||||
%{-help=*:--help=%*}\
|
||||
%{!fsyntax-only:%{S:%W{o*}%{!o*:-o %b.s}}}\
|
||||
- %{fsyntax-only:-o %j} %{-param*}\
|
||||
+ %{fsyntax-only:-o %j} %{-param*} " NO_SSP_SPEC "\
|
||||
%{coverage:-fprofile-arcs -ftest-coverage}\
|
||||
%{fprofile-arcs|fprofile-generate*|coverage:\
|
||||
%{!fprofile-update=singel:\
|
|
@ -1,27 +0,0 @@
|
|||
2017-02-25 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* configure.ac: When adding -Wno-format, also add -Wno-format-security.
|
||||
* configure: Regenerated.
|
||||
|
||||
--- gcc/configure.ac.jj 2017-02-13 12:20:53.000000000 +0100
|
||||
+++ gcc/configure.ac 2017-02-25 12:42:32.859175403 +0100
|
||||
@@ -480,7 +480,7 @@ AC_ARG_ENABLE(build-format-warnings,
|
||||
AS_HELP_STRING([--disable-build-format-warnings],[don't use -Wformat while building GCC]),
|
||||
[],[enable_build_format_warnings=yes])
|
||||
AS_IF([test $enable_build_format_warnings = no],
|
||||
- [wf_opt=-Wno-format],[wf_opt=])
|
||||
+ [wf_opt="-Wno-format -Wno-format-security"],[wf_opt=])
|
||||
ACX_PROG_CXX_WARNING_OPTS(
|
||||
m4_quote(m4_do([-W -Wall -Wno-narrowing -Wwrite-strings ],
|
||||
[-Wcast-qual -Wno-error=format-diag $wf_opt])),
|
||||
--- gcc/configure.jj 2017-02-13 12:20:52.000000000 +0100
|
||||
+++ gcc/configure 2017-02-25 12:42:50.041946391 +0100
|
||||
@@ -6647,7 +6647,7 @@ else
|
||||
fi
|
||||
|
||||
if test $enable_build_format_warnings = no; then :
|
||||
- wf_opt=-Wno-format
|
||||
+ wf_opt="-Wno-format -Wno-format-security"
|
||||
else
|
||||
wf_opt=
|
||||
fi
|
|
@ -1,80 +0,0 @@
|
|||
From f91770216eade83f068528c1e4f00e2ac3b23044 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Liska <mliska@suse.cz>
|
||||
Date: Thu, 13 Aug 2020 09:38:41 +0200
|
||||
Subject: [PATCH] ipa: fix ICE in get_default_value
|
||||
|
||||
The patch aligns code with ipcp_bits_lattice::set_to_constant
|
||||
where we properly mask m_value with m_mask. The same should
|
||||
be done here.
|
||||
|
||||
gcc/ChangeLog:
|
||||
|
||||
PR ipa/96482
|
||||
* ipa-cp.c (ipcp_bits_lattice::meet_with_1): Mask m_value
|
||||
with m_mask.
|
||||
|
||||
gcc/testsuite/ChangeLog:
|
||||
|
||||
PR ipa/96482
|
||||
* gcc.dg/ipa/pr96482-2.c: New test.
|
||||
---
|
||||
gcc/ipa-cp.c | 2 +-
|
||||
gcc/testsuite/gcc.dg/ipa/pr96482-2.c | 33 ++++++++++++++++++++++++++++
|
||||
2 files changed, 34 insertions(+), 1 deletion(-)
|
||||
create mode 100644 gcc/testsuite/gcc.dg/ipa/pr96482-2.c
|
||||
|
||||
diff --git a/gcc/ipa-cp.c b/gcc/ipa-cp.c
|
||||
index 2b21280d919..e4910a04ffa 100644
|
||||
--- a/gcc/ipa-cp.c
|
||||
+++ b/gcc/ipa-cp.c
|
||||
@@ -1048,7 +1048,7 @@ ipcp_bits_lattice::meet_with_1 (widest_int value, widest_int mask,
|
||||
|
||||
widest_int old_mask = m_mask;
|
||||
m_mask = (m_mask | mask) | (m_value ^ value);
|
||||
- m_value &= value;
|
||||
+ m_value &= ~m_mask;
|
||||
|
||||
if (wi::sext (m_mask, precision) == -1)
|
||||
return set_to_bottom ();
|
||||
diff --git a/gcc/testsuite/gcc.dg/ipa/pr96482-2.c b/gcc/testsuite/gcc.dg/ipa/pr96482-2.c
|
||||
new file mode 100644
|
||||
index 00000000000..54b71ac4fc0
|
||||
--- /dev/null
|
||||
+++ b/gcc/testsuite/gcc.dg/ipa/pr96482-2.c
|
||||
@@ -0,0 +1,33 @@
|
||||
+/* PR ipa/96482 */
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-O2" } */
|
||||
+
|
||||
+int i2c_transfer();
|
||||
+void _dev_err();
|
||||
+
|
||||
+struct i2c_msg {
|
||||
+ char bufaddr;
|
||||
+ int adapterdev;
|
||||
+} wdt87xx_i2c_xfer_client;
|
||||
+
|
||||
+int wdt87xx_i2c_xfer_client_0, wdt87xx_i2c_xfer_rxdata, wdt87xx_get_string_str_idx;
|
||||
+
|
||||
+void
|
||||
+static wdt87xx_i2c_xfer(void *txdata, unsigned rxlen) {
|
||||
+ struct i2c_msg msgs[] = {wdt87xx_i2c_xfer_client_0, rxlen,
|
||||
+ wdt87xx_i2c_xfer_rxdata};
|
||||
+ int error = i2c_transfer(wdt87xx_i2c_xfer_client, msgs);
|
||||
+ _dev_err("", __func__, error);
|
||||
+}
|
||||
+static void wdt87xx_get_string(unsigned len) {
|
||||
+ char tx_buf[] = {wdt87xx_get_string_str_idx, 3};
|
||||
+ int rx_len = len + 2;
|
||||
+ wdt87xx_i2c_xfer(tx_buf, rx_len);
|
||||
+}
|
||||
+
|
||||
+void
|
||||
+wdt87xx_ts_probe_tx_buf() {
|
||||
+ wdt87xx_get_string(34);
|
||||
+ wdt87xx_get_string(8);
|
||||
+ wdt87xx_i2c_xfer(wdt87xx_ts_probe_tx_buf, 2);
|
||||
+}
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,147 +0,0 @@
|
|||
From d58f078ce2d53e5dab6b3d0d5f960504268e1894 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Liska <mliska@suse.cz>
|
||||
Date: Wed, 12 Aug 2020 09:21:51 +0200
|
||||
Subject: [PATCH] ipa: fix bit CPP when combined with IPA bit CP
|
||||
|
||||
As mentioned in the PR, let's consider the following example:
|
||||
|
||||
int
|
||||
__attribute__((noinline))
|
||||
foo(int arg)
|
||||
{
|
||||
if (arg == 3)
|
||||
return 1;
|
||||
if (arg == 4)
|
||||
return 123;
|
||||
|
||||
__builtin_unreachable ();
|
||||
}
|
||||
|
||||
during WPA we find all calls of the function
|
||||
(yes the call with value 5 is UBSAN):
|
||||
|
||||
Node: foo/0:
|
||||
param [0]: 5 [loc_time: 4, loc_size: 2, prop_time: 0, prop_size: 0]
|
||||
3 [loc_time: 3, loc_size: 3, prop_time: 0, prop_size: 0]
|
||||
ctxs: VARIABLE
|
||||
Bits: value = 0x5, mask = 0x6
|
||||
|
||||
in LTRANS we have the following VRP info:
|
||||
|
||||
# RANGE [3, 3] NONZERO 3
|
||||
|
||||
when we AND masks in get_default_value we end up with 6 & 3 = 2 (0x010).
|
||||
That means the only second (least significant bit) is unknown and
|
||||
value (5 = 0x101) & ~mask gives us either 7 (0x111) or 5 (0x101).
|
||||
|
||||
That's why if (arg_2(D) == 3) gets optimized to false.
|
||||
|
||||
gcc/ChangeLog:
|
||||
|
||||
PR ipa/96482
|
||||
* ipa-cp.c (ipcp_bits_lattice::meet_with_1): Drop value bits
|
||||
for bits that are unknown.
|
||||
(ipcp_bits_lattice::set_to_constant): Likewise.
|
||||
* tree-ssa-ccp.c (get_default_value): Add sanity check that
|
||||
IPA CP bit info has all bits set to zero in bits that
|
||||
are unknown.
|
||||
|
||||
gcc/testsuite/ChangeLog:
|
||||
|
||||
PR ipa/96482
|
||||
* gcc.dg/ipa/pr96482.c: New test.
|
||||
---
|
||||
gcc/ipa-cp.c | 3 +-
|
||||
gcc/testsuite/gcc.dg/ipa/pr96482.c | 44 ++++++++++++++++++++++++++++++
|
||||
gcc/tree-ssa-ccp.c | 3 ++
|
||||
3 files changed, 49 insertions(+), 1 deletion(-)
|
||||
create mode 100644 gcc/testsuite/gcc.dg/ipa/pr96482.c
|
||||
|
||||
diff --git a/gcc/ipa-cp.c b/gcc/ipa-cp.c
|
||||
index 945a69977f3..2b21280d919 100644
|
||||
--- a/gcc/ipa-cp.c
|
||||
+++ b/gcc/ipa-cp.c
|
||||
@@ -1011,7 +1011,7 @@ ipcp_bits_lattice::set_to_constant (widest_int value, widest_int mask)
|
||||
{
|
||||
gcc_assert (top_p ());
|
||||
m_lattice_val = IPA_BITS_CONSTANT;
|
||||
- m_value = value;
|
||||
+ m_value = wi::bit_and (wi::bit_not (mask), value);
|
||||
m_mask = mask;
|
||||
return true;
|
||||
}
|
||||
@@ -1048,6 +1048,7 @@ ipcp_bits_lattice::meet_with_1 (widest_int value, widest_int mask,
|
||||
|
||||
widest_int old_mask = m_mask;
|
||||
m_mask = (m_mask | mask) | (m_value ^ value);
|
||||
+ m_value &= value;
|
||||
|
||||
if (wi::sext (m_mask, precision) == -1)
|
||||
return set_to_bottom ();
|
||||
diff --git a/gcc/testsuite/gcc.dg/ipa/pr96482.c b/gcc/testsuite/gcc.dg/ipa/pr96482.c
|
||||
new file mode 100644
|
||||
index 00000000000..68ead798d28
|
||||
--- /dev/null
|
||||
+++ b/gcc/testsuite/gcc.dg/ipa/pr96482.c
|
||||
@@ -0,0 +1,44 @@
|
||||
+/* PR ipa/96482 */
|
||||
+/* { dg-do run } */
|
||||
+/* { dg-options "-O2 -flto" } */
|
||||
+/* { dg-require-effective-target lto } */
|
||||
+
|
||||
+int
|
||||
+__attribute__((noinline))
|
||||
+foo(int arg)
|
||||
+{
|
||||
+ if (arg == 3)
|
||||
+ return 1;
|
||||
+ if (arg == 4)
|
||||
+ return 123;
|
||||
+
|
||||
+ __builtin_unreachable ();
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+__attribute__((noinline))
|
||||
+baz(int x)
|
||||
+{
|
||||
+ if (x != 0)
|
||||
+ return foo(3); /* called */
|
||||
+
|
||||
+ return 1;
|
||||
+}
|
||||
+
|
||||
+int
|
||||
+__attribute__((noinline))
|
||||
+bar(int x)
|
||||
+{
|
||||
+ if (x == 0)
|
||||
+ return foo(5); /* not executed */
|
||||
+
|
||||
+ return 1;
|
||||
+}
|
||||
+
|
||||
+int main(int argc, char **argv)
|
||||
+{
|
||||
+ if (bar(argc) != baz(argc))
|
||||
+ __builtin_abort ();
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
diff --git a/gcc/tree-ssa-ccp.c b/gcc/tree-ssa-ccp.c
|
||||
index 7e3921869b8..65dffe06530 100644
|
||||
--- a/gcc/tree-ssa-ccp.c
|
||||
+++ b/gcc/tree-ssa-ccp.c
|
||||
@@ -306,6 +306,9 @@ get_default_value (tree var)
|
||||
{
|
||||
val.lattice_val = CONSTANT;
|
||||
val.value = value;
|
||||
+ widest_int ipa_value = wi::to_widest (value);
|
||||
+ /* Unknown bits from IPA CP must be equal to zero. */
|
||||
+ gcc_assert (wi::bit_and (ipa_value, mask) == 0);
|
||||
val.mask = mask;
|
||||
if (nonzero_bits != -1)
|
||||
val.mask &= extend_mask (nonzero_bits,
|
||||
--
|
||||
2.28.0
|
||||
|
Loading…
Reference in a new issue