mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/supercollider to 3.9.3-3
This commit is contained in:
parent
329ab5dfc8
commit
aef39f5a4e
2 changed files with 20 additions and 4 deletions
|
@ -9,23 +9,27 @@
|
|||
_name=SuperCollider
|
||||
pkgname=supercollider
|
||||
pkgver=3.9.3
|
||||
pkgrel=1
|
||||
pkgdesc="An environment and programming language for real time audio synthesis and algorithmic composition"
|
||||
pkgrel=3
|
||||
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
|
||||
arch=('x86_64')
|
||||
url="https://supercollider.github.io"
|
||||
license=('GPL3')
|
||||
groups=('pro-audio')
|
||||
depends=('boost-libs' 'fftw' 'jack' 'qt5-webkit' 'yaml-cpp')
|
||||
makedepends=('boost' 'cmake' 'emacs' 'qt5-tools')
|
||||
optdepends=('emacs: emacs interface'
|
||||
'gedit: gedit interface'
|
||||
'sc3-plugins: additional extension plugins for scsynth')
|
||||
source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2")
|
||||
source=("https://github.com/${pkgname}/${pkgname}/releases/download/Version-${pkgver}/${_name}-${pkgver}-Source-linux.tar.bz2"
|
||||
'boost-1.67.patch')
|
||||
install="${pkgname}.install"
|
||||
sha512sums=('5b0c29941907d5ca45c1676e34184664c03891051bba0ee50d9e8311400824054de7b6daba6d29fd875ff38f42ee9654504ea2f0b5bf0a36ae9605e6a79a0841')
|
||||
sha512sums=('5b0c29941907d5ca45c1676e34184664c03891051bba0ee50d9e8311400824054de7b6daba6d29fd875ff38f42ee9654504ea2f0b5bf0a36ae9605e6a79a0841'
|
||||
'9980d77802f18fd56d2a13f24f070e81768d9111b2cc63e479a0e9b405a04aec28bc523e5d36aab0462af6a3831d64598470cdc6c3266431e2ca64aa427a6bf2')
|
||||
|
||||
prepare() {
|
||||
mv -v "${_name}-Source" "${pkgname}-${pkgver}"
|
||||
cd "${pkgname}-${pkgver}"
|
||||
patch -Np1 -i ../boost-1.67.patch
|
||||
# requires out-of-tree build
|
||||
mkdir -v bld
|
||||
}
|
||||
|
|
12
community/supercollider/boost-1.67.patch
Normal file
12
community/supercollider/boost-1.67.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -upr supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp supercollider-3.9.3/server/supernova/utilities/time_tag.hpp
|
||||
--- supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp 2018-03-28 23:05:07.000000000 +0300
|
||||
+++ supercollider-3.9.3/server/supernova/utilities/time_tag.hpp 2018-06-03 01:32:16.824417338 +0300
|
||||
@@ -230,7 +230,7 @@ public:
|
||||
#ifdef BOOST_DATE_TIME_POSIX_TIME_STD_CONFIG
|
||||
time_duration offset = seconds(get_secs() - ntp_offset) + nanoseconds(get_nanoseconds());
|
||||
#else
|
||||
- time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(get_nanoseconds()/1000);
|
||||
+ time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(long(get_nanoseconds()/1000));
|
||||
#endif
|
||||
return ptime(base, offset);
|
||||
}
|
Loading…
Reference in a new issue