mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-kirkwood-dt to 4.5.2-1
This commit is contained in:
parent
3a3cc60059
commit
af09995c9a
3 changed files with 2 additions and 542 deletions
|
@ -6,7 +6,7 @@ buildarch=2
|
|||
pkgbase=linux-kirkwood-dt
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Marvell Kirkwood DT"
|
||||
pkgver=4.5.1
|
||||
pkgver=4.5.2
|
||||
srcver=${pkgver%.0}
|
||||
pkgrel=1
|
||||
cryptodev_commit=bc67142c57eadc0aafd0323ec527849012786643
|
||||
|
@ -38,7 +38,7 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
|||
'goflexhome_fdt.patch'
|
||||
'linux.preset')
|
||||
|
||||
md5sums=('488fac47d1c73e8a21ac71f7f3121009'
|
||||
md5sums=('eae8f700463ea73185027caece5f1c5d'
|
||||
'7acee3b15e2942600e335c1257be8a26'
|
||||
'190c3ba09aa63ddfc914e404ad56a969'
|
||||
'09d44b9f07abfaeaf4f688ee52034786'
|
||||
|
|
|
@ -1,364 +0,0 @@
|
|||
diff -Naur a/arch/arm/boot/dts/kirkwood-nsa325.dts b/arch/arm/boot/dts/kirkwood-nsa325.dts
|
||||
--- a/arch/arm/boot/dts/kirkwood-nsa325.dts 1969-12-31 16:00:00.000000000 -0800
|
||||
+++ b/arch/arm/boot/dts/kirkwood-nsa325.dts 2014-10-18 18:36:44.000000000 -0700
|
||||
@@ -0,0 +1,360 @@
|
||||
+/*
|
||||
+ * Device tree file for Zyxel NSA 325 NAS
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "kirkwood.dtsi"
|
||||
+#include "kirkwood-6282.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "ZyXEL NSA325";
|
||||
+ compatible = "zyxel,nsa325", "marvell,kirkwood-88f6282", "marvell,kirkwood";
|
||||
+
|
||||
+ memory {
|
||||
+ device_type = "memory";
|
||||
+ reg = <0x00000000 0x20000000>;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ bootargs = "console=ttyS0,115200";
|
||||
+ stdout-path = &uart0;
|
||||
+ };
|
||||
+
|
||||
+ mbus {
|
||||
+ pcie-controller {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ pcie@1,0 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ocp@f1000000 {
|
||||
+ pinctrl: pin-controller@10000 {
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ pmx_led_sata2_green: pmx-led-sata2-green {
|
||||
+ marvell,pins = "mpp12";
|
||||
+ marvell,function = "gpo";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_sata2_red: pmx-led-sata2-red {
|
||||
+ marvell,pins = "mpp13";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_mcu_data: pmx-mcu-data {
|
||||
+ marvell,pins = "mpp14";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_usb_green: pmx-led-usb-green {
|
||||
+ marvell,pins = "mpp15";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_mcu_clk: pmx-mcu-clk {
|
||||
+ marvell,pins = "mpp16";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_mcu_act: pmx-mcu-act {
|
||||
+ marvell,pins = "mpp17";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_usb_power_off: pmx-usb-power-off {
|
||||
+ marvell,pins = "mpp21";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_sys_green: pmx-led-sys-green {
|
||||
+ marvell,pins = "mpp28";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_sys_orange: pmx-led-sys-orange {
|
||||
+ marvell,pins = "mpp29";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_btn_reset: pmx-btn-reset {
|
||||
+ marvell,pins = "mpp36";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_btn_copy: pmx-btn-copy {
|
||||
+ marvell,pins = "mpp37";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_copy_green: pmx-led-copy-green {
|
||||
+ marvell,pins = "mpp39";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_copy_red: pmx-led-copy-red {
|
||||
+ marvell,pins = "mpp40";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_sata1_green: pmx-led-sata1-green {
|
||||
+ marvell,pins = "mpp41";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_led_sata1_red: pmx-led-sata1-red {
|
||||
+ marvell,pins = "mpp42";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_beeper: pmx-beeper {
|
||||
+ marvell,pins = "mpp44";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_btn_power: pmx-btn-power {
|
||||
+ marvell,pins = "mpp46";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_pwr_sata1: pmx-pwr-sata1 {
|
||||
+ marvell,pins = "mpp47";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+
|
||||
+ pmx_pwr_off: pmx-pwr-off {
|
||||
+ marvell,pins = "mpp48";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ /* This board uses the pcf8563 RTC instead of the SoC RTC */
|
||||
+ rtc@10300 {
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ i2c@11000 {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ pcf8563: pcf8563@51 {
|
||||
+ compatible = "nxp,pcf8563";
|
||||
+ reg = <0x51>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ serial@12000 {
|
||||
+ status = "ok";
|
||||
+ };
|
||||
+
|
||||
+ sata@80000 {
|
||||
+ status = "okay";
|
||||
+ nr-ports = <2>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio_keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ pinctrl-0 = <&pmx_btn_power &pmx_btn_copy &pmx_btn_reset>;
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ button@1 {
|
||||
+ label = "Power Button";
|
||||
+ linux,code = <KEY_POWER>;
|
||||
+ gpios = <&gpio1 14 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ button@2 {
|
||||
+ label = "Copy Button";
|
||||
+ linux,code = <KEY_COPY>;
|
||||
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
|
||||
+ };
|
||||
+
|
||||
+ button@3 {
|
||||
+ label = "Reset Button";
|
||||
+ linux,code = <KEY_RESTART>;
|
||||
+ gpios = <&gpio1 4 GPIO_ACTIVE_LOW>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio-leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-0 = <&pmx_led_sata1_green &pmx_led_sata1_red
|
||||
+ &pmx_led_sata2_green &pmx_led_sata2_red
|
||||
+ &pmx_led_sys_green &pmx_led_sys_orange
|
||||
+ &pmx_led_copy_green &pmx_led_copy_red
|
||||
+ &pmx_led_usb_green>;
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ green-sata2 {
|
||||
+ label = "nsa325:green:sata2";
|
||||
+ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,default-trigger = "ide-disk2";
|
||||
+ };
|
||||
+
|
||||
+ red-sata2 {
|
||||
+ label = "nsa325:red:sata2";
|
||||
+ gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ green-usb {
|
||||
+ label = "nsa325:green:usb";
|
||||
+ gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,default-trigger = "usb-host";
|
||||
+ };
|
||||
+
|
||||
+ green-sys {
|
||||
+ label = "nsa325:green:sys";
|
||||
+ gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
+ };
|
||||
+
|
||||
+ orange-sys {
|
||||
+ label = "nsa325:orange:sys";
|
||||
+ gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,default-trigger = "cpu0";
|
||||
+ };
|
||||
+
|
||||
+ green-copy {
|
||||
+ label = "nsa325:green:copy";
|
||||
+ gpios = <&gpio1 7 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ red-copy {
|
||||
+ label = "nsa325:red:copy";
|
||||
+ gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ green-sata1 {
|
||||
+ label = "nsa325:green:sata1";
|
||||
+ gpios = <&gpio1 9 GPIO_ACTIVE_HIGH>;
|
||||
+ linux,default-trigger = "ide-disk1";
|
||||
+ };
|
||||
+
|
||||
+ red-sata1 {
|
||||
+ label = "nsa325:red:sata1";
|
||||
+ gpios = <&gpio1 10 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio_poweroff {
|
||||
+ compatible = "gpio-poweroff";
|
||||
+ pinctrl-0 = <&pmx_pwr_off>;
|
||||
+ pinctrl-names = "default";
|
||||
+ gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ regulators {
|
||||
+ compatible = "simple-bus";
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ pinctrl-0 = <&pmx_mcu_data &pmx_usb_power_off &pmx_pwr_sata1>;
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+/*
|
||||
+ watchdog_data: regulator@1 {
|
||||
+ compatible = "regulator-fixed";
|
||||
+ regulator-name = "Watchdog Data";
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ gpio = <&gpio0 14 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+*/
|
||||
+
|
||||
+ usb_power: regulator@2 {
|
||||
+ compatible = "regulator-fixed";
|
||||
+ reg = <2>;
|
||||
+ regulator-name = "USB Power";
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ enable-active-high;
|
||||
+ gpio = <&gpio0 21 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ sata1_power: regulator@3 {
|
||||
+ compatible = "regulator-fixed";
|
||||
+ reg = <3>;
|
||||
+ regulator-name = "SATA1 Power";
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ enable-active-high;
|
||||
+ gpio = <&gpio1 15 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&nand {
|
||||
+ status = "okay";
|
||||
+ chip-delay = <40>;
|
||||
+
|
||||
+ partition@0 {
|
||||
+ label = "uboot";
|
||||
+ reg = <0x0000000 0x0100000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@100000 {
|
||||
+ label = "uboot_env";
|
||||
+ reg = <0x0100000 0x0080000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@180000 {
|
||||
+ label = "key_store";
|
||||
+ reg = <0x0180000 0x0080000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@200000 {
|
||||
+ label = "info";
|
||||
+ reg = <0x0200000 0x0080000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@280000 {
|
||||
+ label = "etc";
|
||||
+ reg = <0x0280000 0x0a00000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@c80000 {
|
||||
+ label = "kernel_1";
|
||||
+ reg = <0x0c80000 0x0a00000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@1680000 {
|
||||
+ label = "rootfs1";
|
||||
+ reg = <0x1680000 0x2fc0000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@4640000 {
|
||||
+ label = "kernel_2";
|
||||
+ reg = <0x4640000 0x0a00000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@5040000 {
|
||||
+ label = "rootfs2";
|
||||
+ reg = <0x5040000 0x2fc0000>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&mdio {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ ethphy0: ethernet-phy@1 {
|
||||
+ reg = <1>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+ð0 {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ ethernet0-port@0 {
|
||||
+ phy-handle = <ðphy0>;
|
||||
+ };
|
||||
+};
|
|
@ -1,176 +0,0 @@
|
|||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -114,6 +114,7 @@
|
||||
kirkwood-openrd-client.dtb \
|
||||
kirkwood-openrd-ultimate.dtb \
|
||||
kirkwood-pogo_e02.dtb \
|
||||
+ kirkwood-pogoplugv4.dtb \
|
||||
kirkwood-rd88f6192.dtb \
|
||||
kirkwood-rd88f6281-z0.dtb \
|
||||
kirkwood-rd88f6281-a.dtb \
|
||||
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/kirkwood-pogoplugv4.dts
|
||||
@@ -0,0 +1,161 @@
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "kirkwood.dtsi"
|
||||
+#include "kirkwood-6281.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "CloudEngines Pogoplug V4";
|
||||
+ compatible = "cloudengines,pogoplugv4", "marvell,kirkwood-88f6192", "marvell,kirkwood";
|
||||
+
|
||||
+ memory {
|
||||
+ device_type = "memory";
|
||||
+ reg = <0x00000000 0x8000000>;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ bootargs = "console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p1 rootdelay=10";
|
||||
+ stdout-path = &uart0;
|
||||
+ };
|
||||
+
|
||||
+ mbus {
|
||||
+ pcie-controller {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ pcie@1,0 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ ocp@f1000000 {
|
||||
+ pinctrl: pin-controller@10000 {
|
||||
+ pmx_led_green: pmx-led-green {
|
||||
+ marvell,pins = "mpp22";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ pmx_led_red: pmx-led-red {
|
||||
+ marvell,pins = "mpp24";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ pmx_sdio_cd: pmx-sdio-cd {
|
||||
+ marvell,pins = "mpp27";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ pmx_sdio_wp: pmx-sdio-wp {
|
||||
+ marvell,pins = "mpp28";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ pmx_button_eject: pmx-button-eject {
|
||||
+ marvell,pins = "mpp29";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ spi@10600 {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ m25p05@0 {
|
||||
+ compatible = "m25p05-nonjedec";
|
||||
+ reg = <0>;
|
||||
+ spi-max-frequency = <20000000>;
|
||||
+ mode = <0>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ serial@12000 {
|
||||
+ status = "ok";
|
||||
+ };
|
||||
+
|
||||
+ sata@80000 {
|
||||
+ status = "okay";
|
||||
+ nr-ports = <1>;
|
||||
+ };
|
||||
+
|
||||
+ i2c0: i2c@11000 {
|
||||
+ status = "ok";
|
||||
+ };
|
||||
+
|
||||
+ mvsdio@90000 {
|
||||
+ pinctrl-0 = <&pmx_sdio>;
|
||||
+ pinctrl-names = "default";
|
||||
+ status = "okay";
|
||||
+ cd-gpios = <&gpio0 27 GPIO_ACTIVE_HIGH>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio-leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-0 = <&pmx_led_green &pmx_led_red>;
|
||||
+ pinctrl-names = "default";
|
||||
+ health {
|
||||
+ label = "status:green:health";
|
||||
+ gpios = <&gpio0 22 GPIO_ACTIVE_LOW>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
+ };
|
||||
+ fault {
|
||||
+ label = "status:red:fault";
|
||||
+ gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
|
||||
+ linux,default-trigger = "none";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio_keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+ pinctrl-0 = <&pmx_button_eject>;
|
||||
+ pinctrl-names = "default";
|
||||
+
|
||||
+ button@1 {
|
||||
+ label = "Eject Button";
|
||||
+ linux,code = <KEY_EJECTCD>;
|
||||
+ gpios = <&gpio0 29 1>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&mdio {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ ethphy0: ethernet-phy@0 {
|
||||
+ device_type = "ethernet-phy";
|
||||
+ reg = <0>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+ð0 {
|
||||
+ status = "okay";
|
||||
+ ethernet0-port@0 {
|
||||
+ phy-handle = <ðphy0>;
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&nand {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ partition@0 {
|
||||
+ label = "u-boot";
|
||||
+ reg = <0x0000000 0x200000>;
|
||||
+ read-only;
|
||||
+ };
|
||||
+
|
||||
+ partition@200000 {
|
||||
+ label = "uImage";
|
||||
+ reg = <0x200000 0x300000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@500000 {
|
||||
+ label = "uImage2";
|
||||
+ reg = <0x500000 0x300000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@800000 {
|
||||
+ label = "failsafe";
|
||||
+ reg = <0x800000 0x800000>;
|
||||
+ };
|
||||
+
|
||||
+ partition@2500000 {
|
||||
+ label = "root";
|
||||
+ reg = <0x1000000 0x7000000>;
|
||||
+ };
|
||||
+};
|
||||
|
Loading…
Reference in a new issue