diff --git a/extra/python-matplotlib/.SRCINFO b/extra/python-matplotlib/.SRCINFO
index 2e9b6c65b..c966cf936 100644
--- a/extra/python-matplotlib/.SRCINFO
+++ b/extra/python-matplotlib/.SRCINFO
@@ -1,7 +1,7 @@
 pkgbase = python-matplotlib
 	pkgdesc = A python plotting library, making publication quality plots
-	pkgver = 3.8.3
-	pkgrel = 3
+	pkgver = 3.8.4
+	pkgrel = 2
 	url = https://matplotlib.org
 	arch = x86_64
 	license = custom
@@ -46,6 +46,7 @@ pkgbase = python-matplotlib
 	makedepends = python-setuptools-scm
 	makedepends = pybind11
 	makedepends = python-wheel
+	makedepends = meson-python
 	depends = freetype2
 	depends = python-contourpy
 	depends = python-cycler
@@ -73,12 +74,12 @@ pkgbase = python-matplotlib
 	optdepends = texlive-fontsrecommended: usetex dependencies
 	optdepends = texlive-latexrecommended: usetex usage with pdflatex
 	optdepends = python-certifi: https support
-	source = git+https://github.com/matplotlib/matplotlib.git#tag=50486a281099f6b9dcb556b9f0d3f9d1e4eb40b2?signed
+	source = git+https://github.com/matplotlib/matplotlib.git#tag=v3.8.4?signed
 	source = https://github.com/QuLogic/mpl-images/archive/v3.8.3-with-freetype-2.13.1/mpl-images-3.8.3-ft2.13.1.tar.gz
 	source = freetype.patch
 	validpgpkeys = 23CAB59E3332F94D26BEF0378D86E7FAE5EB0C10
 	validpgpkeys = EB8322187FD451192E430A7279B3FEC456F12599
-	b2sums = bc0e69023695eeec28ecf1e0c156dff1e1696ecbc682b11d313d01faa5a4592fbe8dd173a5ab0708d2f078b0e271de95006f98674776d9e452ef9e79156875a1
+	b2sums = bd245e0bdac7f096b01b187b74c4aa3947cd14d25ef6fefccf25a079171460bc4da02fb00ae2b8c62c6fd44039a2f8cbad2fe034945418fcc5b0e3caf85cc26b
 	b2sums = dabc8af36c6a489fa64ffe341801b8c82e578b6c864745885e18f39c531193187cf5d8030bb25f81abd9ec3f37a890da3ca6a2e30772b61906a80ac1ca53b140
 	b2sums = ccc679b9108342a9c0ceb67ccb1158c7409c7033e5b6ce3cb4ca53b9351b3aa8557a95f8a823ee5f1cd60be4b901230ba993e06db6977a8c7db1419ba0fe4983
 
diff --git a/extra/python-matplotlib/PKGBUILD b/extra/python-matplotlib/PKGBUILD
index 7c7fc16c4..a9a05fede 100644
--- a/extra/python-matplotlib/PKGBUILD
+++ b/extra/python-matplotlib/PKGBUILD
@@ -10,8 +10,8 @@
 #  - disable lto via setup.cfg
 
 pkgname=python-matplotlib
-pkgver=3.8.3
-pkgrel=3
+pkgver=3.8.4
+pkgrel=2
 _mpl_images_ver=3.8.3
 pkgdesc="A python plotting library, making publication quality plots"
 arch=(x86_64)
@@ -34,7 +34,7 @@ optdepends=('tk: Tk{Agg,Cairo} backends'
             'texlive-fontsrecommended: usetex dependencies'
             'texlive-latexrecommended: usetex usage with pdflatex'
             'python-certifi: https support')
-makedepends=(git python-build python-installer python-certifi python-setuptools-scm pybind11 python-wheel)
+makedepends=(git python-build python-installer python-certifi python-setuptools-scm pybind11 python-wheel meson-python)
 checkdepends=(python-pytest python-pytest-xdist python-pytest python-pytest-rerunfailures xorg-server-xvfb
               texlive-bin texlive-latexextra texlive-pictures texlive-fontsrecommended texlive-luatex
               ghostscript inkscape ffmpeg imagemagick gtk4
@@ -43,12 +43,11 @@ checkdepends=(python-pytest python-pytest-xdist python-pytest python-pytest-reru
               jupyter-nbconvert jupyter-nbformat python-ipykernel
               python-pandas python-pikepdf python-pytz python-xarray
               noto-fonts-cjk wqy-zenhei python-xcffib)
-_tag=50486a281099f6b9dcb556b9f0d3f9d1e4eb40b2 # git rev-parse v${pkgver}
 _ftver=2.13.1
-source=(git+https://github.com/matplotlib/matplotlib.git#tag=${_tag}?signed
+source=(git+https://github.com/matplotlib/matplotlib.git#tag=v${pkgver}?signed
         https://github.com/QuLogic/mpl-images/archive/v${_mpl_images_ver}-with-freetype-${_ftver}/mpl-images-${_mpl_images_ver}-ft${_ftver}.tar.gz
         freetype.patch)
-b2sums=('bc0e69023695eeec28ecf1e0c156dff1e1696ecbc682b11d313d01faa5a4592fbe8dd173a5ab0708d2f078b0e271de95006f98674776d9e452ef9e79156875a1'
+b2sums=('bd245e0bdac7f096b01b187b74c4aa3947cd14d25ef6fefccf25a079171460bc4da02fb00ae2b8c62c6fd44039a2f8cbad2fe034945418fcc5b0e3caf85cc26b'
         'dabc8af36c6a489fa64ffe341801b8c82e578b6c864745885e18f39c531193187cf5d8030bb25f81abd9ec3f37a890da3ca6a2e30772b61906a80ac1ca53b140'
         'ccc679b9108342a9c0ceb67ccb1158c7409c7033e5b6ce3cb4ca53b9351b3aa8557a95f8a823ee5f1cd60be4b901230ba993e06db6977a8c7db1419ba0fe4983')
 validpgpkeys=(23CAB59E3332F94D26BEF0378D86E7FAE5EB0C10  # Elliott Sales de Andrade <quantum.analyst@gmail.com>