community/blender to 3.0.1-5

This commit is contained in:
Kevin Mihelich 2022-02-17 19:28:54 +00:00
parent 94fc4c4648
commit afd147147e
3 changed files with 59 additions and 10 deletions

View file

@ -15,7 +15,7 @@ buildarch=8
pkgname=blender
pkgver=3.0.1
pkgrel=2
pkgrel=5
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -23,9 +23,10 @@ license=('GPL')
url="https://www.blender.org"
depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils' 'python-requests' 'potrace'
'shared-mime-info' 'hicolor-icon-theme' 'xdg-utils' 'glew' 'openjpeg2' 'python-numpy'
'freetype2' 'openal' 'ffmpeg' 'fftw' 'boost-libs' 'opencollada' 'alembic' 'openxr'
'freetype2' 'openal' 'ffmpeg4.4' 'fftw' 'boost-libs' 'opencollada' 'alembic' 'openxr'
'openimageio' 'libsndfile' 'jack' 'opencolorio' 'openshadinglanguage'
'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'log4cplus' 'sdl2' 'libharu')
'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'log4cplus' 'sdl2' 'libharu'
'draco')
makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm' 'ninja')
options=(!strip)
source=("git+https://git.blender.org/blender.git#tag=v$pkgver"
@ -33,13 +34,19 @@ source=("git+https://git.blender.org/blender.git#tag=v$pkgver"
"git+https://git.blender.org/blender-addons-contrib.git"
"git+https://git.blender.org/blender-translations.git"
"git+https://git.blender.org/blender-dev-tools.git"
blender-openexr3.patch)
https://developer.download.nvidia.com/redist/optix/v7.3/OptiX-7.3.0-Include.zip
blender-openexr3.patch
force-draco1.patch
force-draco2.patch)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'e2dd7210d26b70445e9ae8e33dea35111ad0b0aca9d3b4ded3df560d0fcc8dc044868f729e0f090a04b6f316f083b5505a7056ce088e8702065add87b9b457e5')
'd842e989bf86f4ae932f8708f6340861de4ea33b21435cceeb9a5e3135ef2ddb671e19fe11c397bddbf85894ba312194eac5acc21cbec70607120c0bda0100ef'
'e2dd7210d26b70445e9ae8e33dea35111ad0b0aca9d3b4ded3df560d0fcc8dc044868f729e0f090a04b6f316f083b5505a7056ce088e8702065add87b9b457e5'
'e239da4f3906f1b54265435181cf770bae3d269c8d915df9a73861e6ee71ec70bf2339426e7c81a91e5a567273b3b3742d7a99feefd3398d821b26e1ff3a56d0'
'527ab66e5eace777de0043c1ca5787a488f6471450ce67fd6d08137ad0ef56177bc0c17696f30a5fca23fa55d8ca9c3f30cb7b17550dba2dbd8e89ca0b361990')
prepare() {
cd "$pkgname"
@ -52,7 +59,9 @@ prepare() {
git submodule update
git submodule foreach git checkout v${pkgver}
patch -p1 < "$srcdir"/blender-openexr3.patch # Fix build with OpenEXR 3
patch -p1 -i "$srcdir"/blender-openexr3.patch # Fix build with OpenEXR 3
patch -p1 -i "$srcdir"/force-draco1.patch
patch -p1 -d release/scripts/addons -i "$srcdir"/force-draco2.patch
}
build() {
@ -60,13 +69,11 @@ build() {
local PYTHON_VER=3.10
# Optix is disabled until NVIDIA makes a new set of Optix headers publically available.
# That means we'll have to wait on NVIDIA for the time being.
cmake \
-Bbuild \
-GNinja \
-Cbuild_files/cmake/config/blender_release.cmake \
-DOPTIX_ROOT_DIR="$srcdir"/include \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DWITH_INSTALL_PORTABLE=OFF \
@ -76,7 +83,8 @@ build() {
-DPYTHON_LIBPATH=/usr/lib \
-DPYTHON_LIBRARY=python$PYTHON_VER \
-DPYTHON_INCLUDE_DIRS=/usr/include/python$PYTHON_VER \
-DCMAKE_CXX_FLAGS="-I /usr/include/python$PYTHON_VER"
-DCMAKE_C_FLAGS="-I /usr/include/ffmpeg4.4" \
-DCMAKE_CXX_FLAGS="-I /usr/include/python$PYTHON_VER -I /usr/include/ffmpeg4.4 -L /usr/lib/ffmpeg4.4"
ninja -C build
}
@ -92,4 +100,9 @@ package() {
# Manually install additional scripts (See FS#69351)
cp -r release/scripts/addons_contrib/* "${pkgdir}"/usr/share/blender/3*/scripts/addons_contrib/
# Manually install draco bindings (See FS#73415)
mkdir -p "${pkgdir}"/usr/lib/python3.10/
mv "${pkgdir}"/usr/share/blender/3*/python/lib/* "${pkgdir}"/usr/lib/
rm -r "${pkgdir}"/usr/share/blender/3*/python
}

View file

@ -0,0 +1,15 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75f5795db68..d50686adfb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -754,10 +754,6 @@ endif()
set_and_warn_dependency(WITH_PYTHON WITH_CYCLES OFF)
set_and_warn_dependency(WITH_PYTHON WITH_DRACO OFF)
-if(WITH_DRACO AND NOT WITH_PYTHON_INSTALL)
- message(STATUS "WITH_DRACO requires WITH_PYTHON_INSTALL to be ON, disabling WITH_DRACO for now")
- set(WITH_DRACO OFF)
-endif()
# enable boost for cycles, audaspace or i18n
# otherwise if the user disabled

View file

@ -0,0 +1,21 @@
diff --git a/io_scene_gltf2/io/com/gltf2_io_draco_compression_extension.py b/io_scene_gltf2/io/com/gltf2_io_draco_compression_extension.py
index e7518ac4..c0d78564 100644
--- a/io_scene_gltf2/io/com/gltf2_io_draco_compression_extension.py
+++ b/io_scene_gltf2/io/com/gltf2_io_draco_compression_extension.py
@@ -13,6 +13,7 @@
# limitations under the License.
import os
+import site
import sys
from pathlib import Path
import bpy
@@ -30,7 +31,7 @@ def dll_path() -> Path:
python_lib = Path('{v[0]}.{v[1]}/python/lib'.format(v=bpy.app.version))
python_version = 'python{v[0]}.{v[1]}'.format(v=sys.version_info)
- path = os.environ.get('BLENDER_EXTERN_DRACO_LIBRARY_PATH')
+ path = site.getsitepackages()[0]
if path is None:
path = {
'win32': blender_root / python_lib / 'site-packages',