alarm/xbmc-imx fix build on wandboard. Add small patch to work around xbmc-imx6/xbmc#51

This commit is contained in:
CrawX 2014-03-29 18:03:24 +01:00
parent 5ded1ad287
commit b03a2f69f7
2 changed files with 29 additions and 4 deletions

View file

@ -6,7 +6,7 @@
buildarch=4
pkgname=xbmc-imx-git
pkgver=13.20140324
pkgver=13.20140329
pkgrel=1
pkgdesc="A software media player and entertainment hub for digital media for select imx6 systems"
arch=('armv7h')
@ -24,10 +24,12 @@ provides=("xbmc")
conflicts=("xbmc")
install="xbmc.install"
source=('xbmc.service'
'fix-wandboard.patch'
'runxbmc')
md5sums=('07096dfd530cc432fa6073ee1a32e7f6'
'56ced80db9c37d86fa732961ad2cfe4c')
'4ddb9c84c81b03da4e6aae46d7e82edb'
'730ac095a89b05c3c2cf2dd93947cb5c')
# master branch of xbmc-imx6 organization. Modified by Stephan "wolgar" Rafin, Chris "koying" Browet, Rudi "rudi-warped" Ihle and smallint
_gitname="xbmc"
@ -54,6 +56,9 @@ prepare() {
cd "${srcdir}/${_gitname}"
# fix running on wandboard-dt
patch -p0 <../fix-wandboard.patch
# fix lsb_release dependency
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
@ -74,8 +79,8 @@ build() {
INCLUDES="-I/opt/fsl/include"
# check for cubox-i, copy some headers and add them to the INCLUDES
_kernel_release="$(pacman -Q linux-headers-imx6-cubox | grep -Eo "[^\ ]+$")"
if [[ $? -eq 0 && -n "$_kernel_release" ]]; then
_kernel_release="$(pacman -Qs linux-headers-imx6-cubox | head -n1 | grep -Eo "[^\ ]+$")"
if [[ -n "$_kernel_release" ]]; then
# dirty: copy headers from kernel as we need those but apart from that want to use the ones in /usr/include
KERNELSRC=/usr/src/linux-${_kernel_release}
mkdir -p linux-includes/include/linux

View file

@ -0,0 +1,20 @@
diff --git xbmc/windowing/egl/EGLNativeTypeIMX.cpp xbmc/windowing/egl/EGLNativeTypeIMX.cpp
index 4ffa708..e85a633 100644
--- xbmc/windowing/egl/EGLNativeTypeIMX.cpp
+++ xbmc/windowing/egl/EGLNativeTypeIMX.cpp
@@ -48,11 +48,15 @@ bool CEGLNativeTypeIMX::CheckCompatibility()
{
std::string strName;
std::string str2 ("mxc_sdc_fb");
+ std::string str3 ("platform:fb.24");
get_sysfs_str("/sys/class/graphics/fb0/device/modalias", strName);
StringUtils::Trim(strName);
size_t found = strName.find(str2);
if (found!=std::string::npos)
return true;
+ found = strName.find(str3);
+ if (found!=std::string::npos)
+ return true;
return false;
}