community/mythtv to 0.27-1

This commit is contained in:
Kevin Mihelich 2013-09-19 13:13:06 +00:00
parent 09595d8454
commit b059bdf2c1
2 changed files with 28 additions and 100 deletions

View file

@ -10,7 +10,7 @@
# - disabled vdpau, mmx # - disabled vdpau, mmx
pkgname=mythtv pkgname=mythtv
pkgver=0.26.1 pkgver=0.27
pkgrel=1 pkgrel=1
epoch=1 epoch=1
pkgdesc="A Homebrew PVR project" pkgdesc="A Homebrew PVR project"
@ -18,40 +18,34 @@ arch=('i686' 'x86_64')
url="http://www.mythtv.org/" url="http://www.mythtv.org/"
license=('GPL') license=('GPL')
depends=('avahi' 'fftw' 'lame' 'libass' 'libavc1394' 'libcdio' 'libiec61883' depends=('avahi' 'fftw' 'lame' 'libass' 'libavc1394' 'libcdio' 'libiec61883'
'libpulse' 'libva' 'libvdpau' 'libxinerama' 'lirc-utils' 'libpulse' 'libva' 'libvpx' 'libxinerama' 'lirc-utils' 'mariadb-clients'
'mariadb-clients' 'mysql-python' 'perl-dbd-mysql' 'perl-io-socket-inet6' 'mysql-python' 'perl-dbd-mysql' 'perl-io-socket-inet6' 'perl-libwww'
'perl-libwww' 'perl-net-upnp' 'python2-lxml' 'qtwebkit' 'urlgrabber' 'perl-net-upnp' 'python2-lxml' 'qtwebkit' 'taglib' 'urlgrabber' 'x264')
'x264')
makedepends=('glew' 'libcec' 'libxml2' 'mesa' 'mesa-libgl' 'openssl' 'yasm') makedepends=('glew' 'libcec' 'libxml2' 'mesa' 'mesa-libgl' 'openssl' 'yasm')
optdepends=('glew: for GPU commercial flagging' optdepends=('glew: for GPU commercial flagging'
'libcec: for consumer electronics control capabilities' 'libcec: for consumer electronics control capabilities'
'libxml2: to read blu-ray metadata' 'libxml2: to read blu-ray metadata'
'openssl: for AirTunes (RAOP) support' 'openssl: for AirTunes (RAOP) support'
'xmltv: to download tv listings') 'xmltv: to download tv listings')
conflicts=('myththemes' 'mythplugins-mythvideo') conflicts=('myththemes' 'mythplugins-mythvideo')
replaces=('myththemes' 'mythplugins-mythvideo') replaces=('myththemes' 'mythplugins-mythvideo')
backup=() backup=()
install='mythtv.install' install='mythtv.install'
source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2" source=("http://www.$pkgname.org/download/$pkgname/$pkgver"
'alsa.patch' 'mythbackend.service'
'mythbackend.service' 'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch')
'libva-compat.patch::https://github.com/garybuhrmaster/mythtv/commit/2add868d2f18b8b47d9747e043f052e88869bfc3.patch' sha256sums=('670b378e379df05a4f2ac28cc3cb2578587b42cb03710e0b230b75d692f8e2b8'
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.patch') 'f628f44164ce773ae54d320fb2f65353cacf9deec16981e4e56316ac33000a2f'
md5sums=('ef25a9b86f4a23d6f07d83791a1e5c9e' '8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3')
'f64b8219e3d27a2edf96733b851e576b'
'e4d572dcc307d6d8ae26bee5aebf9f3a' prepare() {
'ae88a16e9f42a913f395bf71af18e931' cd "$srcdir/$pkgname-fixes-$pkgver/$pkgname"
'6e156c9fc0b369346d93ccafad46cba3') find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np2 -i "$srcdir/libcec-2-support.2.patch"
}
build() { build() {
cd "$srcdir/$pkgname-$pkgver" cd "$srcdir/$pkgname-fixes-$pkgver/$pkgname"
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np1 -i "$srcdir/alsa.patch"
patch -Np2 -i "$srcdir/libva-compat.patch"
patch -Np2 -i "$srcdir/libcec-2-support.patch"
sed -re 's@Key, &@Key, @' -i 'bindings/php/MythBase.php'
[[ $CARCH == "arm" ]] && ARCH="armv5te" [[ $CARCH == "arm" ]] && ARCH="armv5te"
[[ $CARCH == "armv6h" ]] && ARCH="armv6l" [[ $CARCH == "armv6h" ]] && ARCH="armv6l"
@ -60,15 +54,15 @@ build() {
--cpu="$ARCH" \ --cpu="$ARCH" \
--disable-mmx \ --disable-mmx \
--disable-vdpau \ --disable-vdpau \
--disable-altivec \ --disable-altivec \
--disable-audio-jack \ --disable-audio-jack \
--disable-ccache \ --disable-ccache \
--disable-distcc \ --enable-libfftw3 \
--enable-libfftw3 \ --enable-libmp3lame \
--enable-libmp3lame \ --enable-libvpx \
--enable-libx264 \ --enable-libx264 \
--enable-vaapi \ --enable-vaapi \
--python=python2 --python=python2
make make
} }

View file

@ -1,66 +0,0 @@
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-common.c b/external/FFmpeg/libavdevice/alsa-audio-common.c
--- a/external/FFmpeg/libavdevice/alsa-audio-common.c 2012-10-02 23:30:24.000000000 +1300
+++ b/external/FFmpeg/libavdevice/alsa-audio-common.c 2013-01-09 13:23:49.704360811 +1300
@@ -28,6 +28,7 @@
* @author Nicolas George ( nicolas george normalesup org )
*/
+#include <sys/types.h>
#include <alsa/asoundlib.h>
#include "avdevice.h"
#include "libavutil/avassert.h"
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-dec.c b/external/FFmpeg/libavdevice/alsa-audio-dec.c
--- a/external/FFmpeg/libavdevice/alsa-audio-dec.c 2012-10-02 23:30:24.000000000 +1300
+++ b/external/FFmpeg/libavdevice/alsa-audio-dec.c 2013-01-09 13:23:47.911005108 +1300
@@ -45,6 +45,7 @@
* plugin.
*/
+#include <sys/types.h>
#include <alsa/asoundlib.h>
#include "libavformat/internal.h"
#include "libavutil/opt.h"
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-enc.c b/external/FFmpeg/libavdevice/alsa-audio-enc.c
--- a/external/FFmpeg/libavdevice/alsa-audio-enc.c 2012-10-02 23:30:24.000000000 +1300
+++ b/external/FFmpeg/libavdevice/alsa-audio-enc.c 2013-01-09 13:23:46.880992286 +1300
@@ -37,6 +37,7 @@
* which gives a low latency suitable for real-time playback.
*/
+#include <sys/types.h>
#include <alsa/asoundlib.h>
#include "libavformat/internal.h"
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio.h b/external/FFmpeg/libavdevice/alsa-audio.h
--- a/external/FFmpeg/libavdevice/alsa-audio.h 2012-10-02 23:30:24.000000000 +1300
+++ b/external/FFmpeg/libavdevice/alsa-audio.h 2013-01-09 13:23:51.121045145 +1300
@@ -30,6 +30,7 @@
#ifndef AVDEVICE_ALSA_AUDIO_H
#define AVDEVICE_ALSA_AUDIO_H
+#include <sys/types.h>
#include <alsa/asoundlib.h>
#include "config.h"
#include "libavutil/log.h"
diff -Nru a/libs/libmyth/audio/audiooutputalsa.h b/libs/libmyth/audio/audiooutputalsa.h
--- a/libs/libmyth/audio/audiooutputalsa.h 2012-10-02 23:30:24.000000000 +1300
+++ b/libs/libmyth/audio/audiooutputalsa.h 2013-01-09 13:22:13.313180438 +1300
@@ -1,6 +1,7 @@
#ifndef AUDIOOUTPUTALSA
#define AUDIOOUTPUTALSA
+#include <sys/types.h>
#define ALSA_PCM_NEW_HW_PARAMS_API
#define ALSA_PCM_NEW_SW_PARAMS_API
#include <alsa/asoundlib.h>
diff -Nru a/libs/libmythtv/audioinputalsa.h b/libs/libmythtv/audioinputalsa.h
--- a/libs/libmythtv/audioinputalsa.h 2012-10-02 23:30:24.000000000 +1300
+++ b/libs/libmythtv/audioinputalsa.h 2013-01-09 13:22:44.470223553 +1300
@@ -24,6 +24,7 @@
#include "audioinput.h"
#ifdef USING_ALSA
+#include <sys/types.h>
#include <alsa/asoundlib.h>
#else
typedef int snd_pcm_t;