extra/ffmpeg to 2.8.4-1

This commit is contained in:
Kevin Mihelich 2015-12-20 13:58:12 +00:00
parent d74075fe07
commit b05ab3017c
2 changed files with 27 additions and 77 deletions

View file

@ -1,7 +1,7 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Paul Mattal <paul@archlinux.org>
@ -9,48 +9,36 @@
# - use -fPIC in host cflags for armv7 to fix print_options.c compile
pkgname=ffmpeg
pkgver=2.8.3
pkgver=2.8.4
pkgrel=1
epoch=1
pkgdesc='Complete and free Internet live audio and video broadcasting solution'
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
license=('GPL')
depends=(
'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
'libbluray' 'libmodplug' 'libpulse' 'libsoxr' 'libssh' 'libtheora'
'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
'libvpx.so' 'libx264.so' 'libx265.so'
)
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
'libass' 'libbluray' 'libmodplug' 'libpulse' 'libsoxr' 'libssh'
'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
'libvpx.so' 'libx264.so' 'libx265.so')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=(
'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so'
)
source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc}
ffmpeg-2.8.1-libvpxenc-remove-some-unused-ctrl-id-mappings.patch)
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
md5sums=('937a6573ba399cf3e6808c9c6ea3d6d6'
'SKIP'
'71be9bcd297cb9ce833bbc5d425c0470')
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../ffmpeg-2.8.1-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
}
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so')
source=(http://ffmpeg.org/releases/${pkgname}-${pkgver}.tar.bz2{,.asc})
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
sha256sums=('83cc8136a7845546062a43cda9ae3cf0a02f43ef5e434d2f997f055231a75f8e'
'SKIP')
build() {
cd $pkgname-$pkgver
cd ${pkgname}-${pkgver}
[[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CONFIG='--host-cflags="-fPIC"'
./configure \
--prefix=/usr \
--prefix='/usr' \
--disable-debug \
--disable-static \
--disable-stripping \
@ -97,7 +85,10 @@ build() {
}
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install install-man
install -Dm755 tools/qt-faststart "$pkgdir"/usr/bin/qt-faststart
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install install-man
install -Dm 755 tools/qt-faststart "${pkgdir}"/usr/bin/
}
# vim: ts=2 sw=2 et:

View file

@ -1,41 +0,0 @@
From 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab Mon Sep 17 00:00:00 2001
From: James Zern <jzern@google.com>
Date: Mon, 19 Oct 2015 22:44:11 -0700
Subject: [PATCH] libvpxenc: remove some unused ctrl id mappings
VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
from libvpx and the remaining values were never used here
Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
Signed-off-by: James Zern <jzern@google.com>
---
libavcodec/libvpxenc.c | 8 --------
1 file changed, 8 deletions(-)
diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
index 5f39783..992122c 100644
--- a/libavcodec/libvpxenc.c
+++ b/libavcodec/libvpxenc.c
@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
/** String mappings for enum vp8e_enc_control_id */
static const char *const ctlidstr[] = {
- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
[VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
[VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
[VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
[VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
[VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
[VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
[VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
[VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
--
1.7.10.4