core/mkinitcpio to 36-1

This commit is contained in:
Kevin Mihelich 2023-06-03 19:36:23 +00:00
parent 1f380b9502
commit b0b11b981c
5 changed files with 75 additions and 32 deletions

43
core/mkinitcpio/.SRCINFO Normal file
View file

@ -0,0 +1,43 @@
pkgbase = mkinitcpio
pkgdesc = Modular initramfs image creation utility
pkgver = 36
pkgrel = 1
url = https://gitlab.archlinux.org/archlinux/mkinitcpio/mkinitcpio
install = mkinitcpio.install
arch = any
license = GPL
checkdepends = bash-bats
checkdepends = bash-bats-assert
checkdepends = lzop
depends = awk
depends = mkinitcpio-busybox>=1.19.4-2
depends = kmod
depends = util-linux>=2.23
depends = libarchive
depends = coreutils
depends = bash
depends = binutils
depends = diffutils
depends = findutils
depends = grep
depends = filesystem>=2011.10-1
depends = zstd
depends = systemd
optdepends = gzip: Use gzip compression for the initramfs image
optdepends = xz: Use lzma or xz compression for the initramfs image
optdepends = bzip2: Use bzip2 compression for the initramfs image
optdepends = lzop: Use lzo compression for the initramfs image
optdepends = lz4: Use lz4 compression for the initramfs image
optdepends = mkinitcpio-nfs-utils: Support for root filesystem on NFS
provides = initramfs
backup = etc/mkinitcpio.conf
source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-36.tar.gz
source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-36.tar.gz.sig
validpgpkeys = ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB
validpgpkeys = C100346676634E80C940FB9E9C02FF419FECBE16
sha512sums = f13cfdfee62dc1a344b75413fde8f35eb594c4c372d4a2ed8bbc22f2c01d93ea59d423807d06d19a6d1789e47b35286845daffeffef0fec4bae022e0e92b7b64
sha512sums = SKIP
b2sums = b60d8e61a15167df3316a7336467740efd4888784228dd6a08b1d974c54c479c082ba142eb60d3f356b06053e5c472f747e0ca830d50bed9f31c13d52b549ca1
b2sums = SKIP
pkgname = mkinitcpio

View file

@ -1,4 +1,4 @@
From 19178cb8b2874f83fbd8b3659a2d1d532af881a3 Mon Sep 17 00:00:00 2001
From 632c61c58f834442cc43bfd93bdc1d6e9747b7cf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH 1/3] use gzip for compression by default
@ -10,23 +10,23 @@ Subject: [PATCH 1/3] use gzip for compression by default
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/man/mkinitcpio.conf.5.adoc b/man/mkinitcpio.conf.5.adoc
index 08b95c5..41c29be 100644
index 69bbc6a..ad60b6b 100644
--- a/man/mkinitcpio.conf.5.adoc
+++ b/man/mkinitcpio.conf.5.adoc
@@ -56,7 +56,7 @@ Variables
Defines a program to filter the generated image through. The kernel
understands the compression formats yielded by the *zstd*, *gzip*, *bzip2*,
*lz4*, *lzop*, *lzma*, and *xz* compressors. If unspecified, this setting
- defaults to *zstd* compression. In order to create an uncompressed image,
+ defaults to *gzip* compression. In order to create an uncompressed image,
define this variable as *cat*.
+
It's not hard to realize that a filter such as a *tac* or *rev* will cause
@@ -55,7 +55,7 @@ override the main configuration file.
Defines a program to filter the generated image through. The kernel
understands the compression formats yielded by the *zstd*(1), *gzip*(1),
*bzip2*(1), *lz4*(1), *lzop*(1), *lzma*(1), and *xz*(1) compressors. If
- unspecified, this setting defaults to _zstd_ compression. In order to create
+ unspecified, this setting defaults to _gzip_ compression. In order to create
an uncompressed image, define this variable as _cat_.
+
It is not hard to realize that a filter such as a _tac_ or _rev_ will cause
diff --git a/mkinitcpio b/mkinitcpio
index 0c6dc60..f68d70c 100755
index da80fae..b68917c 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -856,7 +856,7 @@ if [[ -n "$_optgenimg" ]]; then
@@ -922,7 +922,7 @@ if [[ -n "$_optgenimg" ]]; then
die "Unable to write to '%s'" "$_optgenimg"
fi

View file

@ -1,4 +1,4 @@
From b496620d56fd79078e43d07e9e9bf43c42a4f770 Mon Sep 17 00:00:00 2001
From 7c407f4ddee777d54b746bab612f8914ce1e1339 Mon Sep 17 00:00:00 2001
From: Janne Grunau <j@jannau.net>
Date: Sun, 30 Jan 2022 10:01:43 +0000
Subject: [PATCH 2/3] functions: handle gzip compressed kernels in kver_generic
@ -9,10 +9,10 @@ Signed-off-by: Janne Grunau <j@jannau.net>
1 file changed, 5 insertions(+)
diff --git a/functions b/functions
index f920c3d..eb3e18a 100644
index cc47594..5b90a4b 100644
--- a/functions
+++ b/functions
@@ -223,6 +223,11 @@ kver_generic() {
@@ -228,6 +228,11 @@ kver_generic() {
read -r _ _ kver _ < <($reader "$1" | grep -m1 -aoE 'Linux version .(\.[-[:alnum:]+]+)+')

View file

@ -1,4 +1,4 @@
From b6fc34928a69f9e0498589c3e001730bc105539e Mon Sep 17 00:00:00 2001
From e6cc3b8af961e2a54d4336e646f16580a9d2f0e3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 21 Mar 2023 17:56:32 -0600
Subject: [PATCH 3/3] check for ALARM kernels in run_post_hooks
@ -9,13 +9,13 @@ Subject: [PATCH 3/3] check for ALARM kernels in run_post_hooks
2 files changed, 31 insertions(+), 5 deletions(-)
diff --git a/functions b/functions
index eb3e18a..8742ef4 100644
index 5b90a4b..a8943e2 100644
--- a/functions
+++ b/functions
@@ -219,13 +219,28 @@ kver_generic() {
@@ -224,13 +224,28 @@ kver_generic() {
# https://elixir.bootlin.com/linux/v5.7.2/source/init/version.c#L46
local kver='' reader='cat'
- [[ "$(detect_compression "$1")" == 'gzip' ]] && reader='zcat'
+ if [[ $1 =~ "/zImage" || $1 =~ /kernel7.img ]]; then
+ # Check for xz zImage
@ -47,10 +47,10 @@ index eb3e18a..8742ef4 100644
printf '%s' "$kver"
diff --git a/mkinitcpio b/mkinitcpio
index f68d70c..2ca3636 100755
index b68917c..1f77acb 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -801,6 +801,17 @@ if [[ "$KERNELVERSION" != 'none' ]]; then
@@ -850,6 +850,17 @@ if [[ "$KERNELVERSION" != 'none' ]]; then
done
fi

View file

@ -9,8 +9,8 @@
# - patch for gzip kernel image support (https://github.com/archlinux/mkinitcpio/pull/86)
pkgname=mkinitcpio
pkgver=35.2
pkgrel=1.1
pkgver=36
pkgrel=1
pkgdesc="Modular initramfs image creation utility"
arch=('any')
url='https://gitlab.archlinux.org/archlinux/mkinitcpio/mkinitcpio'
@ -31,16 +31,16 @@ source=("https://sources.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,
'0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch'
'0003-check-for-ALARM-kernels-in-run_post_hooks.patch')
install=mkinitcpio.install
sha512sums=('9ca8544bc5de3d215bf94ecf9a3bfb9265c9ed9871357af4b597a37e94c6951935641c11558470aaa934e8fbe9bc1f875dfa9d0fe8734a97f90154c9cbabfdba'
sha512sums=('f13cfdfee62dc1a344b75413fde8f35eb594c4c372d4a2ed8bbc22f2c01d93ea59d423807d06d19a6d1789e47b35286845daffeffef0fec4bae022e0e92b7b64'
'SKIP'
'b243f29afd7d4e9863421c29dde4b1e1c30c8a45ed0cab5a2453686d5847cfd712d15eb082743fb537d2e2846aab65e8c7e55cce4365d276f2aee9c72a20789d'
'58907a313e03256c852f22e1e41a08464f3bead58728d8b26a015a7996f4b1bfc554f7c44664e476ab186e4bf158b3374eb5315ea3653f19d1a1d5b2cf792a3d'
'bfd5d9ac626c0d50736d76509db90386aa97616f1035e20370d682cf867e2599ed98b2772d13d7f6f7398c10972218148761a5860d0d24d3314e8235a22fa662')
b2sums=('e7d56ea1de8d21271d4e94a61563af9c5f33320a46ce9f006092bb70e2161be02791dfd75b14e9c9b5ad2fbb781617f04b4e49afa93a707785c23773c1a48664'
'606ddec26b7b70976f3892cd195d1feb5eee9b79867573bff40a3aa3614b84de85b2cd8abc6929eda8c420930407bc3aa0cf4edc13891ab1a74c845e0c435b9f'
'e4f4eceefa20716631a2bb5bed02b0a7484c39c49e977ebc6d3b8ee0c7a4228e48ad94fd85aa6adb32958bbc57ab5844dafaf15c9b5e016deb97c2a9e0cfbe1e'
'f8743e9e6da85c77a89bf8bc28af44d8b40997d3d1f0ce7735e31e323bb3c9d156811c28a045322acaa91befdeed8c6ce281c2659dc0c6ab81c73c674e2ef6a2')
b2sums=('b60d8e61a15167df3316a7336467740efd4888784228dd6a08b1d974c54c479c082ba142eb60d3f356b06053e5c472f747e0ca830d50bed9f31c13d52b549ca1'
'SKIP'
'9d1d0dcb044613c34a2c758c422bccddcaa3dc97671c7522a3111e5ac34631f257df28ad65ba0cdaceae1b7676475146215fa5ccfc872e7ba7e73dce67fdb7f6'
'43b60c230b0e992fe8a8539d45d7357e4306cb7e0f383188437b2b309e1bf38ebdcf0e41e683e5c53f8a5dc73a75e370b535d9726b48ec2564d22a42d14fd086'
'e9086540eac07056c73486c4aad947029c412322c2f1a6a0c3ec146ed17363db59364ad96d863337f8e9308ff89419e6dfb82ab9a17efaa13132e5486b1b5b85')
'be971d8a9d194a35907afadc24bc5cb9b0b2434c264fa595c73c828912c694d5dc5c3129f2da8e74a38fd5439b9bcdc6a49c8ee9873bcd3f8e9c5af2a1269eb0'
'5c28cf1c0a7492736c0a074f5fc085e581b219b25fe6bdb81a3d8f07cbc0e334d76a2565b32cb841724550671d62429fa950ae6ce472420f6fe0c2049f61a753'
'6a5fe2da925f9f5327e14cb339226ed36ac416a00b7b6b09d4c9d332ddaf8f982921d1ea3f2af0d17e4add7a0cc4a253047265ddcc3e98a707b13f28bf294775')
validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
'C100346676634E80C940FB9E9C02FF419FECBE16') # Morten Linderud