extra/meson to 0.47.2-1

This commit is contained in:
Kevin Mihelich 2018-08-25 21:51:32 +00:00
parent 5c9df2e44c
commit b0b2279312
3 changed files with 25 additions and 8 deletions

View file

@ -3,9 +3,9 @@
buildarch=20
pkgname=raspberrypi-firmware
pkgver=20180730
pkgver=20180824
pkgrel=1
_commit=83146e2ec7fec863fdd6dcaa1b5129c43a5b3699
_commit=200c2f4dd54b2048b5dcb8661ea3f232beb7d81e
pkgdesc="Firmware tools, libraries, and headers for Raspberry Pi"
arch=('any')
url="https://github.com/raspberrypi/firmware"
@ -15,7 +15,7 @@ provides=('raspberrypi-firmware-tools')
options=(!strip)
source=("https://github.com/raspberrypi/firmware/archive/${_commit}.tar.gz"
'00-raspberrypi-firmware.conf')
md5sums=('3ca5f674a644f7c9ceaa399e9f44778b'
md5sums=('e69962adc2ae0b048715376e09e3df5d'
'72e0d5818fc513ece1b964f25f7e7882')
package() {

View file

@ -7,8 +7,8 @@
# - remove checkdepend on dmd
pkgname=meson
pkgver=0.47.1
pkgrel=2
pkgver=0.47.2
pkgrel=1
pkgdesc='High productivity build system'
url='http://mesonbuild.com/'
arch=('any')
@ -21,14 +21,18 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt4' 'qt5-b
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
'libwmf' 'valgrind')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
arch-meson)
sha512sums=('b86a95a057cfe3b46a33dfe57d0b215133306808871cd2d0f479421b7fd7ce7f5b49aa4c1d429ac0a1a56f805e1c690d220b567b8118e875b140dc75ad8218a5'
arch-meson test.diff)
sha512sums=('a1ac5691a5319ccf196d9443aea61e6c3ee9f09a9f638a3a7b5e5381b4c14372253c845be74fa2b59f42b9697671f12bce92c46bcb5cb629aeebd68e044e0021'
'SKIP'
'4cdacd6a7d2bdaacde176fd7f90f8a06ae403db7e63498518c637b13bdc344dca595fb8b9f41f978f450cd43ffef8a4013c0e74f669d13ba6881d38068ea1c0d')
'7ea030fdbaa7147694d5e94dc97b407b372254eb3045b284a64537c66d00947eb073462b6822599133b8ffb8f47dc53026b1f1d1e9a57b66ed3d4c734beba1d4'
'0e537c4fc04535decf901713f05d895dd8b93f2136e463b4a5adc5f2bf3a3e4c4ee07b5936fd7d01309af75a50fb1dc8d842b953c039ffe096efd54fd86aa7d0')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
prepare() {
cd ${pkgname}-${pkgver}
# https://github.com/mesonbuild/meson/issues/4083
patch -Np1 -i ../test.diff
}
build() {

13
extra/meson/test.diff Normal file
View file

@ -0,0 +1,13 @@
diff --git i/run_unittests.py w/run_unittests.py
index 28264606..7c267e17 100755
--- i/run_unittests.py
+++ w/run_unittests.py
@@ -3441,7 +3441,7 @@ class LinuxlikeTests(BasePlatformTests):
break
self.assertIsInstance(docbook_target, dict)
ifile = self.introspect(['--target-files', 'generated-gdbus-docbook@cus'])[0]
- self.assertEqual(t['filename'], 'gdbus/generated-gdbus-doc-' + ifile)
+ self.assertEqual(t['filename'], 'gdbus/generated-gdbus-doc-' + os.path.basename(ifile))
def test_build_rpath(self):
if is_cygwin():