core/pacman to 5.1.2-2

This commit is contained in:
Kevin Mihelich 2019-01-10 13:32:21 +00:00
parent f273039196
commit b0c036661f
4 changed files with 23 additions and 22 deletions

View file

@ -1,4 +1,4 @@
From 60abb58d9db663e6050d8d61d67e0e893306dfb0 Mon Sep 17 00:00:00 2001
From 8569d3c4b63f15ea588b9bde050072bfa2769eb0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Sep 2014 18:58:16 -0600
Subject: [PATCH 1/3] Sychronize filesystem
@ -14,7 +14,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+)
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
index af964832..b3f9049e 100644
index 4d97921f..531dbbe4 100644
--- a/lib/libalpm/trans.c
+++ b/lib/libalpm/trans.c
@@ -230,6 +230,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
@ -28,5 +28,5 @@ index af964832..b3f9049e 100644
}
--
2.17.0
2.20.1

View file

@ -1,4 +1,4 @@
From d892998ecea95c8224b128e1797a0e5a970436a8 Mon Sep 17 00:00:00 2001
From 0d026763a6bb067072628d559855072bc034ac7c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
@ -16,10 +16,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 deletion(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index 102a879a..c9fdd4af 100644
index d33eef2a..e08cb923 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -608,7 +608,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -627,7 +627,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
if(pid == 0) {
/* this code runs for the child only (the actual chroot/exec) */
@ -28,5 +28,5 @@ index 102a879a..c9fdd4af 100644
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
--
2.17.0
2.20.1

View file

@ -1,4 +1,4 @@
From dd8d526a39c86c300f158c581e028365efe60a64 Mon Sep 17 00:00:00 2001
From 0dccdcf0113f1a8ec6df1ec30e73a43ee9beec4b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 11 Mar 2016 20:11:24 -0700
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
@ -10,10 +10,10 @@ This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index c9fdd4af..2d57b256 100644
index e08cb923..7e788a7e 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -592,7 +592,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -611,7 +611,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
goto cleanup;
}
@ -22,7 +22,7 @@ index c9fdd4af..2d57b256 100644
_alpm_log(handle, ALPM_LOG_ERROR, _("could not create pipe (%s)\n"), strerror(errno));
retval = 1;
goto cleanup;
@@ -612,9 +612,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -631,9 +631,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
while(dup2(child2parent_pipefd[HEAD], 2) == -1 && errno == EINTR);
@ -37,7 +37,7 @@ index c9fdd4af..2d57b256 100644
close(child2parent_pipefd[TAIL]);
close(child2parent_pipefd[HEAD]);
if(cwdfd >= 0) {
@@ -649,16 +651,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -670,16 +672,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
child2parent->events = POLLIN;
fcntl(child2parent->fd, F_SETFL, O_NONBLOCK);
close(child2parent_pipefd[HEAD]);
@ -56,5 +56,5 @@ index c9fdd4af..2d57b256 100644
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
--
2.17.0
2.20.1

View file

@ -1,5 +1,4 @@
# vim: set ts=2 sw=2 et:
# $Id$
# Maintainer: Dan McGee <dan@archlinux.org>
# Maintainer: Dave Reisner <dreisner@archlinux.org>
@ -11,8 +10,8 @@
# - reverts to allow scriplet input on stdin
pkgname=pacman
pkgver=5.1.1
pkgrel=1
pkgver=5.1.2
pkgrel=2
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="http://www.archlinux.org/pacman/"
@ -22,8 +21,10 @@ depends=('bash' 'glibc' 'libarchive' 'curl'
'gpgme' 'pacman-mirrorlist' 'archlinuxarm-keyring')
makedepends=('asciidoc')
checkdepends=('python2' 'fakechroot')
optdepends=('perl-locale-gettext: translation support in makepkg-template')
backup=(etc/pacman.conf etc/makepkg.conf)
optdepends=('perl-locale-gettext: translation support in makepkg-template'
'xdelta3: delta support in repo-add')
backup=(etc/pacman.conf
etc/makepkg.conf)
options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
@ -33,11 +34,11 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
pacman.conf
makepkg.conf)
sha256sums=('be04b9162d62d2567e21402dcbabb5bedfdb03909fa5ec6e8568e02ab325bd8d'
sha256sums=('ce4eef1585fe64fd1c65c269e263577261edd7535fe2278240103012d74b6ef6'
'SKIP'
'8d70fb5094f58aad98b601bbc42be354c2014b9fe734a1ee0b1e14bb041cc9cc'
'0e771370da68c855bfb4eaad4c2ae137883a474886a049b934dac2e775574cb9'
'2f586f72c34150330389854575a21be1d3ef3637c4f94bec2e948c2717a5aecb'
'ce1be3021e5cd693b602ddfe96aca65117dce59ca11d4127aff58decd634fd04'
'9dc4d4b30e9c561868e89272e1867d5a009fbe6461b885c569f93069a32bdada'
'1b7286b86499a02e63362f501209effafcd1676111d91e88253e07737ba44b89'
'd55cd09eda56a0f19dfba8a042056fdf8d8d441d2c218fddaa30c1546a703532'
'edc48d8a6c051d50241fa727e948a06ece8890d9d9da80573f8894a3bf455d36')