alarm/devtools-alarm to 20160528-1

This commit is contained in:
Kevin Mihelich 2016-06-06 01:37:44 +00:00
parent 9ec7687e4e
commit b14b3fb8a0
7 changed files with 37 additions and 37 deletions

View file

@ -1,4 +1,4 @@
From cb456c4fa987a07e9ff07058f8edddce38b78ca3 Mon Sep 17 00:00:00 2001
From 8c1483d23cbb96d667b97bb18eb91615bd0db34f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:25:58 -0700
Subject: [PATCH 1/6] makechrootpkg: cache dir
@ -8,7 +8,7 @@ Subject: [PATCH 1/6] makechrootpkg: cache dir
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 3c8a20f..64bdbcb 100644
index 709e824..2c4a926 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -51,6 +51,7 @@ usage() {
@ -19,7 +19,7 @@ index 3c8a20f..64bdbcb 100644
echo '-d <dir> Bind directory into build chroot as read-write'
echo '-D <dir> Bind directory into build chroot as read-only'
echo '-u Update the working copy of the chroot before building'
@@ -313,12 +314,13 @@ move_products() {
@@ -252,12 +253,13 @@ move_products() {
orig_argv=("$@")
@ -34,7 +34,7 @@ index 3c8a20f..64bdbcb 100644
r) passeddir="$OPTARG" ;;
I) install_pkgs+=("$OPTARG") ;;
l) copy="$OPTARG" ;;
@@ -337,6 +339,10 @@ chrootdir=$(readlink -e "$passeddir")
@@ -276,6 +278,10 @@ chrootdir=$(readlink -e "$passeddir")
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
@ -45,15 +45,15 @@ index 3c8a20f..64bdbcb 100644
# Detect chrootdir filesystem type
chroottype=$(stat -f -c %T "$chrootdir")
@@ -388,7 +394,7 @@ download_sources
@@ -327,7 +333,7 @@ download_sources
prepare_chroot
-if arch-nspawn "$copydir" \
+if arch-nspawn $cache_dir "$copydir" \
--bind-ro="$PWD:/startdir_host" \
--bind-ro="$SRCDEST:/srcdest_host" \
--bind="$PWD:/startdir" \
--bind="$SRCDEST:/srcdest" \
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \
--
2.6.2
2.8.3

View file

@ -1,4 +1,4 @@
From ba27d39600d09455e1741a15044a4d2df6c9eabb Mon Sep 17 00:00:00 2001
From 0931501eb0adc8e5a941bc3324c25dcd73b430cf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:27:34 -0700
Subject: [PATCH 2/6] arch-nspawn: keep mirrorlist
@ -8,7 +8,7 @@ Subject: [PATCH 2/6] arch-nspawn: keep mirrorlist
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch-nspawn.in b/arch-nspawn.in
index 357d950..f9c2ffb 100644
index e46b57f..081c708 100644
--- a/arch-nspawn.in
+++ b/arch-nspawn.in
@@ -73,7 +73,7 @@ build_mount_args() {
@ -21,5 +21,5 @@ index 357d950..f9c2ffb 100644
[[ -n $pac_conf ]] && cp $pac_conf "$working_dir/etc/pacman.conf"
[[ -n $makepkg_conf ]] && cp $makepkg_conf "$working_dir/etc/makepkg.conf"
--
2.6.2
2.8.3

View file

@ -1,4 +1,4 @@
From f81c6b778a9057e54d633c66bdd6de24c028faea Mon Sep 17 00:00:00 2001
From a94a490e14cadde174ca0a31fe7ae01323bb6116 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:32:15 -0700
Subject: [PATCH 3/6] makechrootpkg: distcc
@ -8,13 +8,13 @@ Subject: [PATCH 3/6] makechrootpkg: distcc
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 64bdbcb..ae2b3a3 100644
index 2c4a926..4b86084 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -290,7 +290,10 @@ _chrootbuild() {
exit 1
fi
@@ -202,7 +202,10 @@ _chrootbuild() {
. /etc/profile
export HOME=/build
cd /startdir
- sudo -u builduser makepkg "$@"
+ mkdir /build/.distcc
+ chown builduser /build/.distcc
@ -22,7 +22,7 @@ index 64bdbcb..ae2b3a3 100644
+ sudo -u builduser DISTCC_IO_TIMEOUT=0 DISTCC_DIR='/build/.distcc' makepkg "$@"
}
move_products() {
_chrootnamcap() {
--
2.6.2
2.8.3

View file

@ -1,4 +1,4 @@
From c98f3cc8414affb83161bf5f18172dc4d34718e3 Mon Sep 17 00:00:00 2001
From 986d267949d8111f04954c0e56ab51251fa6b418 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:33:00 -0700
Subject: [PATCH 4/6] arch-nspawn: arm fix
@ -9,7 +9,7 @@ Subject: [PATCH 4/6] arch-nspawn: arm fix
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch-nspawn.in b/arch-nspawn.in
index f9c2ffb..13eba35 100644
index 081c708..c80afba 100644
--- a/arch-nspawn.in
+++ b/arch-nspawn.in
@@ -96,7 +96,7 @@ copy_hostconf
@ -22,10 +22,10 @@ index f9c2ffb..13eba35 100644
--register=no \
"${mount_args[@]}" \
diff --git a/makechrootpkg.in b/makechrootpkg.in
index ae2b3a3..104f54f 100644
index 4b86084..39dc498 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -240,10 +240,10 @@ download_sources() {
@@ -223,10 +223,10 @@ download_sources() {
# Ensure sources are downloaded
if [[ -n $SUDO_USER ]]; then
sudo -u $SUDO_USER env SRCDEST="$SRCDEST" BUILDDIR="$builddir" \
@ -39,5 +39,5 @@ index ae2b3a3..104f54f 100644
fi
(( $? != 0 )) && die "Could not download sources."
--
2.6.2
2.8.3

View file

@ -1,4 +1,4 @@
From 6027ea9d3d63da7d91f8153537644259fc58c2d2 Mon Sep 17 00:00:00 2001
From 32f7c91339f5bb396c10604a3487ca88da406b22 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:33:41 -0700
Subject: [PATCH 5/6] makechrootpkg: no default logging
@ -8,7 +8,7 @@ Subject: [PATCH 5/6] makechrootpkg: no default logging
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 104f54f..88363c9 100644
index 39dc498..9a69dda 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -12,7 +12,7 @@ m4_include(lib/common.sh)
@ -21,5 +21,5 @@ index 104f54f..88363c9 100644
update_first=false
clean_first=false
--
2.6.2
2.8.3

View file

@ -1,4 +1,4 @@
From 515e0bd96effaf05e0e407570cf04947e9b9a684 Mon Sep 17 00:00:00 2001
From fb9af59e9753f358ffb469aa13c0db2980cec300 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:34:04 -0700
Subject: [PATCH 6/6] archbuild: no setarch
@ -21,5 +21,5 @@ index 9c5d706..a4b5bed 100644
-M "@pkgdatadir@/makepkg-${arch}.conf" \
"${chroots}/${repo}-${arch}/root" \
--
2.6.2
2.8.3

View file

@ -6,7 +6,7 @@
pkgname=devtools-alarm
_pkgname=devtools
pkgver=20151129
pkgver=20160528
pkgrel=1
pkgdesc='Tools for Arch Linux ARM package maintainers'
arch=('any')
@ -22,13 +22,13 @@ source=("https://sources.archlinux.org/other/$_pkgname/$_pkgname-$pkgver.tar.gz"
'0004-arch-nspawn-arm-fix.patch'
'0005-makechrootpkg-no-default-logging.patch'
'0006-archbuild-no-setarch.patch')
md5sums=('86fe057b7180ce0247338e64f1a8722c'
'755e80123ab9d6afc8bb392b9e41a5fc'
'85a94eb74f123d420cc16db1edacd10f'
'8a778d0f0ec93340c0ecd98df8e38527'
'adf75517838b4fdbbc3199ea2049fa73'
'29ca8fac5cf40b5f2b83a16b9eb968f8'
'9182e6ab4f3ed7a60d9263e839c0d71a')
md5sums=('aa2ec2fd3a377fb5a1e7b0d2e491f99b'
'2dd231cc55cb66dabcd0e9770ff727e9'
'ed6f41393b2441f7e2185331be256921'
'da8409a3b73b345e2d888fe233d19cdb'
'093c6c2801a1d7c79a7384d64c520837'
'3d69e998b3f9e10a75b9806ef9bcaa83'
'52b92a26640a2539cf077eba0a2492ce')
prepare() {
cd "${_pkgname}-${pkgver}"