mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/chromium to 74.0.3729.169-2
This commit is contained in:
parent
fe264cb273
commit
b1550fff18
2 changed files with 1 additions and 58 deletions
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=74.0.3729.169
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
|
@ -35,7 +35,6 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium-system-icu.patch
|
||||
chromium-glibc-2.29.patch
|
||||
chromium-fix-the-flash-for-new-windows.patch
|
||||
chromium-fix-window-flash-for-some-WMs.patch
|
||||
chromium-widevine.patch
|
||||
chromium-skia-harmony.patch
|
||||
|
@ -44,7 +43,6 @@ sha256sums=('070f0210017f54b65264f88726431da7582e36a04caa673fe50662e8b41a0cb4'
|
|||
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
|
||||
'e2d284311f49c529ea45083438a768db390bde52949995534034d2a814beab89'
|
||||
'dd791f154b48e69cd47fd94753c45448655b529590995fd71ac1591c53a3d60c'
|
||||
'6d82c052eb1f1ae5644a09f7ad7a88d9e2966d1836124445ca4df93b7657c10a'
|
||||
'183d8cc712f0bcf1afcb01ce90c4c104a4c8d8070a06f94974a28b007d9e2ce4'
|
||||
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
|
||||
'5887f78b55c4ecbbcba5930f3f0bb7bc0117c2a41c2f761805fcf7f46f1ca2b3'
|
||||
|
@ -112,7 +110,6 @@ prepare() {
|
|||
patch -Np1 -i ../chromium-glibc-2.29.patch
|
||||
|
||||
# https://crbug.com/956061
|
||||
patch -Np1 -i ../chromium-fix-the-flash-for-new-windows.patch
|
||||
patch -Np1 -i ../chromium-fix-window-flash-for-some-WMs.patch
|
||||
|
||||
# Load Widevine CDM if available
|
||||
|
|
|
@ -1,54 +0,0 @@
|
|||
From adc543fe6a7b3bae9522257e651205140615fecb Mon Sep 17 00:00:00 2001
|
||||
From: Peng Huang <penghuang@chromium.org>
|
||||
Date: Fri, 3 May 2019 20:40:41 +0000
|
||||
Subject: [PATCH] Fix the flash for any new created window.
|
||||
|
||||
The flash is because the child window created by GLSurfaceGLX doesn't
|
||||
match the visual of parent window. Fix the problem by always creating
|
||||
parent window with the same visual.
|
||||
|
||||
Bug: 956061
|
||||
Change-Id: I88cb65b4a0313be6fdea1bd8d6770d351500ccbb
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1591946
|
||||
Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
|
||||
Reviewed-by: Antoine Labour <piman@chromium.org>
|
||||
Commit-Queue: Peng Huang <penghuang@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#656497}
|
||||
---
|
||||
.../desktop_window_tree_host_x11.cc | 19 +++++--------------
|
||||
1 file changed, 5 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_x11.cc b/ui/views/widget/desktop_aura/desktop_window_tree_host_x11.cc
|
||||
index 4dda760a4d..8bdb7b026d 100644
|
||||
--- a/ui/views/widget/desktop_aura/desktop_window_tree_host_x11.cc
|
||||
+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_x11.cc
|
||||
@@ -1426,24 +1426,15 @@ void DesktopWindowTreeHostX11::InitX11Window(
|
||||
if (override_redirect_)
|
||||
attribute_mask |= CWOverrideRedirect;
|
||||
|
||||
- bool enable_transparent_visuals;
|
||||
- switch (params.opacity) {
|
||||
- case Widget::InitParams::OPAQUE_WINDOW:
|
||||
- enable_transparent_visuals = false;
|
||||
- break;
|
||||
- case Widget::InitParams::TRANSLUCENT_WINDOW:
|
||||
- enable_transparent_visuals = true;
|
||||
- break;
|
||||
- case Widget::InitParams::INFER_OPACITY:
|
||||
- default:
|
||||
- enable_transparent_visuals = params.type == Widget::InitParams::TYPE_DRAG;
|
||||
- }
|
||||
-
|
||||
Visual* visual = CopyFromParent;
|
||||
int depth = CopyFromParent;
|
||||
Colormap colormap = CopyFromParent;
|
||||
+
|
||||
+ // GLSurfaceGLX always create child window with alpha channel. If the parent
|
||||
+ // window doesn't have alpha channel, it causes flash, so always request argb
|
||||
+ // visual.
|
||||
ui::XVisualManager::GetInstance()->ChooseVisualForWindow(
|
||||
- enable_transparent_visuals, &visual, &depth, &colormap,
|
||||
+ true /* want_argb_visual */, &visual, &depth, &colormap,
|
||||
&use_argb_visual_);
|
||||
|
||||
if (colormap != CopyFromParent) {
|
Loading…
Reference in a new issue