mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/rust to 1.54.0-1
This commit is contained in:
parent
4f2ff4651a
commit
b194d5279a
3 changed files with 11 additions and 11 deletions
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 8224eac823b..d0e0f14b202 100644
|
||||
index 16d148db618..856d57faf44 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -988,7 +988,7 @@ fn run(self, builder: &Builder<'_>) -> GeneratedTarball {
|
||||
@@ -992,7 +992,7 @@ fn run(self, builder: &Builder<'_>) -> GeneratedTarball {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index ad2b36691b5..0c57c774f24 100644
|
||||
index 2b547f8be92..09e1152dde4 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1507,7 +1507,7 @@ fn parse_target_triple(matches: &getopts::Matches, error_format: ErrorOutputType
|
||||
@@ -1538,7 +1538,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {:?} does not exist", path))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 165505ee731..00a7f5c2f8c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 2af46693449..a2c6cf49f9c 100644
|
||||
index 0f2aaeb533a..ce27142ec86 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2137,6 +2137,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2164,6 +2164,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetPath(canonicalized_path))
|
||||
}
|
||||
|
||||
|
|
|
@ -16,8 +16,8 @@ highmem=1
|
|||
|
||||
pkgname=('rust' 'rust-docs')
|
||||
epoch=1
|
||||
pkgver=1.53.0
|
||||
pkgrel=2
|
||||
pkgver=1.54.0
|
||||
pkgrel=1
|
||||
|
||||
_llvm_ver=12.0.1
|
||||
|
||||
|
@ -39,13 +39,13 @@ source=(
|
|||
0001-cargo-Change-libexec-dir.patch
|
||||
0002-compiler-Change-LLVM-targets.patch
|
||||
)
|
||||
sha256sums=('5cf7ca39a10f6bf4e0b0bd15e3b9a61ce721f301e12d148262e5ba968ab825b9'
|
||||
sha256sums=('ac8511633e9b5a65ad030a1a2e5bdaa841fdfe3132f2baaa52cc04e71c6c6976'
|
||||
'SKIP'
|
||||
'b4c8d5f2a802332987c1c0a95b5afb35b1a66a96fe44add4e4ed4792c4cba0a4'
|
||||
'SKIP'
|
||||
'35c9cd0d2a220c020f949c231d296bf4a1641ad253485e2f64440a6dc7731082'
|
||||
'644238f652f2099befb30f30eff77a5269a63cb4db1615933032ab3f6cbc31ba'
|
||||
'1833c3b5f8262b598115d13f08e2dcba792536768a2371869870e26244971112'
|
||||
'6786cb5d3831c69659747377f7482b7cd7941a9bddf84c55571f9aef940e1b83')
|
||||
'851172a5a3c35e209d455232d0572f51b6d34d3bc5f1a0416c01f426fdf60e92')
|
||||
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
|
||||
'B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
|
||||
|
|
Loading…
Reference in a new issue