mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/bullet to 2.87-1
This commit is contained in:
parent
6934f82678
commit
b1b7dcdf95
2 changed files with 3 additions and 29 deletions
|
@ -1,23 +0,0 @@
|
|||
From 04b3e88cdeb847efd3917b534bc53a74c572dcdf Mon Sep 17 00:00:00 2001
|
||||
From: Erwin Coumans <erwincoumans@google.com>
|
||||
Date: Tue, 7 Feb 2017 19:15:22 -0800
|
||||
Subject: [PATCH] Attempt to use VERSION string for CMakeLists.txt See Issue
|
||||
953, https://github.com/bulletphysics/bullet3/issues/953
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 26e662c..66f8871 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ set(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS true)
|
||||
SET(MSVC_INCREMENTAL_DEFAULT ON)
|
||||
|
||||
PROJECT(BULLET_PHYSICS)
|
||||
-SET(BULLET_VERSION 2.85)
|
||||
+FILE (STRINGS "VERSION" BULLET_VERSION)
|
||||
|
||||
IF(COMMAND cmake_policy)
|
||||
cmake_policy(SET CMP0003 NEW)
|
|
@ -7,24 +7,21 @@
|
|||
|
||||
pkgbase=bullet
|
||||
pkgname=('bullet' 'bullet-docs')
|
||||
pkgver=2.86
|
||||
pkgrel=2
|
||||
pkgver=2.87
|
||||
pkgrel=1
|
||||
pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.bulletphysics.com/Bullet/"
|
||||
license=('custom:zlib')
|
||||
makedepends=('cmake' 'doxygen' 'graphviz' 'ttf-dejavu' 'mesa' 'glu' 'python' 'python-numpy')
|
||||
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz"
|
||||
954.patch
|
||||
bullet3_examplebrowser.sh)
|
||||
sha512sums=('af8a6b282ab606437d7975a59cd8a9c2bf273c83b0e79f0c4c1de6fa51695ba6d5f3c853dce2fdba9cb55e7572214e15089e54db51afc465ca26f502cbd5a4f9'
|
||||
'6ab8a2e3ac518705e09a4a5ca51ce5efd9d07918ad5374d3b69b3879239576ef1641ca86154e04345027503533ec5578aa5155131b83e927c2a09d34f44e9a70'
|
||||
sha512sums=('649e470223295666eda6f7ff59d03097637c2645b5cd951977060ae14b89f56948ce03e437e83c986d26876f187d7ee34e790bc3882d5d66da9af89a4ab81c21'
|
||||
'8741ad94b6c46c226d89aebc8ab06d8a11bac3c04d3f0a2bf7a7524792a3375aa7bf7d295410b16fbeb4c348a31057b4570acdebe9bbaea251f44daca8d9fe81')
|
||||
|
||||
prepare() {
|
||||
cd bullet3-${pkgver}
|
||||
|
||||
patch -Np1 -i ${srcdir}/954.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue