community/kitty to 0.18.3-1

This commit is contained in:
Kevin Mihelich 2020-08-11 20:19:39 +00:00
parent 13eeb5a745
commit b1d082a2d5
2 changed files with 3 additions and 24 deletions

View file

@ -1,18 +0,0 @@
--- a/glfw/wl_init.c
+++ b/glfw/wl_init.c
@@ -802,6 +802,7 @@ void _glfwPlatformTerminate(void)
glfw_xkb_release(&_glfw.wl.xkb);
glfw_dbus_terminate(&_glfw.wl.dbus);
+ glfw_wlc_destroy();
if (_glfw.wl.cursor.handle)
{
_glfw_dlclose(_glfw.wl.cursor.handle);
@@ -810,7 +811,6 @@ void _glfwPlatformTerminate(void)
if (_glfw.wl.cursorSurface)
wl_surface_destroy(_glfw.wl.cursorSurface);
- glfw_wlc_destroy();
if (_glfw.wl.subcompositor)
wl_subcompositor_destroy(_glfw.wl.subcompositor);
if (_glfw.wl.compositor)

View file

@ -8,8 +8,8 @@
pkgbase=kitty
pkgname=(kitty kitty-terminfo)
pkgver=0.18.2
pkgrel=2
pkgver=0.18.3
pkgrel=1
pkgdesc="A modern, hackable, featureful, OpenGL-based terminal emulator"
arch=('x86_64')
url="https://github.com/kovidgoyal/kitty"
@ -17,14 +17,11 @@ license=('GPL3')
depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11' 'libxkbcommon-x11' 'libxi' 'hicolor-icon-theme' 'libgl' 'libcanberra' 'dbus')
makedepends=('libxinerama' 'libxcursor' 'libxrandr' 'wayland-protocols' 'python-sphinx')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz"
"2884-fix-wayland-segfault.patch"
'0001-remove-lto.patch')
sha512sums=('a0b053ed67ab197b5f5f25bfc9cd7df99b85bdfd62a68b6ca64ba194cb1823434d084864bdf115f40423d929ec127b3884ed6de5b42afcc921ccb74db999af40'
'f7cebb4f68d331f06ffeb83123f621a101f46762e69d8c5b9191d5c0c16d8f1bcb8ec99c4dde415f08eebbfca347eb56b35ad69cf83233667bb92328a759c743'
sha512sums=('dee04572905f735ac098e8406ec3f36c2eb4d21ff0c6ff1b94216fab2b861c4d72a865b36cc18be1d9ed77235c33cc01a207e1992260da47679ff8b83f62f6e8'
'1c0290a42552cbe5b3bb120965bcd2dc20b9236dba43e43ff086adc14dc25417323bf9b750bf1cb06ecb65267d6d479f79daf14f64eac697c06a138fa7baa601')
prepare() {
patch -Np1 -i "$srcdir/2884-fix-wayland-segfault.patch" -d "$srcdir/$pkgname-$pkgver"
patch -Np1 -i "$srcdir/0001-remove-lto.patch" -d "$srcdir/$pkgname-$pkgver"
}