mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/firefox to 105.0-2
This commit is contained in:
parent
321db5dfa8
commit
b2204d8eaa
2 changed files with 33 additions and 2 deletions
|
@ -0,0 +1,26 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Morgan Rae Reschenberg <mreschenberg@mozilla.com>
|
||||
Date: Wed, 24 Aug 2022 04:44:38 +0000
|
||||
Subject: [PATCH] Bug 1786638: Return early if we can't fetch an internal obj
|
||||
when computing ATK relations r=Jamie
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D155426
|
||||
---
|
||||
accessible/atk/AccessibleWrap.cpp | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/accessible/atk/AccessibleWrap.cpp b/accessible/atk/AccessibleWrap.cpp
|
||||
index 85281ba2cc20..2bdb40ddcb15 100644
|
||||
--- a/accessible/atk/AccessibleWrap.cpp
|
||||
+++ b/accessible/atk/AccessibleWrap.cpp
|
||||
@@ -836,6 +836,10 @@ AtkRelationSet* refRelationSetCB(AtkObject* aAtkObj) {
|
||||
ATK_OBJECT_CLASS(parent_class)->ref_relation_set(aAtkObj);
|
||||
|
||||
Accessible* acc = GetInternalObj(aAtkObj);
|
||||
+ if (!acc) {
|
||||
+ return relation_set;
|
||||
+ }
|
||||
+
|
||||
if (!StaticPrefs::accessibility_cache_enabled_AtStartup() &&
|
||||
acc->IsRemote()) {
|
||||
RemoteAccessible* proxy = acc->AsRemote();
|
|
@ -11,7 +11,7 @@ highmem=1
|
|||
|
||||
pkgname=firefox
|
||||
pkgver=105.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=(x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -29,10 +29,12 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
|
|||
'xdg-desktop-portal: Screensharing with Wayland')
|
||||
options=(!emptydirs !makeflags !strip !lto !debug)
|
||||
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
|
||||
0001-Bug-1786638-Return-early-if-we-can-t-fetch-an-intern.patch
|
||||
build-arm-libopus.patch
|
||||
$pkgname.desktop identity-icons-brand.svg)
|
||||
sha256sums=('2b5becbb89aa2b2007ba8c86ad517aeae1b54904d007d9d3acbf054be6a0ed62'
|
||||
'SKIP'
|
||||
'befaba1bb16e441953cb36d8ac494991b62134cfbf40cd339904a55034472dd5'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
|
||||
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
|
||||
|
@ -55,6 +57,9 @@ prepare() {
|
|||
mkdir mozbuild
|
||||
cd firefox-$pkgver
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1786638
|
||||
patch -Np1 -i ../0001-Bug-1786638-Return-early-if-we-can-t-fetch-an-intern.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
@ -102,7 +107,7 @@ END
|
|||
# https://bugzilla.redhat.com/show_bug.cgi?id=1641623
|
||||
echo "ac_add_options --disable-av1" >> .mozconfig
|
||||
# reduce jobs due to RAM constraints
|
||||
MAKEFLAGS="-j4"
|
||||
MAKEFLAGS="-j1"
|
||||
# disable hard-coded LTO
|
||||
sed -i '/cargo_rustc_flags += -Clto/d' config/makefiles/rust.mk
|
||||
sed -i '/RUSTFLAGS += -Cembed-bitcode=yes/d' config/makefiles/rust.mk
|
||||
|
|
Loading…
Reference in a new issue