extra/chromium to 29.0.1547.57-1

This commit is contained in:
Kevin Mihelich 2013-08-21 02:37:51 +00:00
parent 96919a8870
commit b28c21cdbd
3 changed files with 5 additions and 84 deletions

View file

@ -21,8 +21,8 @@ buildarch=20
highmem=1
pkgname=chromium
pkgver=28.0.1500.95
pkgrel=1.1
pkgver=29.0.1547.57
pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('armv6h' 'armv7h')
url="http://www.chromium.org/"
@ -44,16 +44,12 @@ source=(https://gsdview.appspot.com/chromium-browser-official/$pkgname-$pkgver.t
chromium.default
chromium.sh
chromium-28.0.1500.71-avoid-std-string-copying-in-GetFileNameInWhitelist.patch
chromium-nss-3.15.patch
chromium-system-harfbuzz-r0.patch
arm-webrtc-fix.patch)
sha256sums=('3c38888bebed3d13f860babc7fb667d425723c350e25cdfb73fc746f4f91d734'
sha256sums=('ae77204a5417ad7bf1ade257ba49f3ca64c83ed5741cb811a31f9f675d498576'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
'7c2e448c30677999f524f9513c2f998f3cb15bc6084692cad9c3f310aa813530'
'a5ca532d213cc6f9ad19341445309ad4e4aec9530f4309536fb42ee97deca5a6'
'2bc4cf17adac9864f4e832e57247984f28fce171d3699c0fc2c3596d1ab20386'
'222ec0db5d40b02e4ebbde8a1f1c5de3f0579e51836be87be138c44f8487d0ce')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -76,12 +72,6 @@ prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=471198#c23
patch -Np1 -i "$srcdir/chromium-28.0.1500.71-avoid-std-string-copying-in-GetFileNameInWhitelist.patch"
# Fix build with NSS 3.15 (patch from Gentoo)
patch -Np1 -i "$srcdir/chromium-nss-3.15.patch"
# Fix build with system harfbuzz (patch from Gentoo)
patch -Np1 -i "$srcdir/chromium-system-harfbuzz-r0.patch"
# Use Python 2
find . -type f -exec sed -i -r \
-e 's|/usr/bin/python$|&2|g' \
@ -160,6 +150,7 @@ fi
-Dtarget_arch=arm
-Darm_neon=0
-Dlinux_use_tcmalloc=0
-Dlogging_like_official_build=1
-Ddisable_nacl=1
-Dv8_use_arm_eabi_hardfloat=true
-Darm_float_abi=hard
@ -167,7 +158,7 @@ fi
${arch_specific_flags})
build/linux/unbundle/replace_gyp_files.py "${_chromium_conf[@]}"
build/gyp_chromium --depth=. "${_chromium_conf[@]}"
build/gyp_chromium -f make --depth=. "${_chromium_conf[@]}"
make chrome chrome_sandbox BUILDTYPE=Release
}

View file

@ -1,26 +0,0 @@
--- a/net/third_party/nss/ssl/bodge/secitem_array.c
+++ b/net/third_party/nss/ssl/bodge/secitem_array.c
@@ -6,6 +6,7 @@
* Support routines for SECItemArray data structure.
*/
+#include "nssutil.h"
#include "seccomon.h"
#include "secitem.h"
#include "secerr.h"
@@ -13,10 +14,15 @@
+#define NSSUTIL_VERSION_NUM \
+ (NSSUTIL_VMAJOR * 10000 + NSSUTIL_VMINOR * 100 + NSSUTIL_VPATCH)
+#if NSSUTIL_VERSION_NUM < 31500
+// Added in NSS 3.15.
typedef struct SECItemArrayStr SECItemArray;
struct SECItemArrayStr {
SECItem *items;
unsigned int len;
};
+#endif
SECItemArray *
SECITEM_AllocArray(PLArenaPool *arena, SECItemArray *array, unsigned int len)

View file

@ -1,44 +0,0 @@
Index: build/linux/unbundle/harfbuzz.gyp
diff --git a/build/linux/unbundle/harfbuzz.gyp b/build/linux/unbundle/harfbuzz.gyp
index 456dd384df2d5c57d9857cfb775d46ef87add2bc..93b2a69c12d7b7524fa0c2aa67b52136b779196d 100644
--- a/build/linux/unbundle/harfbuzz.gyp
+++ b/build/linux/unbundle/harfbuzz.gyp
@@ -3,24 +3,34 @@
# found in the LICENSE file.
{
+ 'variables': {
+ # Check for presence of harfbuzz-icu library, use it if present.
+ 'harfbuzz_libraries':
+ '<!(python <(DEPTH)/tools/compile_test/compile_test.py '
+ '--code "int main() { return 0; }" '
+ '--run-linker '
+ '--on-success "harfbuzz harfbuzz-icu" '
+ '--on-failure "harfbuzz" '
+ '-- -lharfbuzz-icu)',
+ },
'targets': [
{
'target_name': 'harfbuzz-ng',
'type': 'none',
'cflags': [
- '<!@(pkg-config --cflags harfbuzz)',
+ '<!@(pkg-config --cflags <(harfbuzz_libraries))',
],
'direct_dependent_settings': {
'cflags': [
- '<!@(pkg-config --cflags harfbuzz)',
+ '<!@(pkg-config --cflags <(harfbuzz_libraries))',
],
},
'link_settings': {
'ldflags': [
- '<!@(pkg-config --libs-only-L --libs-only-other harfbuzz)',
+ '<!@(pkg-config --libs-only-L --libs-only-other <(harfbuzz_libraries))',
],
'libraries': [
- '<!@(pkg-config --libs-only-l harfbuzz)',
+ '<!@(pkg-config --libs-only-l <(harfbuzz_libraries))',
],
},
},