diff --git a/alarm/uboot-cubox/PKGBUILD b/alarm/uboot-cubox/PKGBUILD
deleted file mode 100644
index 9aaacc7da..000000000
--- a/alarm/uboot-cubox/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# U-Boot: Cubox (Dove)
-# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
-
-buildarch=4
-
-pkgname=uboot-cubox     
-pkgver=2009.08
-pkgrel=1
-pkgdesc="U-Boot for Cubox (Dove)"
-arch=('armv7h')
-url="https://github.com/archlinuxarm/PKGBUILDs"
-license=('GPL')
-makedepends=('uboot-tools')
-backup=('boot/boot.scr')   
-_commit=814386d3e43b8ab8d81f04aa7fe402952503d8fe
-source=('boot.txt')                                                                                 
-md5sums=('02356c39d1e254e3f64c016be3895191')
-
-package() {
-  mkimage -A arm -O linux -T script -C none -n "Boot script" -d boot.txt boot.scr
-  mkdir -p "${pkgdir}"/boot
-  cp boot.scr "${pkgdir}"/boot
-}
diff --git a/alarm/uboot-cubox/boot.txt b/alarm/uboot-cubox/boot.txt
deleted file mode 100644
index 348639632..000000000
--- a/alarm/uboot-cubox/boot.txt
+++ /dev/null
@@ -1,12 +0,0 @@
-echo ======== Starting boot ========
-usb start
-setenv uimagearg 'uImage'
-setenv uinitarg 'uInitrd'
-setenv my1arg 'console=ttyS0,115200n8 console=tty1,115200n8'
-setenv my2arg 'vmalloc=384M video=dovefb:lcd0:1280x720-32@60-edid clcd.lcd0_enable=1 clcd.lcd1_enable=0'
-ext2load ide 0:1 0x04000000 /boot/${uinitarg} && ext2load ide 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/sda1 rw rootwait' && bootm 0x02000000 0x04000000
-ext2load usb 0:1 0x04000000 /boot/${uinitarg} && ext2load usb 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/sda1 rw rootwait' && bootm 0x02000000 0x04000000
-ext2load mmc 0:1 0x04000000 /boot/${uinitarg} && ext2load mmc 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/mmcblk0p1 rw rootwait' && bootm 0x02000000 0x04000000
-ext2load ide 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/sda1 rw rootwait' && bootm 0x02000000
-ext2load usb 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/sda1 rw rootwait' && bootm 0x02000000
-ext2load mmc 0:1 0x02000000 /boot/${uimagearg} && setenv bootargs ${my1arg} ${my2arg} 'root=/dev/mmcblk0p1 rw rootwait' && bootm 0x02000000