mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed extra/audacity
This commit is contained in:
parent
c799f7dd21
commit
b2bc36a21a
3 changed files with 0 additions and 86 deletions
|
@ -1,43 +0,0 @@
|
||||||
# $Id: PKGBUILD 176352 2013-01-30 20:25:49Z eric $
|
|
||||||
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - added --disable-sse to configure
|
|
||||||
# - disable soundtouch on v5
|
|
||||||
|
|
||||||
pkgname=audacity
|
|
||||||
pkgver=2.1.1
|
|
||||||
pkgrel=2
|
|
||||||
pkgdesc="A program that lets you manipulate digital audio waveforms"
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
url="http://audacityteam.org"
|
|
||||||
license=('GPL')
|
|
||||||
depends=('libmad' 'libid3tag' 'wxgtk2.8' 'lame' 'lilv' 'soundtouch'
|
|
||||||
'ffmpeg' 'vamp-plugin-sdk' 'sbsms' 'portsmf' 'desktop-file-utils')
|
|
||||||
makedepends=('cmake' 'python2')
|
|
||||||
options=('!makeflags')
|
|
||||||
install=audacity.install
|
|
||||||
source=(https://github.com/audacity/audacity/archive/Audacity-${pkgver}.zip
|
|
||||||
audacity-ffmpeg.patch)
|
|
||||||
sha1sums=('3ff019e02a8ef9d712166dd1b466c494102a859a'
|
|
||||||
'5f1733a3802bcec7d9b54cb3ec8d7d81fc38fc61')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd audacity-Audacity-${pkgver}
|
|
||||||
patch -p1 -i "${srcdir}/audacity-ffmpeg.patch"
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd audacity-Audacity-${pkgver}
|
|
||||||
|
|
||||||
[[ $CARCH == 'arm' ]] && CONFIG="--without-soundtouch"
|
|
||||||
|
|
||||||
WX_CONFIG=/usr/bin/wx-config-2.8 ./configure --prefix=/usr --with-libsamplerate
|
|
||||||
|
|
||||||
make
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd audacity-Audacity-${pkgver}
|
|
||||||
make DESTDIR="${pkgdir}" install
|
|
||||||
}
|
|
|
@ -1,30 +0,0 @@
|
||||||
diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
|
|
||||||
--- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
|
|
||||||
+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
|
|
||||||
@@ -688,7 +688,7 @@
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
||||||
AVOutputFormat*,
|
|
||||||
av_oformat_next,
|
|
||||||
- (AVOutputFormat *f),
|
|
||||||
+ (const AVOutputFormat *f),
|
|
||||||
(f)
|
|
||||||
);
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
||||||
@@ -755,7 +755,7 @@
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
||||||
int,
|
|
||||||
av_fifo_size,
|
|
||||||
- (AVFifoBuffer *f),
|
|
||||||
+ (const AVFifoBuffer *f),
|
|
||||||
(f)
|
|
||||||
);
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
||||||
@@ -801,7 +801,7 @@
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
||||||
AVDictionaryEntry *,
|
|
||||||
av_dict_get,
|
|
||||||
- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
|
|
||||||
+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
|
|
||||||
(m, key, prev, flags)
|
|
||||||
);
|
|
||||||
FFMPEG_FUNCTION_WITH_RETURN(
|
|
|
@ -1,13 +0,0 @@
|
||||||
post_install() {
|
|
||||||
update-desktop-database -q
|
|
||||||
update-mime-database usr/share/mime &> /dev/null
|
|
||||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
|
||||||
}
|
|
||||||
|
|
||||||
post_upgrade() {
|
|
||||||
post_install
|
|
||||||
}
|
|
||||||
|
|
||||||
post_remove() {
|
|
||||||
post_install
|
|
||||||
}
|
|
Loading…
Reference in a new issue