extra/rust to 1.38.0-2

This commit is contained in:
Kevin Mihelich 2019-10-11 00:26:22 +00:00
parent e7e06ab0ac
commit b2e9e2c1a6
3 changed files with 72 additions and 59 deletions

View file

@ -4,6 +4,7 @@
# Contributor: userwithuid <userwithuid@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove lib32 package and related bits
# - add a link to g++ to compensate for broken cross-compiler decisions
# - build v6/v7 with -j2 - RAM constraints
# - set llvm-config in config.toml for ARM architectures
@ -12,14 +13,12 @@
buildarch=28
highmem=1
# Remember to bump lib32-rust as well!
pkgname=('rust' 'rust-docs')
epoch=1
pkgver=1.38.0
pkgrel=1
pkgrel=2
_llvm_ver=8.0.1
_llvm_ver=9.0.0
pkgdesc='Systems programming language focused on safety, speed and concurrency'
url='https://www.rust-lang.org/'
@ -33,26 +32,70 @@ options=('!emptydirs')
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
"https://github.com/llvm/llvm-project/releases/download/llvmorg-$_llvm_ver/compiler-rt-$_llvm_ver.src.tar.xz"{,.sig}
0001-WIP-minimize-the-rust-std-component.patch
config.toml)
bootstrap-1.38.patch
0001-WIP-minimize-the-rust-std-component.patch)
sha256sums=('644263ca7c7106f8ee8fcde6bb16910d246b30668a74be20b8c7e0e9f4a52d80'
'SKIP'
'11828fb4823387d820c6715b25f6b2405e60837d12a7469e7a8882911c721837'
'56e4cd96dd1d8c346b07b4d6b255f976570c6f2389697347a6c3dcb9e820d10e'
'SKIP'
'1d6b69444ef6ff033fe1612e56ecdaad5c52aa44395e704f78b1a047c65b9321'
'27ac00c9e3a1daeed7b5d343cd7ef45c98a348e6d9178b4d7a501d97eb16e5c7')
'71935e8994d1045680cde22f72a12c4959e1877e5a42fc21fd034d677100dab3'
'1d6b69444ef6ff033fe1612e56ecdaad5c52aa44395e704f78b1a047c65b9321')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE' # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
'474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>
'474E22316ABF4785A88C6E8EA2C794A986419D8A' # Tom Stellard <tstellar@redhat.com>
'B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
prepare() {
cd "rustc-$pkgver-src"
# Fix bootstrap to compile with 1.38
patch -Np1 -i ../bootstrap-1.38.patch
# For https://bugzilla.redhat.com/show_bug.cgi?id=1756487
# From https://src.fedoraproject.org/rpms/rust/tree/master
patch -Np1 -i ../0001-WIP-minimize-the-rust-std-component.patch
cp "$srcdir"/config.toml config.toml
cat >config.toml <<END
[llvm]
link-shared = true
[build]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
python = "/usr/bin/python"
extended = true
sanitizers = false
profiler = true
vendor = true
[install]
prefix = "/usr"
[rust]
# LLVM crashes when passing an object through ThinLTO twice. This is triggered when using rust
# code in cross-language LTO if libstd was built using ThinLTO.
# http://blog.llvm.org/2019/09/closing-gap-cross-language-lto-between.html
# https://github.com/rust-lang/rust/issues/54872
codegen-units-std = 1
debuginfo-level = 0
channel = "stable"
rpath = false
[target.x86_64-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
[target.aarch64-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
[target.armv7-unknown-linux-gnueabihf]
llvm-config = "/usr/bin/llvm-config"
[target.arm-unknown-linux-gnueabihf]
llvm-config = "/usr/bin/llvm-config"
END
if [[ $CARCH == armv7h ]]; then
mkdir path
@ -64,14 +107,7 @@ prepare() {
fi
}
build() {
cd "rustc-$pkgver-src"
export RUST_BACKTRACE=1
export RUST_COMPILER_RT_ROOT="$srcdir/compiler-rt-$_llvm_ver.src"
python ./x.py build $jobs
}
# Don't call build — install will duplicate a lot of work and --keep-stage is not enough
package_rust() {
depends=('gcc-libs' 'llvm-libs' 'curl' 'libssh2')
@ -81,7 +117,10 @@ package_rust() {
cd "rustc-$pkgver-src"
DESTDIR="$pkgdir" python ./x.py install
export RUST_BACKTRACE=1
export RUST_COMPILER_RT_ROOT="$srcdir/compiler-rt-$_llvm_ver.src"
DESTDIR="$pkgdir" python ./x.py install $jobs
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE*

View file

@ -0,0 +1,13 @@
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
index e54c9360baec..9e4cd5ebca74 100644
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
@@ -145,7 +145,7 @@ impl StepDescription {
only_hosts: S::ONLY_HOSTS,
should_run: S::should_run,
make_run: S::make_run,
- name: unsafe { ::std::intrinsics::type_name::<S>() },
+ name: std::any::type_name::<S>(),
}
}

View file

@ -1,39 +0,0 @@
[llvm]
link-shared = true
[build]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
python = "python"
extended = true
sanitizers = false
profiler = true
local-rebuild = false
[install]
prefix = "/usr"
[rust]
# LLVM crashes when passing an object through ThinLTO twice. This is triggered when using rust
# code in cross-language LTO if libstd was built using ThinLTO.
# http://blog.llvm.org/2019/09/closing-gap-cross-language-lto-between.html
# https://github.com/rust-lang/rust/issues/54872
codegen-units-std = 1
debuginfo-level = 0
channel = "stable"
rpath = false
[target.x86_64-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
[target.aarch64-unknown-linux-gnu]
llvm-config = "/usr/bin/llvm-config"
[target.armv7-unknown-linux-gnueabihf]
llvm-config = "/usr/bin/llvm-config"
[target.arm-unknown-linux-gnueabihf]
llvm-config = "/usr/bin/llvm-config"