core/linux-armv5-rc to 4.1.rc7-2

This commit is contained in:
Kevin Mihelich 2015-06-15 02:34:34 +00:00
parent 05ac075e19
commit b2f722c82b
8 changed files with 946 additions and 1164 deletions

View file

@ -1,7 +1,7 @@
From e74efbd1dd2b84c8761af9d2be2dc1294fbb8b6d Mon Sep 17 00:00:00 2001
From 0529b39bd74633bff2cedc6718e36a349a40b288 Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Mon, 29 Jul 2013 20:14:38 +0200
Subject: [PATCH 1/5] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
Subject: [PATCH 1/6] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
---
sound/soc/codecs/Kconfig | 4 +
@ -2891,5 +2891,5 @@ index 0000000..2fba109
+
+#endif
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 67cd1951bac133002ce52cd7132625ff6f1943a8 Mon Sep 17 00:00:00 2001
From 4ce602d47cfe84584d3254cc5d9210dcde51abdc Mon Sep 17 00:00:00 2001
From: Robert Nelson <robertcnelson@gmail.com>
Date: Mon, 12 Aug 2013 11:27:22 -0500
Subject: [PATCH 2/5] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
Subject: [PATCH 2/6] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
---
@ -50,5 +50,5 @@ index 8204539..db0fd3f 100644
+ };
};
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From aad1b273d25d2a45aa7527913955c215eac4b86f Mon Sep 17 00:00:00 2001
From 211315da444680859fca69b2377d1c3a30d7c2b0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 18 Jun 2014 21:55:51 -0600
Subject: [PATCH 3/5] imx23 I2C fixes
Subject: [PATCH 3/6] imx23 I2C fixes
---
arch/arm/boot/dts/imx23-olinuxino.dts | 35 ++++++++++++++++++++++++++++++
@ -122,5 +122,5 @@ index bbcfb5a..54b6a83 100644
dma-names = "rx-tx";
status = "disabled";
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From 1d9e3650cc61660e0bed3c4696be90cff10cd21b Mon Sep 17 00:00:00 2001
From a304cd81213a2b631a0c7900b324c867a922ad0c Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Tue, 30 Jul 2013 14:28:17 +0200
Subject: [PATCH 4/5] Added DTS with mxs-builtin-* entries for testing the
Subject: [PATCH 4/6] Added DTS with mxs-builtin-* entries for testing the
audio driver.
---
@ -169,5 +169,5 @@ index 0000000..1555896
+ };
+};
--
2.3.5
2.4.3

View file

@ -1,7 +1,7 @@
From c64d2aae17c941a1fae8a6a59655ec8b5b3e9bf8 Mon Sep 17 00:00:00 2001
From eb51d1cb5bce9627563695e385b39b891e998a4c Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 5/5] at91: ariag25 updates
Subject: [PATCH 5/6] at91: ariag25 updates
v2: dropped at91sam9x5 usart fix, as merged mainline
@ -89,5 +89,5 @@ index e9ced30..8308515 100644
usb0: ohci@00600000 {
--
2.3.5
2.4.3

View file

@ -0,0 +1,380 @@
From 002ce387a17a7be9b625e05d1cb7e2f227aa7ca7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Jun 2015 13:46:30 -0600
Subject: [PATCH 6/6] at91: arietta-g25 support
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/Makefile | 2 +
arch/arm/boot/dts/at91-arietta128.dts | 169 ++++++++++++++++++++++++++++++++++
arch/arm/boot/dts/at91-arietta256.dts | 169 ++++++++++++++++++++++++++++++++++
3 files changed, 340 insertions(+)
create mode 100644 arch/arm/boot/dts/at91-arietta128.dts
create mode 100644 arch/arm/boot/dts/at91-arietta256.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 992736b..b91ed4d 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -31,6 +31,8 @@ dtb-$(CONFIG_SOC_SAM_V4_V5) += \
at91sam9n12ek.dtb \
at91sam9rlek.dtb \
at91-ariag25.dtb \
+ at91-arietta128.dtb \
+ at91-arietta256.dtb \
at91-cosino_mega2560.dtb \
at91sam9g15ek.dtb \
at91sam9g25ek.dtb \
diff --git a/arch/arm/boot/dts/at91-arietta128.dts b/arch/arm/boot/dts/at91-arietta128.dts
new file mode 100644
index 0000000..e43533d
--- /dev/null
+++ b/arch/arm/boot/dts/at91-arietta128.dts
@@ -0,0 +1,169 @@
+/*
+ * acme-arietta.dts - Device Tree file for Arietta G25
+ * Generated by http://dts.acmesystems.it/arietta
+ */
+/dts-v1/;
+#include "at91sam9g25.dtsi"
+/ {
+ model = "Acme Systems Arietta G25";
+ compatible = "acme,ariettag25", "atmel,at91sam9x5ek","atmel,at91sam9x5", "atmel,at91sam9";
+ aliases {
+ serial0 = &dbgu;
+ serial1 = &usart0;
+ serial2 = &usart1;
+ serial3 = &usart2;
+ serial4 = &usart3;
+ serial5 = &uart0;
+ serial6 = &uart1;
+ };
+ chosen {
+ bootargs = "console=ttyS0,115200 root=/dev/mmcblk0p2 rw rootwait";
+ };
+ memory {
+ reg = <0x20000000 0x8000000>;
+ };
+ clocks {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ ranges;
+ main_clock: clock@0 {
+ compatible = "atmel,osc", "fixed-clock";
+ clock-frequency = <12000000>;
+ };
+
+ main_xtal {
+ clock-frequency = <12000000>;
+ };
+ };
+ ahb {
+ apb {
+ mmc0: mmc@f0008000 {
+ pinctrl-0 = <
+ &pinctrl_mmc0_slot0_clk_cmd_dat0
+ &pinctrl_mmc0_slot0_dat1_3>;
+ status = "okay";
+ slot@0 {
+ reg = <0>;
+ bus-width = <4>;
+ };
+ };
+ i2c0: i2c@f8010000 {
+ status ="okay";
+ wm8731: wm8731@1b {
+ compatible = "wm8731";
+ reg = <0x1b>;
+ };
+ };
+ i2c1: i2c@f8014000 {
+ status ="okay";
+ };
+ usart0: serial@f801c000 {
+ pinctrl-0 = <&pinctrl_usart0>;
+ status ="okay";
+ };
+ spi1: spi@f0004000 {
+ status = "okay";
+ cs-gpios = <&pioA 8 0>, <&pioA 0 0>, <&pioA 31 0>, <&pioA 30 0>;
+ device@0 {
+ compatible = "spidev";
+ spi-max-frequency = <5000000>; // 5 MHz
+ reg = <0>;
+ };
+ };
+
+ pinctrl@fffff400 {
+ adc0 {
+ pinctrl_adc0_ad0: adc0_ad0 {
+ atmel,pins = <AT91_PIOB 11 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad1: adc0_ad1 {
+ atmel,pins = <AT91_PIOB 12 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad2: adc0_ad2 {
+ atmel,pins = <AT91_PIOB 13 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad3: adc0_ad3 {
+ atmel,pins = <AT91_PIOB 14 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ };
+ };
+
+ adc0: adc@f804c000 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_adc0_ad0 &pinctrl_adc0_ad1 &pinctrl_adc0_ad2 &pinctrl_adc0_ad3>;
+ atmel,adc-channels-used = <0xf>;
+ atmel,adc-num-channels = <4>;
+ compatible = "atmel,at91sam9x5-adc";
+ atmel,adc-startup-time = <40>;
+ atmel,adc-status-register = <0x1c>;
+ atmel,adc-trigger-register = <0x08>;
+ atmel,adc-use-external;
+ atmel,adc-vref = <3250>;
+ atmel,adc-res = <8 10>;
+ atmel,adc-res-names = "lowres", "highres";
+ atmel,adc-use-res = "highres";
+ trigger@0 {
+ trigger-name = "continuous";
+ trigger-value = <0x6>;
+ };
+ };
+
+ ssc0: ssc@f0010000 {
+ status = "okay";
+ };
+ usb2: gadget@f803c000 {
+ status = "okay";
+ };
+ dbgu: serial@fffff200 {
+ status = "okay";
+ };
+ pinctrl@fffff400 {
+ w1_0 {
+ pinctrl_w1_0: w1_0-0 {
+ /* pull up on */
+ atmel,pins = <2 31 0x0 0x1>;
+ };
+ };
+
+ };
+ rtc@fffffeb0 {
+ status = "okay";
+ };
+ };
+ usb0: ohci@00600000 {
+ status = "okay";
+ num-ports = <3>;
+ };
+ usb1: ehci@00700000 {
+ status = "okay";
+ };
+ };
+ leds {
+ compatible = "gpio-leds";
+ arietta_led {
+ label = "arietta_led";
+ gpios = <&pioB 8 GPIO_ACTIVE_HIGH>; /* PB8 */
+ linux,default-trigger = "heartbeat";
+ };
+ };
+ onewire@0 {
+ compatible = "w1-gpio";
+ gpios = <&pioC 31 GPIO_ACTIVE_LOW>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_w1_0>;
+ };
+
+ sound {
+ compatible = "atmel,sam9x5-wm8731-audio";
+ atmel,model = "wm8731 @ AT91SAM9X5EK";
+ atmel,audio-routing =
+ "Headphone Jack", "RHPOUT",
+ "Headphone Jack", "LHPOUT",
+ "LLINEIN", "Line In Jack",
+ "RLINEIN", "Line In Jack";
+ atmel,ssc-controller = <&ssc0>;
+ atmel,audio-codec = <&wm8731>;
+ };
+
+};
diff --git a/arch/arm/boot/dts/at91-arietta256.dts b/arch/arm/boot/dts/at91-arietta256.dts
new file mode 100644
index 0000000..cbae789
--- /dev/null
+++ b/arch/arm/boot/dts/at91-arietta256.dts
@@ -0,0 +1,169 @@
+/*
+ * acme-arietta.dts - Device Tree file for Arietta G25
+ * Generated by http://dts.acmesystems.it/arietta
+ */
+/dts-v1/;
+#include "at91sam9g25.dtsi"
+/ {
+ model = "Acme Systems Arietta G25";
+ compatible = "acme,ariettag25", "atmel,at91sam9x5ek","atmel,at91sam9x5", "atmel,at91sam9";
+ aliases {
+ serial0 = &dbgu;
+ serial1 = &usart0;
+ serial2 = &usart1;
+ serial3 = &usart2;
+ serial4 = &usart3;
+ serial5 = &uart0;
+ serial6 = &uart1;
+ };
+ chosen {
+ bootargs = "console=ttyS0,115200 root=/dev/mmcblk0p2 rw rootwait";
+ };
+ memory {
+ reg = <0x20000000 0x10000000>;
+ };
+ clocks {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ ranges;
+ main_clock: clock@0 {
+ compatible = "atmel,osc", "fixed-clock";
+ clock-frequency = <12000000>;
+ };
+
+ main_xtal {
+ clock-frequency = <12000000>;
+ };
+ };
+ ahb {
+ apb {
+ mmc0: mmc@f0008000 {
+ pinctrl-0 = <
+ &pinctrl_mmc0_slot0_clk_cmd_dat0
+ &pinctrl_mmc0_slot0_dat1_3>;
+ status = "okay";
+ slot@0 {
+ reg = <0>;
+ bus-width = <4>;
+ };
+ };
+ i2c0: i2c@f8010000 {
+ status ="okay";
+ wm8731: wm8731@1b {
+ compatible = "wm8731";
+ reg = <0x1b>;
+ };
+ };
+ i2c1: i2c@f8014000 {
+ status ="okay";
+ };
+ usart0: serial@f801c000 {
+ pinctrl-0 = <&pinctrl_usart0>;
+ status ="okay";
+ };
+ spi1: spi@f0004000 {
+ status = "okay";
+ cs-gpios = <&pioA 8 0>, <&pioA 0 0>, <&pioA 31 0>, <&pioA 30 0>;
+ device@0 {
+ compatible = "spidev";
+ spi-max-frequency = <5000000>; // 5 MHz
+ reg = <0>;
+ };
+ };
+
+ pinctrl@fffff400 {
+ adc0 {
+ pinctrl_adc0_ad0: adc0_ad0 {
+ atmel,pins = <AT91_PIOB 11 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad1: adc0_ad1 {
+ atmel,pins = <AT91_PIOB 12 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad2: adc0_ad2 {
+ atmel,pins = <AT91_PIOB 13 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ pinctrl_adc0_ad3: adc0_ad3 {
+ atmel,pins = <AT91_PIOB 14 AT91_PERIPH_GPIO AT91_PINCTRL_NONE>;
+ };
+ };
+ };
+
+ adc0: adc@f804c000 {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_adc0_ad0 &pinctrl_adc0_ad1 &pinctrl_adc0_ad2 &pinctrl_adc0_ad3>;
+ atmel,adc-channels-used = <0xf>;
+ atmel,adc-num-channels = <4>;
+ compatible = "atmel,at91sam9x5-adc";
+ atmel,adc-startup-time = <40>;
+ atmel,adc-status-register = <0x1c>;
+ atmel,adc-trigger-register = <0x08>;
+ atmel,adc-use-external;
+ atmel,adc-vref = <3250>;
+ atmel,adc-res = <8 10>;
+ atmel,adc-res-names = "lowres", "highres";
+ atmel,adc-use-res = "highres";
+ trigger@0 {
+ trigger-name = "continuous";
+ trigger-value = <0x6>;
+ };
+ };
+
+ ssc0: ssc@f0010000 {
+ status = "okay";
+ };
+ usb2: gadget@f803c000 {
+ status = "okay";
+ };
+ dbgu: serial@fffff200 {
+ status = "okay";
+ };
+ pinctrl@fffff400 {
+ w1_0 {
+ pinctrl_w1_0: w1_0-0 {
+ /* pull up on */
+ atmel,pins = <2 31 0x0 0x1>;
+ };
+ };
+
+ };
+ rtc@fffffeb0 {
+ status = "okay";
+ };
+ };
+ usb0: ohci@00600000 {
+ status = "okay";
+ num-ports = <3>;
+ };
+ usb1: ehci@00700000 {
+ status = "okay";
+ };
+ };
+ leds {
+ compatible = "gpio-leds";
+ arietta_led {
+ label = "arietta_led";
+ gpios = <&pioB 8 GPIO_ACTIVE_HIGH>; /* PB8 */
+ linux,default-trigger = "heartbeat";
+ };
+ };
+ onewire@0 {
+ compatible = "w1-gpio";
+ gpios = <&pioC 31 GPIO_ACTIVE_LOW>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_w1_0>;
+ };
+
+ sound {
+ compatible = "atmel,sam9x5-wm8731-audio";
+ atmel,model = "wm8731 @ AT91SAM9X5EK";
+ atmel,audio-routing =
+ "Headphone Jack", "RHPOUT",
+ "Headphone Jack", "LHPOUT",
+ "LLINEIN", "Line In Jack",
+ "RLINEIN", "Line In Jack";
+ atmel,ssc-controller = <&ssc0>;
+ atmel,audio-codec = <&wm8731>;
+ };
+
+};
--
2.4.3

View file

@ -11,7 +11,7 @@ _srcname=linux-4.$((${_rcver##*.}-1))
_kernelname=${pkgbase#linux}
_desc="ARMv5 multi-platform"
pkgver=${_rcver}.rc${_rcrel}
pkgrel=1
pkgrel=2
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
@ -24,15 +24,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0003-imx23-I2C-fixes.patch'
'0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
'0005-at91-ariag25-updates.patch'
'0006-at91-arietta-g25-support.patch'
'config')
md5sums=('a86916bd12798220da9eb4a1eec3616d'
'a831062aea035ee4bae52e59ccf0cf71'
'ed7991bb04554fd9ed4292ffd07bc916'
'9225efbd445352fcfeaa83317bed0825'
'560af5c50a5374201e3b89113cd69977'
'8b9d27de7a5a5b73dba4dbd249b378eb'
'a6461a6896d6d9bc2144ee199def455d'
'f2b89154ae5da2fe14c6d8c957b5599c')
'1576643242d4c2a4ef3f69c62cba953c'
'dc460708c043cac8c70e733fcd6e1a9b'
'e29707ad7bf5b2d357ad6d96cd9d88ac'
'decd45d4861dbf461196e6af4e34e423'
'8c926477e229099a35ce4b67c13dcc6a'
'069885e001c96ed6095dedd9bf840141'
'b187c9f4fcd65b4741a767a0a4a6bf3b')
prepare() {
cd "${srcdir}/${_srcname}"
@ -46,6 +48,7 @@ prepare() {
git apply ../0003-imx23-I2C-fixes.patch
git apply ../0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
git apply ../0005-at91-ariag25-updates.patch
git apply ../0006-at91-arietta-g25-support.patch
cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff