mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/mythtv to 0.27.5-3
This commit is contained in:
parent
e7867b8174
commit
b30ebdb396
2 changed files with 47 additions and 1 deletions
|
@ -11,7 +11,7 @@
|
||||||
|
|
||||||
pkgname=mythtv
|
pkgname=mythtv
|
||||||
pkgver=0.27.5
|
pkgver=0.27.5
|
||||||
pkgrel=2
|
pkgrel=3
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgdesc="A Homebrew PVR project"
|
pkgdesc="A Homebrew PVR project"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
|
@ -34,13 +34,18 @@ replaces=('myththemes' 'mythplugins-mythvideo')
|
||||||
install='mythtv.install'
|
install='mythtv.install'
|
||||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
|
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
|
||||||
'mythbackend.service'
|
'mythbackend.service'
|
||||||
|
'ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch'
|
||||||
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch')
|
'http://code.mythtv.org/trac/raw-attachment/ticket/11338/libcec-2-support.2.patch')
|
||||||
sha256sums=('7e625f94332effeadfba8e7ae7c98d44a83bfc25b7c59e39adce67dc2f4e1e1b'
|
sha256sums=('7e625f94332effeadfba8e7ae7c98d44a83bfc25b7c59e39adce67dc2f4e1e1b'
|
||||||
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
|
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
|
||||||
|
'277994aca5a6e40c1a90750859828817e0646bfb28142fdb34d5f9d3196c3f7a'
|
||||||
'8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3')
|
'8270407c2074b305e0c32151f89c84f6bf980a32665a2da8e4727405fa3911f3')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$srcdir/$pkgname-$pkgver/$pkgname"
|
cd "$srcdir/$pkgname-$pkgver/$pkgname"
|
||||||
|
|
||||||
|
patch -d external/FFmpeg -Np1 -i "$srcdir/ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch"
|
||||||
|
|
||||||
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
||||||
patch -Np2 -i "$srcdir/libcec-2-support.2.patch"
|
patch -Np2 -i "$srcdir/libcec-2-support.2.patch"
|
||||||
}
|
}
|
||||||
|
|
|
@ -0,0 +1,41 @@
|
||||||
|
From 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab Mon Sep 17 00:00:00 2001
|
||||||
|
From: James Zern <jzern@google.com>
|
||||||
|
Date: Mon, 19 Oct 2015 22:44:11 -0700
|
||||||
|
Subject: [PATCH] libvpxenc: remove some unused ctrl id mappings
|
||||||
|
|
||||||
|
VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
|
||||||
|
from libvpx and the remaining values were never used here
|
||||||
|
|
||||||
|
Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
|
||||||
|
Signed-off-by: James Zern <jzern@google.com>
|
||||||
|
---
|
||||||
|
libavcodec/libvpxenc.c | 8 --------
|
||||||
|
1 file changed, 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
|
||||||
|
index 5f39783..992122c 100644
|
||||||
|
--- a/libavcodec/libvpxenc.c
|
||||||
|
+++ b/libavcodec/libvpxenc.c
|
||||||
|
@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
|
||||||
|
|
||||||
|
/** String mappings for enum vp8e_enc_control_id */
|
||||||
|
static const char *const ctlidstr[] = {
|
||||||
|
- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
|
||||||
|
- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
|
||||||
|
- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
|
||||||
|
- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
|
||||||
|
- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
|
||||||
|
- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
|
||||||
|
[VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
|
||||||
|
[VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
|
||||||
|
[VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
|
||||||
|
- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
|
||||||
|
[VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
|
||||||
|
[VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
|
||||||
|
- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
|
||||||
|
[VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
|
||||||
|
[VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
|
||||||
|
[VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
|
||||||
|
--
|
||||||
|
1.7.10.4
|
||||||
|
|
Loading…
Reference in a new issue