mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/binutils to 2.29.1-1
This commit is contained in:
parent
3c6478cda3
commit
b343002ba4
2 changed files with 44 additions and 6 deletions
|
@ -0,0 +1,29 @@
|
|||
From 7a7431ddc2332ddc3753330a8dd815bb5f7193c0 Mon Sep 17 00:00:00 2001
|
||||
From: "H.J. Lu" <hjl.tools@gmail.com>
|
||||
Date: Tue, 26 Sep 2017 14:41:22 -0700
|
||||
Subject: [PATCH] x86-64: Don't pass output_bfd to info->callbacks->minfo
|
||||
|
||||
Don't pass output_bfd to info->callbacks->minfo when dumping local IFUNC
|
||||
functions in the map file.
|
||||
|
||||
PR ld/22199
|
||||
* elf64-x86-64.c (elf_x86_64_finish_dynamic_symbol): Don't pass
|
||||
output_bfd to info->callbacks->minfo.
|
||||
|
||||
(cherry picked from commit ac69a0d75bf472a140e5405c8a90420d5f63a998)
|
||||
|
||||
diff --git a/bfd/elf64-x86-64.c b/bfd/elf64-x86-64.c
|
||||
index d9225ad..1f6dfb8 100644
|
||||
--- a/bfd/elf64-x86-64.c
|
||||
+++ b/bfd/elf64-x86-64.c
|
||||
@@ -6133,7 +6133,6 @@ elf_x86_64_finish_dynamic_symbol (bfd *output_bfd,
|
||||
if (SYMBOL_REFERENCES_LOCAL (info, h))
|
||||
{
|
||||
info->callbacks->minfo (_("Local IFUNC function `%s' in %B\n"),
|
||||
- output_bfd,
|
||||
h->root.root.string,
|
||||
h->root.u.def.section->owner);
|
||||
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -11,9 +11,8 @@
|
|||
noautobuild=1
|
||||
|
||||
pkgname=binutils
|
||||
pkgver=2.29.0
|
||||
pkgver=2.29.1
|
||||
pkgrel=1
|
||||
_commit=dd9a28c0966d13924fbd1096a724ae334954d830
|
||||
pkgdesc='A set of programs to assemble and manipulate binary and object files'
|
||||
arch=(i686 x86_64)
|
||||
url='http://www.gnu.org/software/binutils/'
|
||||
|
@ -23,16 +22,26 @@ depends=('glibc>=2.26' zlib)
|
|||
makedepends=(git)
|
||||
checkdepends=(dejagnu bc)
|
||||
options=(staticlibs !distcc !ccache)
|
||||
source=(git://sourceware.org/git/binutils-gdb.git#commit=${_commit})
|
||||
md5sums=('SKIP')
|
||||
#_commit=d1a6e7195b9bb0255fa77588985b969ad8aaacf5
|
||||
#source=(git+https://sourceware.org/git/binutils-gdb.git#commit=${_commit}
|
||||
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig}
|
||||
0001-x86-64_Dont_pass_output_bfd_to_info-callbacks-minfo.patch)
|
||||
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
|
||||
md5sums=('acc9cd826edb9954ac7cecb81c727793'
|
||||
'SKIP'
|
||||
'e4be936139ef46122cb3841881c432b2')
|
||||
|
||||
prepare() {
|
||||
mkdir -p binutils-build
|
||||
|
||||
cd binutils-gdb
|
||||
#cd binutils-gdb
|
||||
cd binutils-$pkgver
|
||||
|
||||
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
|
||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
|
||||
|
||||
# https://bugs.archlinux.org/task/55741
|
||||
git apply ../0001-x86-64_Dont_pass_output_bfd_to_info-callbacks-minfo.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -44,7 +53,7 @@ build() {
|
|||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf"
|
||||
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu"
|
||||
|
||||
"$srcdir/binutils-gdb/configure" \
|
||||
"$srcdir/binutils-$pkgver/configure" \
|
||||
--prefix=/usr \
|
||||
--with-lib-path=/usr/lib:/usr/local/lib \
|
||||
--with-bugurl=https://github.com/archlinuxarm/PKGBUILDs/issues \
|
||||
|
|
Loading…
Reference in a new issue