extra/calligra to 3.1.0-21

This commit is contained in:
Kevin Mihelich 2019-08-23 13:02:01 +00:00
parent 9cd15e721c
commit b35c8b2674
2 changed files with 26 additions and 1 deletions

View file

@ -10,7 +10,7 @@
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=19
pkgrel=21
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -41,6 +41,7 @@ for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb n
done
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
calligra-qt5.11.patch
calligra-qt5.13.patch
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
calligra-poppler-0.71.patch
calligra-poppler-0.72.patch
@ -49,6 +50,7 @@ source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.x
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
'd32a9cda1343f224f5a0cfa2b8122c5571a0dbb09c9948414d6770d9c3814f4d'
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
@ -63,6 +65,8 @@ prepare() {
cd $pkgname-$pkgver
# Fix build with Qt 5.11
patch -p1 -i ../calligra-qt5.11.patch
# Fix build with Qt 5.13
patch -p1 -i ../calligra-qt5.13.patch
# Fix build with poppler 0.69
patch -p1 -i ../calligra-poppler-0.69.patch
# Fix build with poppler 0.71

View file

@ -0,0 +1,21 @@
From 0c5430697bdcf41a45046107b28014e40c49a11a Mon Sep 17 00:00:00 2001
From: David Faure <faure@kde.org>
Date: Tue, 23 Jul 2019 13:02:34 +0200
Subject: [PATCH] Fix compilation with Qt 5.13 (missing include)
---
sheets/plugins/calendar/CalendarToolWidget.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/sheets/plugins/calendar/CalendarToolWidget.cpp b/sheets/plugins/calendar/CalendarToolWidget.cpp
index b10b23022a2..0c5eeb68cf3 100644
--- a/sheets/plugins/calendar/CalendarToolWidget.cpp
+++ b/sheets/plugins/calendar/CalendarToolWidget.cpp
@@ -30,6 +30,7 @@
#include <kdatepicker.h>
#include <QPushButton>
+#include <QDate>
namespace Calligra
{