mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-udoo to 2016.11-1
This commit is contained in:
parent
a202b09247
commit
b371684bdd
2 changed files with 32 additions and 20 deletions
|
@ -1,26 +1,37 @@
|
||||||
From 446af39a88aa7a8f63a2e484df8bb828851e47ec Mon Sep 17 00:00:00 2001
|
From 47c20fdeda242b8c605722eb3799af67061fe7bb Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Tue, 26 Jul 2016 21:28:27 -0600
|
Date: Tue, 26 Jul 2016 21:28:27 -0600
|
||||||
Subject: [PATCH] arch linux arm modifications
|
Subject: [PATCH] arch linux arm modifications
|
||||||
|
|
||||||
---
|
---
|
||||||
include/configs/udoo.h | 103 +++++++++++++++++++++++--------------------------
|
configs/udoo_defconfig | 1 +
|
||||||
1 file changed, 49 insertions(+), 54 deletions(-)
|
include/configs/udoo.h | 105 ++++++++++++++++++++++++-------------------------
|
||||||
|
2 files changed, 52 insertions(+), 54 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configs/udoo_defconfig b/configs/udoo_defconfig
|
||||||
|
index a4a17c1..514cbd2 100644
|
||||||
|
--- a/configs/udoo_defconfig
|
||||||
|
+++ b/configs/udoo_defconfig
|
||||||
|
@@ -30,3 +30,4 @@ CONFIG_CMD_FS_GENERIC=y
|
||||||
|
CONFIG_DM=y
|
||||||
|
CONFIG_DM_THERMAL=y
|
||||||
|
CONFIG_OF_LIBFDT=y
|
||||||
|
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
||||||
diff --git a/include/configs/udoo.h b/include/configs/udoo.h
|
diff --git a/include/configs/udoo.h b/include/configs/udoo.h
|
||||||
index fba78d0..b96f490 100644
|
index 0a7767c..44e664c 100644
|
||||||
--- a/include/configs/udoo.h
|
--- a/include/configs/udoo.h
|
||||||
+++ b/include/configs/udoo.h
|
+++ b/include/configs/udoo.h
|
||||||
@@ -18,6 +18,8 @@
|
@@ -51,6 +51,9 @@
|
||||||
#define MACH_TYPE_UDOO 4800
|
|
||||||
#define CONFIG_MACH_TYPE MACH_TYPE_UDOO
|
|
||||||
|
|
||||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
/* Command definition */
|
||||||
+
|
#define CONFIG_CMD_BMODE
|
||||||
/* Size of malloc() pool */
|
+#define CONFIG_PARTITION_UUIDS
|
||||||
#define CONFIG_SYS_MALLOC_LEN (2 * SZ_1M)
|
+#define CONFIG_CMD_PART
|
||||||
|
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||||
|
|
||||||
@@ -63,7 +65,6 @@
|
#define CONFIG_SYS_MEMTEST_START 0x10000000
|
||||||
|
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
|
||||||
|
@@ -61,7 +64,6 @@
|
||||||
#define CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
|
#define CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
|
||||||
|
|
||||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||||
|
@ -28,7 +39,7 @@ index fba78d0..b96f490 100644
|
||||||
"image=zImage\0" \
|
"image=zImage\0" \
|
||||||
"console=ttymxc1\0" \
|
"console=ttymxc1\0" \
|
||||||
"splashpos=m,m\0" \
|
"splashpos=m,m\0" \
|
||||||
@@ -71,47 +72,50 @@
|
@@ -69,47 +71,51 @@
|
||||||
"initrd_high=0xffffffff\0" \
|
"initrd_high=0xffffffff\0" \
|
||||||
"fdt_file=undefined\0" \
|
"fdt_file=undefined\0" \
|
||||||
"fdt_addr=0x18000000\0" \
|
"fdt_addr=0x18000000\0" \
|
||||||
|
@ -55,7 +66,6 @@ index fba78d0..b96f490 100644
|
||||||
- "mmc write ${loadaddr} 0x2 ${fw_sz}; " \
|
- "mmc write ${loadaddr} 0x2 ${fw_sz}; " \
|
||||||
- "fi; " \
|
- "fi; " \
|
||||||
- "fi\0" \
|
- "fi\0" \
|
||||||
+ "mmcroot=/dev/mmcblk0p1 rootwait rw\0" \
|
|
||||||
"mmcargs=setenv bootargs console=${console},${baudrate} " \
|
"mmcargs=setenv bootargs console=${console},${baudrate} " \
|
||||||
- "root=${mmcroot}\0" \
|
- "root=${mmcroot}\0" \
|
||||||
- "loadbootscript=" \
|
- "loadbootscript=" \
|
||||||
|
@ -76,7 +86,7 @@ index fba78d0..b96f490 100644
|
||||||
- "echo WARN: Cannot load the DT; " \
|
- "echo WARN: Cannot load the DT; " \
|
||||||
- "fi; " \
|
- "fi; " \
|
||||||
+ "${optargs} " \
|
+ "${optargs} " \
|
||||||
+ "root=${mmcroot} " \
|
+ "root=${root} " \
|
||||||
+ "video=${video}\0" \
|
+ "video=${video}\0" \
|
||||||
+ "loadimage=echo Loading /boot/${image}..; load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/${image}\0" \
|
+ "loadimage=echo Loading /boot/${image}..; load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/${image}\0" \
|
||||||
+ "loadfdt=echo Loading /boot/dtbs/${fdt_file}..; load mmc ${mmcdev}:${mmcpart} ${fdt_addr} /boot/dtbs/${fdt_file}\0" \
|
+ "loadfdt=echo Loading /boot/dtbs/${fdt_file}..; load mmc ${mmcdev}:${mmcpart} ${fdt_addr} /boot/dtbs/${fdt_file}\0" \
|
||||||
|
@ -85,6 +95,8 @@ index fba78d0..b96f490 100644
|
||||||
+ "if mmc rescan; then " \
|
+ "if mmc rescan; then " \
|
||||||
+ "echo SD/MMC found on device ${mmcdev};" \
|
+ "echo SD/MMC found on device ${mmcdev};" \
|
||||||
+ "setenv bootpart ${mmcdev}:1; " \
|
+ "setenv bootpart ${mmcdev}:1; " \
|
||||||
|
+ "part uuid mmc ${bootpart} uuid;" \
|
||||||
|
+ "setenv root PARTUUID=${uuid} rw rootwait;" \
|
||||||
+ "echo Checking for: ${bootdir}/uEnv.txt ...;" \
|
+ "echo Checking for: ${bootdir}/uEnv.txt ...;" \
|
||||||
+ "if test -e mmc ${bootpart} ${bootdir}/uEnv.txt; then " \
|
+ "if test -e mmc ${bootpart} ${bootdir}/uEnv.txt; then " \
|
||||||
+ "load mmc ${bootpart} ${loadaddr} ${bootdir}/uEnv.txt;" \
|
+ "load mmc ${bootpart} ${loadaddr} ${bootdir}/uEnv.txt;" \
|
||||||
|
@ -115,7 +127,7 @@ index fba78d0..b96f490 100644
|
||||||
"fi;\0" \
|
"fi;\0" \
|
||||||
"netargs=setenv bootargs console=${console},${baudrate} " \
|
"netargs=setenv bootargs console=${console},${baudrate} " \
|
||||||
"root=/dev/nfs " \
|
"root=/dev/nfs " \
|
||||||
@@ -137,26 +141,17 @@
|
@@ -135,26 +141,17 @@
|
||||||
"else " \
|
"else " \
|
||||||
"bootz; " \
|
"bootz; " \
|
||||||
"fi;\0" \
|
"fi;\0" \
|
||||||
|
@ -151,5 +163,5 @@ index fba78d0..b96f490 100644
|
||||||
/* Print Buffer Size */
|
/* Print Buffer Size */
|
||||||
#define CONFIG_SYS_PBSIZE (CONFIG_SYS_CBSIZE + sizeof(CONFIG_SYS_PROMPT) + 16)
|
#define CONFIG_SYS_PBSIZE (CONFIG_SYS_CBSIZE + sizeof(CONFIG_SYS_PROMPT) + 16)
|
||||||
--
|
--
|
||||||
2.10.0
|
2.10.2
|
||||||
|
|
||||||
|
|
|
@ -4,7 +4,7 @@
|
||||||
buildarch=4
|
buildarch=4
|
||||||
|
|
||||||
pkgname=uboot-udoo
|
pkgname=uboot-udoo
|
||||||
pkgver=2016.09
|
pkgver=2016.11
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="U-Boot for UDOO Dual and Quad"
|
pkgdesc="U-Boot for UDOO Dual and Quad"
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
|
@ -15,8 +15,8 @@ license=('GPL')
|
||||||
install=${pkgname}.install
|
install=${pkgname}.install
|
||||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||||
'0001-arch-linux-arm-modifications.patch')
|
'0001-arch-linux-arm-modifications.patch')
|
||||||
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1'
|
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
|
||||||
'6165211bb53ee947ce58a22828984b5e')
|
'c4323b9ac181ac8f526349eed88e0ded')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd u-boot-${pkgver/rc/-rc}
|
cd u-boot-${pkgver/rc/-rc}
|
||||||
|
|
Loading…
Reference in a new issue