mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/meson to 0.58.1-1
This commit is contained in:
parent
d27298959e
commit
b390199d6d
2 changed files with 3 additions and 41 deletions
|
@ -6,8 +6,8 @@
|
|||
# - disable lto in arch-meson
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.58.0
|
||||
pkgrel=2
|
||||
pkgver=0.58.1
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='https://mesonbuild.com/'
|
||||
arch=('any')
|
||||
|
@ -20,12 +20,10 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
|
|||
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
|
||||
'python-pytest-xdist' 'python2-setuptools' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
|
||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver/rc/.rc}/meson-${pkgver}.tar.gz{,.asc}
|
||||
workaround-8744.diff
|
||||
skip-test.diff
|
||||
arch-meson)
|
||||
sha512sums=('6a075666a12962a613c63c35e19c692b31ee434ce61040ecd12af83d98766164076744570fe426ebf7f6a93ce83f7fdce26c8447f9d3752f6b94824d57c751c5'
|
||||
sha512sums=('64ac1a9bcc642fb6d37c4b677d8b7db16d821f852f927a980d3fb1c149d680b7ff2c8d03676c6772666d46a33b6ce8674220433d302fcd92d13d9818558d6453'
|
||||
'SKIP'
|
||||
'5f4ab315599c5c950048472a92b4ef28cd978cfc2aed17f8361174d68ad1ef153a72ff4e6d3d0593d0363b8988daca9c454a55c33422b9f3357e0a55e1545155'
|
||||
'a40e3be7a4ea7048cbbab59d28fb355debdfcdc5e45244aad65ab57fa222f4a2cf3165f28cc7e1dba893a162de9c7563ef0e155fa6a77960c4d02ef622313ace'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
@ -33,9 +31,6 @@ validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpak
|
|||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# Workaround https://github.com/mesonbuild/meson/issues/8744
|
||||
patch -Np1 -i ../workaround-8744.diff
|
||||
|
||||
# Our containers do not allow sanitizers to run
|
||||
patch -Np1 -i ../skip-test.diff
|
||||
}
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
diff --git i/mesonbuild/backend/backends.py w/mesonbuild/backend/backends.py
|
||||
index ee5f4463a..4100c54c9 100644
|
||||
--- i/mesonbuild/backend/backends.py
|
||||
+++ w/mesonbuild/backend/backends.py
|
||||
@@ -23,6 +23,7 @@ import pickle
|
||||
import re
|
||||
import typing as T
|
||||
import hashlib
|
||||
+import copy
|
||||
|
||||
from .. import build
|
||||
from .. import dependencies
|
||||
@@ -1429,7 +1430,19 @@ class Backend:
|
||||
d.targets.append(i)
|
||||
|
||||
def generate_custom_install_script(self, d: InstallData) -> None:
|
||||
- d.install_scripts = self.build.install_scripts
|
||||
+ result: T.List[ExecutableSerialisation] = []
|
||||
+ srcdir = self.environment.get_source_dir()
|
||||
+ builddir = self.environment.get_build_dir()
|
||||
+ for i in self.build.install_scripts:
|
||||
+ fixed_args = []
|
||||
+ for a in i.cmd_args:
|
||||
+ a = a.replace('@SOURCE_ROOT@', srcdir)
|
||||
+ a = a.replace('@BUILD_ROOT@', builddir)
|
||||
+ fixed_args.append(a)
|
||||
+ es = copy.copy(i)
|
||||
+ es.cmd_args = fixed_args
|
||||
+ result.append(es)
|
||||
+ d.install_scripts = result
|
||||
|
||||
def generate_header_install(self, d: InstallData) -> None:
|
||||
incroot = self.environment.get_includedir()
|
Loading…
Reference in a new issue