mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added extra/gimp
This commit is contained in:
parent
9e25fa06df
commit
b3ba06af86
4 changed files with 228 additions and 0 deletions
58
extra/gimp/0001-do-not-hardcode-gegl-version.patch
Normal file
58
extra/gimp/0001-do-not-hardcode-gegl-version.patch
Normal file
|
@ -0,0 +1,58 @@
|
|||
From f6a8d93190e2e00006295ed1c1a7c34b770989d6 Mon Sep 17 00:00:00 2001
|
||||
From: Jehan <jehan@girinstud.io>
|
||||
Date: Sat, 28 Apr 2018 01:30:19 +0200
|
||||
Subject: [PATCH] configure, gimp.pc: do no hardcode the major.minor version of
|
||||
GEGL.
|
||||
|
||||
---
|
||||
configure.ac | 10 +++++++---
|
||||
gimp.pc.in | 2 +-
|
||||
2 files changed, 8 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 07faa44..f017e34 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -44,7 +44,10 @@ m4_define([gimp_full_name], [GNU Image Manipulation Program])
|
||||
|
||||
# required versions of other packages
|
||||
m4_define([babl_required_version], [0.1.46])
|
||||
-m4_define([gegl_required_version], [0.4.0])
|
||||
+m4_define([gegl_major_minor_version], [0.4])
|
||||
+m4_define([gegl_micro_version], [0])
|
||||
+m4_define([gegl_required_version],
|
||||
+ [gegl_major_minor_version.gegl_micro_version])
|
||||
m4_define([glib_required_version], [2.54.2])
|
||||
m4_define([atk_required_version], [2.2.0])
|
||||
m4_define([gtk_required_version], [2.24.10])
|
||||
@@ -141,6 +144,7 @@ GTK_REQUIRED_VERSION=gtk_required_version
|
||||
GTK_WIN32_RECOMMENDED_VERSION=gtk_win32_recommended_version
|
||||
CAIRO_REQUIRED_VERSION=cairo_required_version
|
||||
CAIRO_PDF_REQUIRED_VERSION=cairo_pdf_required_version
|
||||
+GEGL_MAJOR_MINOR_VERSION=gegl_major_minor_version
|
||||
GEGL_REQUIRED_VERSION=gegl_required_version
|
||||
GEXIV2_REQUIRED_VERSION=gexiv2_required_version
|
||||
LCMS_REQUIRED_VERSION=lcms_required_version
|
||||
@@ -671,8 +675,8 @@ m4_define([add_deps_error], [
|
||||
|
||||
PKG_CHECK_MODULES(BABL, [babl >= babl_required_version],,
|
||||
[add_deps_error([babl >= babl_required_version])])
|
||||
-PKG_CHECK_MODULES(GEGL, gegl-0.4 >= gegl_required_version,,
|
||||
- [add_deps_error([gegl-0.4 >= gegl_required_version])])
|
||||
+PKG_CHECK_MODULES(GEGL, gegl-gegl_major_minor_version >= gegl_required_version,,
|
||||
+ [add_deps_error([gegl-gegl_major_minor_version >= gegl_required_version])])
|
||||
PKG_CHECK_MODULES(ATK, atk >= atk_required_version,,
|
||||
[add_deps_error([atk >= atk_required_version])])
|
||||
|
||||
diff --git a/gimp.pc.in b/gimp.pc.in
|
||||
index 9cf1da9..2e8d78c 100644
|
||||
--- a/gimp.pc.in
|
||||
+++ b/gimp.pc.in
|
||||
@@ -12,6 +12,6 @@ gimplocaledir=@gimplocaledir@
|
||||
Name: GIMP
|
||||
Description: GIMP Library
|
||||
Version: @GIMP_REAL_VERSION@
|
||||
-Requires: gdk-pixbuf-2.0 >= @GDK_PIXBUF_REQUIRED_VERSION@ cairo >= @CAIRO_REQUIRED_VERSION@ gegl-0.3 >= @GEGL_REQUIRED_VERSION@
|
||||
+Requires: gdk-pixbuf-2.0 >= @GDK_PIXBUF_REQUIRED_VERSION@ cairo >= @CAIRO_REQUIRED_VERSION@ gegl-@GEGL_MAJOR_MINOR_VERSION@ >= @GEGL_REQUIRED_VERSION@
|
||||
Libs: -L${libdir} -lgimp-@GIMP_API_VERSION@ -lgimpmath-@GIMP_API_VERSION@ -lgimpconfig-@GIMP_API_VERSION@ -lgimpcolor-@GIMP_API_VERSION@ -lgimpbase-@GIMP_API_VERSION@ @RT_LIBS@
|
||||
Cflags: -I${includedir}/gimp-@GIMP_API_VERSION@
|
74
extra/gimp/PKGBUILD
Normal file
74
extra/gimp/PKGBUILD
Normal file
|
@ -0,0 +1,74 @@
|
|||
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
||||
# Contributor: Daniel Isenmann <daniel@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - upstream patch to fix GEGL_MAJOR_MINOR_VERSION substitution
|
||||
|
||||
pkgname=gimp
|
||||
pkgver=2.10.0
|
||||
pkgrel=5.1
|
||||
pkgdesc='GNU Image Manipulation Program'
|
||||
url='https://www.gimp.org/'
|
||||
arch=('x86_64')
|
||||
license=('GPL' 'LGPL')
|
||||
depends=('pygtk' 'lcms' 'libxpm' 'libwmf' 'libxmu' 'librsvg' 'libmng' 'dbus-glib' 'libwebp'
|
||||
'libexif' 'gegl>=0.4' 'jasper' 'desktop-file-utils' 'hicolor-icon-theme' 'babl'
|
||||
'openexr' 'libgudev' 'poppler-data' 'libmypaint' 'mypaint-brushes' 'glib-networking')
|
||||
makedepends=('intltool' 'poppler-glib' 'alsa-lib' 'iso-codes' 'curl' 'ghostscript' 'gtk-doc')
|
||||
optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
|
||||
'poppler-glib: for pdf support'
|
||||
'alsa-lib: for MIDI event controller module'
|
||||
'curl: for URI support'
|
||||
'ghostscript: for postscript support')
|
||||
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
|
||||
0001-do-not-hardcode-gegl-version.patch
|
||||
https://github.com/GNOME/gimp/commit/245143532325783fb3414a74cbf58adc8a3199e8.patch
|
||||
linux.gpl
|
||||
uri-backend-libcurl.patch)
|
||||
sha256sums=('7fcc96fb88cb0a0595d2610f63a15dec245bb37bf9db527d37a24fb75e547de2'
|
||||
'1a52374e5db39d798297159afe2a9ea87460521c5f18a9c99729a9f5e25c4deb'
|
||||
'91a9a63f42791804be1bc60156ef348a93d5f6d35c86b4c50a76380886228bc8'
|
||||
'1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3'
|
||||
'0708a971455fba6406bfa190652797c6620c789a9d21012c57249d2d4878bd55')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
_mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
|
||||
sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
|
||||
patch -Np1 < ../0001-do-not-hardcode-gegl-version.patch
|
||||
patch -Np1 < ../245143532325783fb3414a74cbf58adc8a3199e8.patch
|
||||
autoreconf -vi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
PYTHON=/usr/bin/python2 ./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--enable-mp \
|
||||
--enable-gimp-console \
|
||||
--enable-gimp-remote \
|
||||
--enable-python \
|
||||
--enable-gtk-doc \
|
||||
--with-gif-compression=lzw \
|
||||
--with-libcurl \
|
||||
--without-aa \
|
||||
--without-hal \
|
||||
--without-gvfs \
|
||||
--without-gnomevfs
|
||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
|
||||
|
||||
rm "${pkgdir}/usr/share/man/man1/gimp-console.1"
|
||||
ln -s gimp-console-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
|
||||
ln -s gimptool-2.0 "${pkgdir}/usr/bin/gimptool"
|
||||
ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
19
extra/gimp/linux.gpl
Normal file
19
extra/gimp/linux.gpl
Normal file
|
@ -0,0 +1,19 @@
|
|||
GIMP Palette
|
||||
Name: linux
|
||||
#
|
||||
0 0 0
|
||||
0 0 170
|
||||
0 170 0
|
||||
0 170 170
|
||||
170 0 0
|
||||
170 0 170
|
||||
170 85 0
|
||||
170 170 170
|
||||
85 85 85
|
||||
85 85 255
|
||||
85 255 85
|
||||
85 255 255
|
||||
255 85 85
|
||||
255 85 255
|
||||
255 255 85
|
||||
255 255 255
|
77
extra/gimp/uri-backend-libcurl.patch
Normal file
77
extra/gimp/uri-backend-libcurl.patch
Normal file
|
@ -0,0 +1,77 @@
|
|||
diff -aur gimp-2.6.11/plug-ins/file-uri/uri-backend-libcurl.c gimp-2.6.11.patched/plug-ins/file-uri/uri-backend-libcurl.c
|
||||
--- gimp-2.6.11/plug-ins/file-uri/uri-backend-libcurl.c 2010-07-03 00:51:59.000000000 +0200
|
||||
+++ gimp-2.6.11.patched/plug-ins/file-uri/uri-backend-libcurl.c 2011-06-23 19:15:30.000000000 +0200
|
||||
@@ -4,9 +4,9 @@
|
||||
* libcurl backend for the URI plug-in
|
||||
* Copyright (C) 2006 Mukund Sivaraman <muks@mukund.org>
|
||||
*
|
||||
- * This program is free software; you can redistribute it and/or modify
|
||||
+ * This program is free software: you can redistribute it and/or modify
|
||||
* it under the terms of the GNU General Public License as published by
|
||||
- * the Free Software Foundation; either version 2 of the License, or
|
||||
+ * the Free Software Foundation; either version 3 of the License, or
|
||||
* (at your option) any later version.
|
||||
*
|
||||
* This program is distributed in the hope that it will be useful,
|
||||
@@ -15,8 +15,7 @@
|
||||
* GNU General Public License for more details.
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
- * along with this program; if not, write to the Free Software
|
||||
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
*/
|
||||
|
||||
#include "config.h"
|
||||
@@ -24,7 +23,6 @@
|
||||
#include <errno.h>
|
||||
|
||||
#include <curl/curl.h>
|
||||
-#include <curl/types.h>
|
||||
#include <curl/easy.h>
|
||||
|
||||
#include <glib/gstdio.h>
|
||||
@@ -63,7 +61,7 @@
|
||||
|
||||
vinfo = curl_version_info (CURLVERSION_NOW);
|
||||
|
||||
- protocols = g_string_new ("http:,ftp:");
|
||||
+ protocols = g_string_new ("http:,ftp:,gopher:");
|
||||
|
||||
if (vinfo->features & CURL_VERSION_SSL)
|
||||
{
|
||||
@@ -153,7 +151,7 @@
|
||||
FILE *out_file;
|
||||
CURL *curl_handle;
|
||||
CURLcode result;
|
||||
- gint response_code;
|
||||
+ glong response_code;
|
||||
|
||||
gimp_progress_init (_("Connecting to server"));
|
||||
|
||||
@@ -195,12 +193,12 @@
|
||||
|
||||
curl_easy_getinfo (curl_handle, CURLINFO_RESPONSE_CODE, &response_code);
|
||||
|
||||
- if (response_code != 200)
|
||||
+ if (response_code != 200 && response_code != 226 && response_code != 0)
|
||||
{
|
||||
fclose (out_file);
|
||||
g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_FAILED,
|
||||
_("Opening '%s' for reading resulted in HTTP "
|
||||
- "response code: %d"),
|
||||
+ "response code: %ld"),
|
||||
uri, response_code);
|
||||
curl_easy_cleanup (curl_handle);
|
||||
return FALSE;
|
||||
@@ -224,3 +222,10 @@
|
||||
|
||||
return FALSE;
|
||||
}
|
||||
+
|
||||
+gchar *
|
||||
+uri_backend_map_image (const gchar *uri,
|
||||
+ GimpRunMode run_mode)
|
||||
+{
|
||||
+ return NULL;
|
||||
+}
|
Loading…
Reference in a new issue